summarylogtreecommitdiffstats
path: root/gcc10.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gcc10.patch')
-rw-r--r--gcc10.patch87
1 files changed, 0 insertions, 87 deletions
diff --git a/gcc10.patch b/gcc10.patch
deleted file mode 100644
index cad51f61e1b9..000000000000
--- a/gcc10.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-commit 3a58245198d7ea9521e1a856111df27f22822cb6
-Author: egnappahz <egnappah@gmail.com>
-Date: Fri May 15 12:21:43 2020 +0200
-
- disable warning as errors for gcc10
-
- Signed-off-by: egnappahz <egnappah@gmail.com>
-
-diff --git a/Makefile b/Makefile
-index d252219666fd..d4938ac6ebbf 100644
---- a/Makefile
-+++ b/Makefile
-@@ -708,10 +708,6 @@ else ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
- KBUILD_CFLAGS += -Os
- endif
-
--ifdef CONFIG_CC_DISABLE_WARN_MAYBE_UNINITIALIZED
--KBUILD_CFLAGS += -Wno-maybe-uninitialized
--endif
--
- # Tell gcc to never replace conditional load with a non-conditional one
- KBUILD_CFLAGS += $(call cc-option,--param=allow-store-data-races=0)
-
-@@ -861,6 +857,9 @@ KBUILD_CFLAGS += -Wno-pointer-sign
- # disable stringop warnings in gcc 8+
- KBUILD_CFLAGS += $(call cc-disable-warning, stringop-truncation)
-
-+# Enabled with W=2, disabled by default as noisy
-+KBUILD_CFLAGS += $(call cc-disable-warning, maybe-uninitialized)
-+
- # disable invalid "can't wrap" optimizations for signed / pointers
- KBUILD_CFLAGS += $(call cc-option,-fno-strict-overflow)
-
-diff --git a/init/Kconfig b/init/Kconfig
-index 4f717bfdbfe2..ef59c5c36cdb 100644
---- a/init/Kconfig
-+++ b/init/Kconfig
-@@ -36,22 +36,6 @@ config TOOLS_SUPPORT_RELR
- config CC_HAS_ASM_INLINE
- def_bool $(success,echo 'void foo(void) { asm inline (""); }' | $(CC) -x c - -c -o /dev/null)
-
--config CC_HAS_WARN_MAYBE_UNINITIALIZED
-- def_bool $(cc-option,-Wmaybe-uninitialized)
-- help
-- GCC >= 4.7 supports this option.
--
--config CC_DISABLE_WARN_MAYBE_UNINITIALIZED
-- bool
-- depends on CC_HAS_WARN_MAYBE_UNINITIALIZED
-- default CC_IS_GCC && GCC_VERSION < 40900 # unreliable for GCC < 4.9
-- help
-- GCC's -Wmaybe-uninitialized is not reliable by definition.
-- Lots of false positive warnings are produced in some cases.
--
-- If this option is enabled, -Wno-maybe-uninitialzed is passed
-- to the compiler to suppress maybe-uninitialized warnings.
--
- config CONSTRUCTORS
- bool
- depends on !UML
-@@ -1249,14 +1233,12 @@ config CC_OPTIMIZE_FOR_PERFORMANCE
- config CC_OPTIMIZE_FOR_PERFORMANCE_O3
- bool "Optimize more for performance (-O3)"
- depends on ARC
-- imply CC_DISABLE_WARN_MAYBE_UNINITIALIZED # avoid false positives
- help
- Choosing this option will pass "-O3" to your compiler to optimize
- the kernel yet more for performance.
-
- config CC_OPTIMIZE_FOR_SIZE
- bool "Optimize for size (-Os)"
-- imply CC_DISABLE_WARN_MAYBE_UNINITIALIZED # avoid false positives
- help
- Choosing this option will pass "-Os" to your compiler resulting
- in a smaller kernel.
-diff --git a/kernel/trace/Kconfig b/kernel/trace/Kconfig
-index 402eef84c859..743647005f64 100644
---- a/kernel/trace/Kconfig
-+++ b/kernel/trace/Kconfig
-@@ -466,7 +466,6 @@ config PROFILE_ANNOTATED_BRANCHES
- config PROFILE_ALL_BRANCHES
- bool "Profile all if conditionals" if !FORTIFY_SOURCE
- select TRACE_BRANCH_PROFILING
-- imply CC_DISABLE_WARN_MAYBE_UNINITIALIZED # avoid false positives
- help
- This tracer profiles all branch conditions. Every if ()
- taken in the kernel is recorded whether it hit or miss.