summarylogtreecommitdiffstats
path: root/geary-enchant2.patch
diff options
context:
space:
mode:
Diffstat (limited to 'geary-enchant2.patch')
-rw-r--r--geary-enchant2.patch5
1 files changed, 2 insertions, 3 deletions
diff --git a/geary-enchant2.patch b/geary-enchant2.patch
index 364f24fd57f0..07bc0c98db95 100644
--- a/geary-enchant2.patch
+++ b/geary-enchant2.patch
@@ -1,7 +1,7 @@
diff --u a/meson.build b/meson.build
--- a/meson.build
+++ b/meson.build
-@@ -51,7 +51,18 @@
+@@ -51,7 +51,17 @@
webkit2gtk = dependency('webkit2gtk-4.0', version: '>=' + target_webkit)
# Secondary deps - keep sorted alphabetically
@@ -11,10 +11,9 @@ diff --u a/meson.build b/meson.build
+ dependency('enchant-2', version: '>= 1.6')
+ enchant = valac.find_library(
+ 'enchant',
-+ dirs: '/usr/share/vala-0.40/vapi/',
+ required: true
+ )
-+ # TODO These arguments should be applied more specifically
++ # TODO These arguments should be only applied where actually needed.
+ add_project_arguments('-I/usr/include/enchant-2/', language : 'c')
+ add_project_link_arguments('-lenchant-2', language : 'c')
+endif