summarylogtreecommitdiffstats
path: root/genlogo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'genlogo.patch')
-rw-r--r--genlogo.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/genlogo.patch b/genlogo.patch
new file mode 100644
index 000000000000..f7392109642d
--- /dev/null
+++ b/genlogo.patch
@@ -0,0 +1,23 @@
+diff --git a/logo/Makefile b/logo/Makefile
+index 5b33d9c..115837e 100644
+--- a/logo/Makefile
++++ b/logo/Makefile
+@@ -4,10 +4,17 @@ WIDTH := 200
+ HEIGHT := 200
+ ADDITIONAL_OPTS :=
+
++INKSCAPE_VERSION_MAIN = $(shell inkscape --version 2>/dev/null | grep -e 'Inkscape\s*[0-9.]\+' | sed -e 's#^.*Inkscape\s*\([0-9]\+\)\..*$$#\1#')
++ifeq ($(INKSCAPE_VERSION_MAIN),0)
++ INKSCAPE_EXPORT_PNG_OPT = --export-png
++else
++ INKSCAPE_EXPORT_PNG_OPT = --export-filename
++endif
++
+ all: $(OUT_NAME)
+
+ %.png: logo.svg
+- $(INKSCAPE) --export-png=$@ $(ADDITIONAL_OPTS) --export-area-drawing --export-width=$(WIDTH) --export-height=$(HEIGHT) $<
++ $(INKSCAPE) $(INKSCAPE_EXPORT_PNG_OPT)=$@ $(ADDITIONAL_OPTS) --export-area-drawing --export-width=$(WIDTH) --export-height=$(HEIGHT) $<
+
+ clean:
+ rm -f $(OUT_NAME)