summarylogtreecommitdiffstats
path: root/harden.patch
diff options
context:
space:
mode:
Diffstat (limited to 'harden.patch')
-rw-r--r--harden.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/harden.patch b/harden.patch
new file mode 100644
index 000000000000..9a13e5dace0d
--- /dev/null
+++ b/harden.patch
@@ -0,0 +1,24 @@
+Author: Andreas Tille <tille@debian.org>
+Last-Update: Mon, 11 May 2020 16:16:46 +0200
+Description: Propagate hardening flags
+
+--- a/c/Makefile
++++ b/c/Makefile
+@@ -6,7 +6,7 @@ CC = gcc -O3 -DALLELECOUNTER_VERSION='"$
+ #compiler flags
+ # -g adds debug info to the executable file
+ # -Wall turns on most warnings from compiler
+-CFLAGS = -g -Wall
++CFLAGS += -g -Wall
+
+ #Location of samtools/htslib libraries
+ HTSLOC?=$(HTSLIB)
+@@ -67,7 +67,7 @@ all: clean make_bin make_htslib_tmp $(CO
+ @echo Binaries have been compiled.
+
+ $(COUNTER_TARGET): $(OBJS)
+- $(CC) $(JOIN_INCLUDES) $(INCLUDES) $(CFLAGS) -o $(COUNTER_TARGET) $(OBJS) $(LFLAGS) $(CAT_LFLAGS) $(LIBS) ./src/alleleCounter.c
++ $(CC) $(JOIN_INCLUDES) $(INCLUDES) $(CFLAGS) -o $(COUNTER_TARGET) $(OBJS) $(LFLAGS) $(CAT_LFLAGS) $(LIBS) ./src/alleleCounter.c $(LDFLAGS)
+
+ #Unit Tests
+ test: $(COUNTER_TARGET) \ No newline at end of file