summarylogtreecommitdiffstats
path: root/llvm15.patch
diff options
context:
space:
mode:
Diffstat (limited to 'llvm15.patch')
-rw-r--r--llvm15.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/llvm15.patch b/llvm15.patch
new file mode 100644
index 000000000000..47094d525b8d
--- /dev/null
+++ b/llvm15.patch
@@ -0,0 +1,39 @@
+--- a/CMakeLists.txt 2023-02-06 01:05:30.000000000 +0100
++++ b/CMakeLists.txt 2023-03-17 16:28:27.484191793 +0100
+@@ -348,34 +348,14 @@
+ AllTargetsCodeGens
+ AllTargetsDescs
+ AllTargetsInfos
+- AggressiveInstCombine
+- Analysis
+- AsmParser
+- BitWriter
+- CodeGen
+- Core
+- Extensions
+- IPO
+- IRReader
+- InstCombine
+- Instrumentation
+- MC
+- MCJIT
+- ObjCARCOpts
+- OrcJIT
+- Remarks
+- ScalarOpts
+ Support
+- Symbolize
+- Target
+- TransformUtils
+- Vectorize
+- Passes)
++ )
+ if(APPLE)
+ target_link_libraries(codonc PRIVATE ${LLVM_LIBS} fmt dl codonrt)
+ else()
+ target_link_libraries(codonc PRIVATE ${STATIC_LIBCPP} ${LLVM_LIBS} fmt dl codonrt)
+ endif()
++target_link_libraries (codonc PUBLIC LLVM)
+
+ # Gather headers
+ add_custom_target(