summarylogtreecommitdiffstats
path: root/nopic.patch
diff options
context:
space:
mode:
Diffstat (limited to 'nopic.patch')
-rw-r--r--nopic.patch51
1 files changed, 0 insertions, 51 deletions
diff --git a/nopic.patch b/nopic.patch
deleted file mode 100644
index 2d302f535eec..000000000000
--- a/nopic.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From 672949d6c61d9cba01c5b414eed9d522082f04d3 Mon Sep 17 00:00:00 2001
-From: Olaf Hering <olaf@aepfle.de>
-Date: Mon, 26 Jun 2017 14:55:07 +0200
-Subject: [PATCH] rombios: prevent building with PIC/PIE
-
-If the default compiler silently defaults to to -fPIC/-fPIE building
-rombios fails:
-
- ld -melf_i386 -s -r 32bitbios.o tcgbios/tcgbiosext.o util.o pmm.o -o 32bitbios_all.o
- There are undefined symbols in the BIOS:
- U _GLOBAL_OFFSET_TABLE_
- make[10]: *** [Makefile:26: 32bitbios_all.o] Error 11
-
-Prevent the failure by enforcing non-PIC/PIE mode.
-
-Signed-off-by: Olaf Hering <olaf@aepfle.de>
-Acked-by: Andrew Cooper <andrew.cooper3@citrix.com>
----
- tools/firmware/rombios/32bit/Makefile | 2 ++
- tools/firmware/rombios/32bit/tcgbios/Makefile | 2 ++
- 2 files changed, 4 insertions(+)
-
-diff --git a/tools/firmware/rombios/32bit/Makefile b/tools/firmware/rombios/32bit/Makefile
-index b0583c9..28c1544 100644
---- a/tools/firmware/rombios/32bit/Makefile
-+++ b/tools/firmware/rombios/32bit/Makefile
-@@ -4,6 +4,8 @@ include $(XEN_ROOT)/tools/firmware/Rules.mk
- TARGET = 32bitbios_flat.h
-
- CFLAGS += $(CFLAGS_xeninclude) -I.. -I../../../libacpi
-+$(call cc-option-add,CFLAGS,CC,-fno-pic)
-+$(call cc-option-add,CFLAGS,CC,-fno-PIE)
-
- SUBDIRS = tcgbios
-
-diff --git a/tools/firmware/rombios/32bit/tcgbios/Makefile b/tools/firmware/rombios/32bit/tcgbios/Makefile
-index f87d130..5cff4ef 100644
---- a/tools/firmware/rombios/32bit/tcgbios/Makefile
-+++ b/tools/firmware/rombios/32bit/tcgbios/Makefile
-@@ -4,6 +4,8 @@ include $(XEN_ROOT)/tools/firmware/Rules.mk
- TARGET = tcgbiosext.o
-
- CFLAGS += $(CFLAGS_xeninclude) -I.. -I../.. -I../../../../libacpi
-+$(call cc-option-add,CFLAGS,CC,-fno-pic)
-+$(call cc-option-add,CFLAGS,CC,-fno-PIE)
-
- .PHONY: all
- all: $(TARGET)
---
-2.1.4
-