summarylogtreecommitdiffstats
path: root/smesh-pthread.patch
diff options
context:
space:
mode:
Diffstat (limited to 'smesh-pthread.patch')
-rw-r--r--smesh-pthread.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/smesh-pthread.patch b/smesh-pthread.patch
new file mode 100644
index 000000000000..3497015488cd
--- /dev/null
+++ b/smesh-pthread.patch
@@ -0,0 +1,18 @@
+--- a/src/3rdParty/salomesmesh/CMakeLists.txt 2018-04-06 10:48:37.000000000 +0200
++++ a/src/3rdParty/salomesmesh/CMakeLists.txt 2018-04-06 10:48:37.000000000 +0200
+@@ -85,6 +85,7 @@
+ else(MSVC)
+ if(BUILD_FEM_NETGEN)
+ set(SMESH_LIBS
++ pthread
+ ${NGLIB_LIBRARIES}
+ ${OCC_LIBRARIES}
+ ${OCC_OCAF_LIBRARIES}
+@@ -92,6 +93,7 @@
+ ADD_DEFINITIONS(${NETGEN_DEFINITIONS})
+ else(BUILD_FEM_NETGEN)
+ set(SMESH_LIBS
++ pthread
+ ${OCC_LIBRARIES}
+ ${OCC_OCAF_LIBRARIES}
+ )