summarylogtreecommitdiffstats
path: root/ssl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'ssl.patch')
-rw-r--r--ssl.patch34
1 files changed, 17 insertions, 17 deletions
diff --git a/ssl.patch b/ssl.patch
index e7101f79a8d4..b1ef69503586 100644
--- a/ssl.patch
+++ b/ssl.patch
@@ -1,25 +1,25 @@
diff --git a/src/cpp/core/CMakeLists.txt b/src/cpp/core/CMakeLists.txt
-index 5803988968..eb8d4d5efd 100644
+index 3990f893d3..d5b390dacf 100644
--- a/src/cpp/core/CMakeLists.txt
+++ b/src/cpp/core/CMakeLists.txt
-@@ -201,8 +201,12 @@ if (UNIX)
+@@ -202,8 +202,12 @@ if (UNIX)
endif()
if(RSTUDIO_SERVER)
- find_package(OpenSSL REQUIRED QUIET)
-+ #find_package(OpenSSL REQUIRED QUIET)
++ #find_package(OpenSSL REQUIRED QUIET)
find_package(PAM REQUIRED)
+ find_library(SSL ssl PATHS /usr/lib/openssl-1.0)
+ find_library(CRYPTO crypto PATHS /usr/lib/openssl-1.0)
-+ set(OPENSSL_INCLUDE_DIRS /usr/include/openssl-1.0)
-+ set(OPENSSL_LIBRARIES /usr/lib/openssl-1.0/libssl.so /usr/lib/openssl-1.0/libcrypto.so)
++ set(OPENSSL_INCLUDE_DIRS /usr/include/openssl-1.0)
++ set(OPENSSL_LIBRARIES /usr/lib/openssl-1.0/libssl.so /usr/lib/openssl-1.0/libcrypto.so)
set(CORE_SYSTEM_LIBRARIES
${CORE_SYSTEM_LIBRARIES}
${OPENSSL_LIBRARIES}
-diff --git a/src/cpp/core/system/PosixCrypto.cpp b/src/cpp/core/system/PosixCrypto.cpp
-index 2e4c01bb12..9653edb244 100644
---- a/src/cpp/core/system/PosixCrypto.cpp
-+++ b/src/cpp/core/system/PosixCrypto.cpp
+diff --git a/src/cpp/core/system/Crypto.cpp b/src/cpp/core/system/Crypto.cpp
+index da286d2950..4569e8ba07 100644
+--- a/src/cpp/core/system/Crypto.cpp
++++ b/src/cpp/core/system/Crypto.cpp
@@ -18,14 +18,14 @@
#include <fcntl.h>
@@ -32,14 +32,14 @@ index 2e4c01bb12..9653edb244 100644
-#include <openssl/pem.h>
-#include <openssl/rand.h>
-#include <openssl/rsa.h>
-+#include <openssl-1.0/openssl/err.h>
-+#include <openssl-1.0/openssl/hmac.h>
-+#include <openssl-1.0/openssl/bio.h>
-+#include <openssl-1.0/openssl/buffer.h>
-+#include <openssl-1.0/openssl/evp.h>
-+#include <openssl-1.0/openssl/pem.h>
-+#include <openssl-1.0/openssl/rand.h>
-+#include <openssl-1.0/openssl/rsa.h>
++#include <openssl-1.0/openssl//err.h>
++#include <openssl-1.0/openssl//hmac.h>
++#include <openssl-1.0/openssl//bio.h>
++#include <openssl-1.0/openssl//buffer.h>
++#include <openssl-1.0/openssl//evp.h>
++#include <openssl-1.0/openssl//pem.h>
++#include <openssl-1.0/openssl//rand.h>
++#include <openssl-1.0/openssl//rsa.h>
#include <algorithm>