summarylogtreecommitdiffstats
path: root/use-system-libs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'use-system-libs.patch')
-rw-r--r--use-system-libs.patch5
1 files changed, 3 insertions, 2 deletions
diff --git a/use-system-libs.patch b/use-system-libs.patch
index ec33785674a9..9f1adbeb47ba 100644
--- a/use-system-libs.patch
+++ b/use-system-libs.patch
@@ -38,7 +38,7 @@ index 38127c9809..b7fb0d9e16 100644
genconfig = declare_dependency(include_directories: 'genconfig')
diff --git a/ui/thirdparty/meson.build b/ui/thirdparty/meson.build
-index ad01b58932..11e37d9839 100644
+index ad01b58932..deb07ce5d5 100644
--- a/ui/thirdparty/meson.build
+++ b/ui/thirdparty/meson.build
@@ -60,8 +60,8 @@ endif
@@ -50,7 +50,8 @@ index ad01b58932..11e37d9839 100644
+json = dependency('nlohmann_json')
+httplib = dependency('httplib')
- libfatx = static_library('fatx', sources: 'fatx/fatx.c')
+-libfatx = static_library('fatx', sources: 'fatx/fatx.c')
++libfatx = static_library('fatx', sources: files('fatx/fatx.c') + genh)
fatx = declare_dependency(include_directories: 'fatx', link_with: libfatx)
diff --git a/ui/xui/reporting.cc b/ui/xui/reporting.cc
index 992d5da0a7..b9a538e07a 100644