summarylogtreecommitdiffstats
path: root/xen_gcc10_1_omnibus.patch
diff options
context:
space:
mode:
Diffstat (limited to 'xen_gcc10_1_omnibus.patch')
-rw-r--r--xen_gcc10_1_omnibus.patch115
1 files changed, 0 insertions, 115 deletions
diff --git a/xen_gcc10_1_omnibus.patch b/xen_gcc10_1_omnibus.patch
deleted file mode 100644
index 64fcb519f103..000000000000
--- a/xen_gcc10_1_omnibus.patch
+++ /dev/null
@@ -1,115 +0,0 @@
-diff -Naur orig/stubdom/Makefile changed/stubdom/Makefile
---- orig/stubdom/Makefile 2020-05-14 05:19:32.000000000 -0700
-+++ changed/stubdom/Makefile 2020-05-20 12:06:15.266666457 -0700
-@@ -231,6 +231,7 @@
- patch -d $@ -p1 < vtpm-cmake-Wextra.patch
- patch -d $@ -p1 < vtpm-implicit-fallthrough.patch
- patch -d $@ -p1 < vtpm_TPM_ChangeAuthAsymFinish.patch
-+ patch -d $@ -p1 < vtpm_gcc10_1.patch
- mkdir $@/build
- cd $@/build; CC=${CC} $(CMAKE) .. -DCMAKE_C_FLAGS:STRING="-std=c99 -DTPM_NO_EXTERN $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -Wno-declaration-after-statement"
- touch $@
-diff -Naur orig/stubdom/vtpm_gcc10_1.patch changed/stubdom/vtpm_gcc10_1.patch
---- orig/stubdom/vtpm_gcc10_1.patch 1969-12-31 16:00:00.000000000 -0800
-+++ changed/stubdom/vtpm_gcc10_1.patch 2020-05-20 12:04:59.593333123 -0700
-@@ -0,0 +1,48 @@
-+diff -Naur orig/tpm/tpm_emulator_extern.h changed/tpm/tpm_emulator_extern.h
-+--- orig/tpm/tpm_emulator_extern.h 2020-05-20 11:58:56.533333115 -0700
-++++ changed/tpm/tpm_emulator_extern.h 2020-05-20 11:50:57.153333124 -0700
-+@@ -29,7 +29,7 @@
-+ TPM_LOG_ERROR
-+ };
-+
-+-void (*tpm_log)(int priority, const char *fmt, ...);
-++extern void (*tpm_log)(int priority, const char *fmt, ...);
-+
-+ #if defined(_WIN32) || defined(_WIN64)
-+ #define __BFILE__ ((strrchr(__FILE__, '\\') ? : __FILE__ - 1) + 1)
-+@@ -44,27 +44,27 @@
-+ #define error(fmt, ...) tpm_log(TPM_LOG_ERROR, "%s:%d: Error: " fmt "\n", \
-+ __BFILE__, __LINE__, ## __VA_ARGS__)
-+ /* initialization */
-+-int (*tpm_extern_init)(void);
-+-void (*tpm_extern_release)(void);
-++extern int (*tpm_extern_init)(void);
-++extern void (*tpm_extern_release)(void);
-+
-+ /* memory allocation */
-+
-+-void* (*tpm_malloc)(size_t size);
-++extern void* (*tpm_malloc)(size_t size);
-+
-+-void (*tpm_free)(/*const*/ void *ptr);
-++extern void (*tpm_free)(/*const*/ void *ptr);
-+
-+ /* random numbers */
-+
-+-void (*tpm_get_extern_random_bytes)(void *buf, size_t nbytes);
-++extern void (*tpm_get_extern_random_bytes)(void *buf, size_t nbytes);
-+
-+ /* usec since last call */
-+
-+-uint64_t (*tpm_get_ticks)(void);
-++extern uint64_t (*tpm_get_ticks)(void);
-+
-+ /* file handling */
-+
-+-int (*tpm_write_to_storage)(uint8_t *data, size_t data_length);
-+-int (*tpm_read_from_storage)(uint8_t **data, size_t *data_length);
-++extern int (*tpm_write_to_storage)(uint8_t *data, size_t data_length);
-++extern int (*tpm_read_from_storage)(uint8_t **data, size_t *data_length);
-+
-+ #endif /* _TPM_EMULATOR_EXTERN_H_ */
-+
-diff -Naur orig/stubdom/vtpmmgr/vtpmmgr.h changed/stubdom/vtpmmgr/vtpmmgr.h
---- orig/stubdom/vtpmmgr/vtpmmgr.h 2020-05-14 05:19:32.000000000 -0700
-+++ changed/stubdom/vtpmmgr/vtpmmgr.h 2020-05-20 12:04:28.506666463 -0700
-@@ -50,7 +50,7 @@
- #define RSA_KEY_SIZE 0x0800
- #define RSA_CIPHER_SIZE (RSA_KEY_SIZE / 8)
-
--enum {
-+extern enum {
- TPM1_HARDWARE = 1,
- TPM2_HARDWARE,
- } tpm_version;
-diff -Naur orig/tools/firmware/etherboot/patches/ipxe_gcc10_1.patch changed/tools/firmware/etherboot/patches/ipxe_gcc10_1.patch
---- orig/tools/firmware/etherboot/patches/ipxe_gcc10_1.patch 1969-12-31 16:00:00.000000000 -0800
-+++ changed/tools/firmware/etherboot/patches/ipxe_gcc10_1.patch 2020-05-20 12:06:53.043333126 -0700
-@@ -0,0 +1,30 @@
-+diff --git a/src/Makefile.housekeeping b/src/Makefile.housekeeping
-+index 1dd14794..8aaa2754 100644
-+--- a/src/Makefile.housekeeping
-++++ b/src/Makefile.housekeeping
-+@@ -130,7 +130,7 @@ eval :
-+ # Check for various tool workarounds
-+ #
-+
-+-WORKAROUND_CFLAGS :=
-++WORKAROUND_CFLAGS := -Wno-array-bounds -Wno-enum-conversion
-+ WORKAROUND_ASFLAGS :=
-+ WORKAROUND_LDFLAGS :=
-+
-+@@ -170,6 +170,16 @@ CFI_FLAGS := $(shell $(CFI_TEST) && \
-+ WORKAROUND_CFLAGS += $(CFI_FLAGS)
-+ endif
-+
-++# gcc 10 switched default behavior from -fcommon to -fno-common. Since
-++# "__shared" relies on the legacy behavior, explicitly specify it.
-++#
-++ifeq ($(CCTYPE),gcc)
-++FCOMMON_TEST = $(CC) -fcommon -x c -c /dev/null \
-++ -o /dev/null >/dev/null 2>&1
-++FCOMMON_FLAGS := $(shell $(FCOMMON_TEST) && $(ECHO) '-fcommon')
-++WORKAROUND_CFLAGS += $(FCOMMON_FLAGS)
-++endif
-++
-+ # gcc 4.6 generates spurious warnings if -Waddress is in force.
-+ # Inhibit this.
-+ #
-diff -Naur orig/tools/firmware/etherboot/patches/series changed/tools/firmware/etherboot/patches/series
---- orig/tools/firmware/etherboot/patches/series 2020-05-14 05:19:32.000000000 -0700
-+++ changed/tools/firmware/etherboot/patches/series 2020-05-20 12:13:35.533333130 -0700
-@@ -1 +1,2 @@
- boot_prompt_option.patch
-+ipxe_gcc10_1.patch