summarylogtreecommitdiffstats
path: root/PKGBUILD
blob: 3c3cc1a2e8847bab6410272f85e452f0f1e31576 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
# Maintainer: Chris Severance aur.severach AatT spamgourmet.com
# Contributor: Chris Fordham <chris at fordham-nagy dot id dot au> aka flaccid
# Contributor: Alper KANAT <alperkanat@raptiye.org>
# Package Source: https://github.com/flaccid/archlinux-packages/blob/master/aws-cli/PKGBUILD

# This package is designed so that these PKGBUILD are easy to sync with Midnight Commander:
#  aws-cli & aws-cli-git
#  python-botocore & python-botocore-git

# TODO: put tox back into depends

# Use mcdiff to watch for changes
_fn_foobar() {
local _foobar="
#requirements-docs.txt
Sphinx==1.1.3
#requirements.txt
tox>=2.3.1,<3.0.0
docutils>=0.10
# botocore and the awscli packages are typically developed
# in tandem, so we're requiring the latest develop
# branch of botocore when working on the awscli.
-e git://github.com/boto/botocore.git@develop#egg=botocore
-e git://github.com/boto/s3transfer.git@develop#egg=s3transfer
-e git://github.com/boto/jmespath.git@develop#egg=jmespath
nose==1.3.7
colorama>=0.2.5,<=0.3.9
mock==1.3.0
rsa>=3.1.2,<=3.5.0
wheel==0.24.0
PyYAML>=3.10,<=3.13

#setup.py
import awscli


requires = ['botocore==1.12.156',
            'colorama>=0.2.5,<=0.3.9',
            'docutils>=0.10',
            'rsa>=3.1.2,<=3.5.0',
            's3transfer>=0.2.0,<0.3.0',
            'PyYAML>=3.10,<=3.13']
"
}
unset -f _fn_foobar

set -u
_pyver="python2"
_pybase='aws-cli'
if [ "${_pyver}" = 'python' ]; then
pkgname="${_pybase}"
_pyverother='python2'
else
pkgname="${_pyver}-${_pybase}"
_pyverother='python'
fi
pkgver=1.16.248
# Generally when this version changes, the version of botocore also changes
pkgrel=1
pkgdesc='Universal Command Line Interface for Amazon Web Services awscli'
arch=('any')
url="https://github.com/aws/${_pybase}"
license=('Apache') # Apache License 2.0
_pydepends=( # See setup.py, README.rst, and requirements.txt for version dependencies
  "${_pyver}-bcdoc"           # AUR
  "${_pyver}-botocore>=1.12.156" # COM ==
  "${_pyver}-colorama>=0.2.5" #,"<=0.3.7"}   # COM requested by phw
  "${_pyver}-rsa"{'>=3.2','<=3.5.0'}
  "${_pyver}-s3transfer"{'>=0.2.0','<0.3.0'} # COM

  ### These are from python-botocore
  "${_pyver}-wheel>=0.24.0"   # COM ==
  "${_pyver}-dateutil"{">=2.1","<3.0.0"} # COM
  "${_pyver}-jmespath>=0.7.1" # COM ==
  #"${_pyver}-tox"{'>=2.3.1','<3.0.0'} # COM
  "${_pyver}-yaml"{">=3.10","<=3.13"} # COM
  "${_pyver}-nose>=1.3.7"     # COM ==
  "${_pyver}-mock>=1.3.0"     # COM ==
  "${_pyver}-docutils>=0.10"  # COM
  "${_pyver}-six>=1.1.0"      # COM This is in the sources but I'm not sure where the version comes from.
  # requirements-docs.txt
  #"${_pyver}-sphinx>=1.1.3" #"${_pyver}-sphinx"{>=1.1.3,<1.3}     # COM Arch is already newer. Documentation might not work.
  "${_pyver}-guzzle-sphinx-theme"{'>=0.7.10','<0.8'}
)
if [ "${_pyver}" = 'python2' ]; then
  _pydepends+=('python2-futures')
fi
depends=("${_pyver}" "${_pydepends[@]}")
makedepends=("${_pyver}" "${_pyver}-distribute") # same as python-setuptools
options=('!emptydirs' '!strip')
source=("${_pybase}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
sha256sums=('000bc49d5bbab420fae22ef5f9d7732e4e834e08e240e32fa1357809b06c61b4')

if [ "${pkgname%-git}" != "${pkgname}" ]; then # this is easily done with case
  _srcdir="${_pybase}"
  makedepends+=('git')
  _vcsprovides=("${pkgname%-git}=${pkgver%%.r*}")
  _vcsconflicts=("${pkgname%-git}")
  source=("${_srcdir}::${url//https:/git:}.git")
  :;sha256sums=('SKIP')
pkgver() {
  set -u
  cd "${_srcdir}"
  printf '%s.r%s.g%s' "$(sed -ne "s:__version__ = '\(.*\)'"'$:\1:p' 'awscli/__init__.py')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" # "
  set +u
}
else
  _srcdir="${_pybase}-${pkgver}"
#  _verwatch=("${url}/releases" "${url#*github.com}/archive/\(.*\)\.tar\.gz" 'l')
  _vcsprovides=()
  _vcsconflicts=()
fi

build() {
  set -u
  cd "${_srcdir}"
  ${_pyver} setup.py build
  set +u
}

check() {
  set -u
  cd "${_srcdir}"
  # If pip is installed, some package tests download missing packages. We can't allow that.
  #${_pyver} setup.py test --verbose
  set +u
}

package() {
  set +u
  provides=("${_pybase}=${pkgver%%.r*}" "${_vcsprovides[@]}")
  conflicts=("${_pyverother}-aws-cli" "${_pyver}-aws-cli" "${_pybase}" "${_vcsconflicts[@]}")
  set -u
  #depends=("${_pyver}" "${_pydepends[@]}")
  #replaces=("${_pyver}-aws-cli" "${_pybase//-/}")

  cd "${_srcdir}"
  ${_pyver} setup.py install --root="${pkgdir}" --optimize=1
  install -Dpm644 'bin/aws_zsh_completer.sh' "${pkgdir}/etc/zsh/aws_complete.zsh" # someone dropped an s. I don't know if I can change it safely.

  install -Dpm644 <(cat << EOF
# ${pkgname} ${pkgver} bash completion script
# https://aur.archlinux.org/
complete -C aws_completer aws
EOF
) "${pkgdir}/usr/share/bash-completion/completions/${pkgname%-git}"

  install -Dpm644 'README.rst' 'requirements.txt' -t "${pkgdir}/usr/share/doc/${pkgname%-git}/"
  install -Dpm644 'LICENSE.txt' "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
  set +u
}
set +u
# vim:set ts=2 sw=2 et: