Package Details: amule-daemon r10941-1

Git Clone URL: https://aur.archlinux.org/amule-daemon.git (read-only)
Package Base: amule-daemon
Description: An eMule-like client for the eD2k and Kademlia p2p networks. (Only Daemon, CLI tools and Webserver)
Upstream URL: http://www.amule.org
Licenses: GPL
Conflicts: amule
Submitter: sl1pkn07
Maintainer: sl1pkn07
Last Packager: sl1pkn07
Votes: 5
Popularity: 0.907471
First Submitted: 2013-02-18 11:07
Last Updated: 2016-07-31 07:55

Dependencies (8)

Required by (1)

Sources (5)

Latest Comments

Bitl0rd commented on 2016-07-31 04:18

link dead , aMule-SVN-r10941.tar.bz2

sl1pkn07 commented on 2016-04-11 13:50

you can modify the pkgbuild to adapt to wxgtk(2.8). but is not supported by me in this package

Bitl0rd commented on 2016-04-11 04:58

wxbase2.8 y wxgtk in confict.

audacity, kicad, wxpython etc, has wxGTK dependence. there is no way that amule-daemon work with wxGTK?

sl1pkn07 commented on 2015-11-30 21:02

try now

ThecaTTony commented on 2015-11-30 20:12

Hi, the install file fails with:

-> Service' amule@' (by user) can be started as 'systemctl start amule@'.
/tmp/alpm_KBD87u/.INSTALL: line 15: $'\E(B\E[m\E[1m\E[34m-': command not found
error: command failed to execute correctly

Line 15:
${blue}->${all_off} Service '${bold}amuleweb${all_off}' can be started as '${bold}systemctl start amuleweb${all_off}'.\n".\n"

Besides that, could you please add armv7h as ARCH? Thanks.

sl1pkn07 commented on 2015-02-10 15:29

edit the /etc/wx/config-2.8 and comment out '#wx=base-unicode-release-2.8' and comment 'wx=gtk2-unicode-release-2.8'

or use --with-wx-config=/usr/lib/wx/config/base-unicode-release-2.8

sl1pkn07 commented on 2015-02-10 15:25

edit the /etc/wx/config-2.8 and comment out '#wx=base-unicode-release-2.8' and comment 'wx=gtk2-unicode-release-2.8'

DarkElf commented on 2015-02-10 15:06

After adding the line:
--with-wx-config=/usr/bin/wx-config-2.8
to the PKGBUILD (which is necessary)
makepkg shows this error:

checking for the --with-wxversion option... 2.8
checking for wx-config... /usr/bin/wx-config-2.8
checking for wxWidgets version >= 2.8.12 (--unicode=yes --toolkit=base --version=2.8)... no
configure: error:
The requested wxWidgets build couldn't be found.

The configuration you asked for aMule requires a wxWidgets
build with the following settings:
--unicode=yes --toolkit=base --version=2.8
but such build is not available.

To see the wxWidgets builds available on this system, please use
'wx-config --list' command. To use the default build, returned by
'wx-config --selected-config', use the options with their 'auto'
default values.

If you still get this error, then check that 'wx-config' is
in path, the directory where wxWidgets libraries are installed
(returned by 'wx-config --libs' command) is in LD_LIBRARY_PATH
or equivalent variable and wxWidgets version is 2.8.12 or above.

Any solution?
Thanks

sl1pkn07 commented on 2014-03-11 20:29

hi, i've make several changes

now "amuled" user is deprecated, now user ir "amule" (like a arch package)
new amuleweb.service is created

see post_update/post_install instructions


greetings

sl1pkn07 commented on 2014-01-08 17:14

@PerfectGentleman

http://amule.forumer.com/fail-build-if-wxgtk-is-build-with-enable-stl-t2348153.html

All comments