Package Details: asciinema-git 1.0.0.r8.g365b36c-2

Git Clone URL: https://aur.archlinux.org/asciinema-git.git (read-only)
Package Base: asciinema-git
Description: Record and share your terminal sessions, the right way
Upstream URL: https://github.com/sickill/asciinema
Licenses: MIT
Conflicts: asciinema
Submitter: sudokode
Maintainer: sudokode
Last Packager: sudokode
Votes: 7
Popularity: 0.000000
First Submitted: 2013-10-18 15:28
Last Updated: 2015-08-16 05:21

Dependencies (2)

Required by (0)

Sources (1)

Latest Comments

AK_IL commented on 2016-10-17 17:07

I have added a stable python package:
https://aur.archlinux.org/packages/python-asciinema/
Maybe I will fix this one up for newer features.

AK_IL commented on 2016-10-17 16:42

makepkg doesn't work, the output:

[alex@archlinux asciinema-git]$ makepkg
==> Making package: asciinema-git 1.0.0.r8.g365b36c-2 (Mon Oct 17 19:41:23 IDT 2016)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Updating asciinema-git git repo...
Fetching origin
==> Validating source files with sha256sums...
asciinema-git ... Skipped
==> Extracting sources...
-> Creating working copy of asciinema git repo...
Switched to a new branch 'makepkg'
==> Starting prepare()...
can't load package: package .: no buildable Go source files in /home/alex/Downloads/asciinema-git/src/asciinema-git
==> ERROR: A failure occurred in prepare().
Aborting...
[alex@archlinux asciinema-git]$

xyproto commented on 2016-07-28 11:54

asciinema switched back to using Python

sudokode commented on 2016-02-20 20:42

What would you have me do? gcc-go is in [core]. There is no way to choose a make depends via an aur helper like that, afaik. If this is a conflict, edit it before building and change it to community/go instead.

eduncan911 commented on 2016-01-25 18:09

Package requires the incorrect "gcc-go" package, not the standard "go" package.

This conflicts with the standard "go" community package, not to mention irking a lot of a Go developers (like me). Go developers usually maintain their own gcc-go installation.

It is NOT a requirement for asciinema and as a matter of fact could possibly cause encoding issues as gcc-go doesn't have all the encoding bindings as the official Go package does (not tested at all, just guessing since asciinema requires utf-8 and adds a lot of encoding conversions for the recording session).

Please remove "gcc-go" and instead use "go" package as the dependency.

The package properly builds under "go", without "gcc-go" installed - verified 2016-01-25.

It was first reported about this error back in July with the previous comment. Six months later, it still has not been resolved.

Flagging out of date for incorrect dependencies.

dlin commented on 2015-07-11 16:03

==> asciinema-git dependencies:
- git (already installed)
- go (already installed)
- gcc-go (package found)

==> asciinema-git conflicts:
- asciinema-0.9.8-2

==> Continue building asciinema-git ? [Y/n]
==> ---------------------------------------
==>
==> Building and installing package
==> Install or build missing dependencies for asciinema-git:
resolving dependencies...
looking for conflicting packages...
:: gcc-go and go are in conflict. Remove go? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)

sudokode commented on 2015-04-20 19:35

Thanks. Go took a little work. Should work fine though.

carstene1ns commented on 2015-04-19 09:39

This is no longer a python package, so the python dependencies should be removed.

Muflone commented on 2014-09-05 22:18

The asciiio-git package is going to be merged with asciinema-git as requested from sudokode, the maintainer of both packages.

sickill commented on 2013-12-01 12:35

requests dependency requirement for version 0.9.7 is ">=1.1.0", no need for 2.0.0 here.

All comments