Package Details: attica-qt4 0.4.2-7

Git Clone URL: https://aur.archlinux.org/attica-qt4.git (read-only, click to copy)
Package Base: attica-qt4
Description: A Qt4 library that implements the Open Collaboration Services API
Upstream URL: https://projects.kde.org/projects/frameworks/attica
Licenses: LGPL
Submitter: arojas
Maintainer: bidulock
Last Packager: bidulock
Votes: 16
Popularity: 1.29
First Submitted: 2018-08-24 06:44
Last Updated: 2018-11-04 23:50

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

dejohnua commented on 2018-11-04 04:18

Had the same problem related to Qt5Transitional

archieslove commented on 2018-11-03 23:38

Can confirm the comment below. Facing the same error.

mozo commented on 2018-11-03 22:47

I get this error:

==> Downloading attica-qt4 PKGBUILD from AUR...

x .SRCINFO

x PKGBUILD

JohnRobson commented on 2018-11-03 18:43

Pilli commented on 2018-11-03 18:43

snack commented on 2018-11-03 19:09

Mikaeshin commented on 2018-11-03 20:34

JohnRobson commented on 2018-11-03 21:20

attica-qt4 0.4.2-6 (2018-11-03 17:04)

( Unsupported package: Potentially dangerous ! ) ==> attica-qt4 dependencies:

  • qt4 (already installed)

  • cmake (already installed) [makedepend]

==> Continue building attica-qt4 ? [Y/n]

==> ------------------------------------

==> ==> Building and installing package

==> Making package: attica-qt4 0.4.2-6 (Sun 04 Nov 2018 12:40:22 AM EET)

==> Checking runtime dependencies...

==> Checking buildtime dependencies...

==> Retrieving sources...

-> Downloading attica-0.4.2.tar.bz2...

% Total % Received % Xferd Average Speed Time Time Time Current

                             Dload  Upload   Total   Spent    Left  Speed

100 349 100 349 0 0 1593 0 --:--:-- --:--:-- --:--:-- 1593

100 338 100 338 0 0 246 0 0:00:01 0:00:01 --:--:-- 1215

100 57093 100 57093 0 0 33368 0 0:00:01 0:00:01 --:--:-- 33368

==> Validating source files with md5sums...

attica-0.4.2.tar.bz2 ... Passed

==> Extracting sources...

-> Extracting attica-0.4.2.tar.bz2 with bsdtar

==> Starting prepare()...

==> Starting build()...

-- The C compiler identification is GNU 8.2.1

-- The CXX compiler identification is GNU 8.2.1

-- Check for working C compiler: /usr/bin/cc

-- Check for working C compiler: /usr/bin/cc -- works

-- Detecting C compiler ABI info

-- Detecting C compiler ABI info - done

-- Detecting C compile features

-- Detecting C compile features - done

-- Check for working CXX compiler: /usr/bin/c++

-- Check for working CXX compiler: /usr/bin/c++ -- works

-- Detecting CXX compiler ABI info

-- Detecting CXX compiler ABI info - done

-- Detecting CXX compile features

-- Detecting CXX compile features - done

-- Building with Qt5 support

CMake Error at CMakeLists.txt:12 (find_package):

By not providing "FindQt5Transitional.cmake" in CMAKE_MODULE_PATH this

project has asked CMake to find a package configuration file provided by

"Qt5Transitional", but CMake did not find one.

Could not find a package configuration file provided by "Qt5Transitional" with any of the following names:

Qt5TransitionalConfig.cmake

qt5transitional-config.cmake

Add the installation prefix of "Qt5Transitional" to CMAKE_PREFIX_PATH or

set "Qt5Transitional_DIR" to a directory containing one of the above files.

If "Qt5Transitional" provides a separate development package or SDK, be

sure it has been installed.

-- Configuring incomplete, errors occurred!

See also "/tmp/makepkg/attica-qt4/src/build/CMakeFiles/CMakeOutput.log".

==> ERROR: A failure occurred in build().

Aborting...

==> ERROR: Makepkg was unable to build attica-qt4.

==> Restart building attica-qt4 ? [y/N]

JohnRobson commented on 2018-11-03 21:20

@snack I did use a clean chroot and I also had same error than @Mikaeshin.

Mikaeshin commented on 2018-11-03 20:34

I can't update to 0.4.2-6, it says a error something like

"mkdir: could not create directory build: file exists

ERROR: a failure occurred in prepare()

Aborting..."

snack commented on 2018-11-03 19:09

@Pilli @JohnRobson you must build in a clean chroot.

Pilli commented on 2018-11-03 18:43

Hi.

I cannot build the package. I get this error:

-- Building with Qt5 support
CMake Error at CMakeLists.txt:12 (find_package):
  By not providing "FindQt5Transitional.cmake" in CMAKE_MODULE_PATH this
  project has asked CMake to find a package configuration file provided by
  "Qt5Transitional", but CMake did not find one.

  Could not find a package configuration file provided by "Qt5Transitional"
  with any of the following names:

    Qt5TransitionalConfig.cmake
    qt5transitional-config.cmake

  Add the installation prefix of "Qt5Transitional" to CMAKE_PREFIX_PATH or
  set "Qt5Transitional_DIR" to a directory containing one of the above files.
  If "Qt5Transitional" provides a separate development package or SDK, be
  sure it has been installed.


-- Configuring incomplete, errors occurred!
See also "/tmp/trizen-username/attica-qt4/src/build/CMakeFiles/CMakeOutput.log".
==> ERROR: Se produjo un fallo en build().
    Cancelando...
:: Unable to build attica-qt4 - makepkg exited with code: 4

JohnRobson commented on 2018-11-03 18:43

==> Starting build()... -- Building with Qt5 support CMake Error at CMakeLists.txt:12 (find_package): By not providing "FindQt5Transitional.cmake" in CMAKE_MODULE_PATH this project has asked CMake to find a package configuration file provided by "Qt5Transitional", but CMake did not find one.

Could not find a package configuration file provided by "Qt5Transitional" with any of the following names:

Qt5TransitionalConfig.cmake
qt5transitional-config.cmake

Add the installation prefix of "Qt5Transitional" to CMAKE_PREFIX_PATH or set "Qt5Transitional_DIR" to a directory containing one of the above files. If "Qt5Transitional" provides a separate development package or SDK, be sure it has been installed.

-- Configuring incomplete, errors occurred! See also "/tmp/makepkg/attica-qt4/src/build/CMakeFiles/CMakeOutput.log". ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Makepkg was unable to build attica-qt4. ==> Restart building attica-qt4 ? [y/N]

bidulock commented on 2018-11-03 17:06

Builds fine for me now in a clean chroot too, so I reverted the changes and made it a version 0.4.2-6.

snack commented on 2018-11-03 08:43

Version 0.4.2-5 breaks my system since it produces a wrongly versioned library file: libattica.so.1.0.0 instead of libattica.so.0.4.2. I reverted to attica-qt4-0.4.2-4 (built from clean chroot) and it seems to fix the problems.