Package Details: aurman 2.13.1-1

Git Clone URL: https://aur.archlinux.org/aurman.git (read-only)
Package Base: aurman
Description: AUR helper with almost pacman syntax
Upstream URL: https://github.com/polygamma/aurman
Licenses: MIT
Submitter: polygamma
Maintainer: polygamma
Last Packager: polygamma
Votes: 111
Popularity: 62.987713
First Submitted: 2018-03-20 21:31
Last Updated: 2018-06-20 18:30

Required by (0)

Sources (1)

Pinned Comments

Alad commented on 2018-06-06 12:00

I've already removed scores of spam from this page. The next guy who makes personal attacks or feels entitled to support without using the proper channels as kindly requested by the author will get his account suspended indefinitely.

polygamma commented on 2018-06-06 10:33

This is not the right place for reporting aurman bugs or request features, please use https://github.com/polygamma/aurman/issues

If you do not want to register on GitHub for such things, I do not care from now on.

I am not going to respond to comments on this page, if they have nothing to do with the PKGBUILD.

tl;dr: Bugs and feature requests -> GitHub, PKGBUILD problems -> here, not going to answer comments if they have nothing to do with the PKGBUILD from now on

Latest Comments

Foxboron commented on 2018-06-21 20:00

@regeya,

This is expected and any users using the AUR should be aware of how this works. Yelling about outdated VCS packages and claiming that an Arch Dev and an AUR helper developer doesn't understand the basics is just insulting to say the least.

It is even documented in the page we expect you to read. https://wiki.archlinux.org/index.php/Arch_User_Repository#Foo_in_the_AUR_is_outdated.3B_what_should_I_do.3F

polygamma commented on 2018-06-21 19:51

@regeya - https://github.com/polygamma/aurman/issues/153#issuecomment-399194590 I even provided "proof", that the version is going to be the needed one.

regeya commented on 2018-06-21 19:48

And you know, had someone said, "just install the package manually or from your current aur helper, some black magic bleepery will give it the right version number upon install despite the version number being wrong in the PKGBUILD," that would have been more or less acceptable. In fact, that's what I'm saying right now. :-) No need for the open hostility or the condescending behavior; could you leave this all here so that anyone else running into the problem will know?

Eschwartz commented on 2018-06-21 19:13

The goal of bootstrapping packages which require versioned dependencies, of VCS packages for which the version will only be calculated when actually running makepkg to build the package, is fundamentally incompatible with upfront dependency resolution. In order to install expac-git and aurman at the correct versions, it is necessary to first install expac-git on its own, then install aurman.

This is not a problem to be solved by AUR helpers. AUR helpers can do a lot, but they cannot completely obviate the need for human interaction.

You're a Turing-complete user -- act like it.

polygamma commented on 2018-06-21 19:00

@regeya the dependency listed in the PKGBUILD of aurman is correct. aurman needs expac-git>=8.1.g5ae006f, whereas 8.1.g5ae006f-1 is the version you get, if you build expac-git as of now, so what is your problem?

Eschwartz commented on 2018-06-21 06:29

The & would be completely wrong, actually.

The ?signed is being incorrectly interpreted as part of the clone URL, but if your pacman version was the current latest version then makepkg would stop choking on this new syntax.

johnjq commented on 2018-06-21 02:28

As of version 2.13.1-1, line 10 of PKGBUILD should be [[[source=("aurman_sources::git+https://github.com/polygamma/aurman.git?signed&tag=${pkgver}")]]] instead of [[[source=("aurman_sources::git+https://github.com/polygamma/aurman.git?signed#tag=${pkgver}")]]].

Otherwise the following error occurs:

Cloning into bare repository '.../.cache/pacaur/aurman/aurman_sources'...

warning: redirecting to https://github.com/polygamma/aurman?signed/

fatal: https://github.com/polygamma/aurman?signed/info/refs not valid: is this a git repository?

xantares commented on 2018-06-19 09:22

pkgdesc should not contain the package name

Eschwartz commented on 2018-06-18 18:43

@Cavsfan, I've already explained this. This is a GnuPG issue, not an issue with aurman itself. It is erroneous to ask for GnuPG support here, please consult one of the many Arch Linux support channels, e.g. the Wiki, the BBS, #archlinux on Freenode, and ask for help fixing your GnuPG which is unable to import PGP keys. This will get you an actual solution, unlike complaining here that this one key does not work (to which the only answer is "yes it does, you're wrong").

The aurman developer does not want to know about your GnuPG issues. His GnuPG works fine, and aurman works fine too. He's not necessarily an expert in GnuPG, but it's irrelevant because if he wanted to spend time providing support for GnuPG, he'd be on those other support channels providing general support on miscellaneous topics. Whereas this is the aurman-specific location for getting support specific to aurman itself.

There's no reason to "wait until it sorts itself out" -- if your GnuPG is broken, that won't magically fix itself, and it is something you should try to get fixed... by asking for support for GnuPG, in the appropriate places to get support for GnuPG on Arch Linux. Which is not here.

polygamma commented on 2018-06-18 18:26

@Cavsfan that still does not make it an aurman PKGBUILD problem, but a problem with importing PGP keys. You can find the needed public key e.g. here: https://github.com/polygamma.gpg and you may import it manually

All comments