Package Details: bino 2.1-1

Git Clone URL: https://aur.archlinux.org/bino.git (read-only, click to copy)
Package Base: bino
Description: A video player with focus on 3D and Virtual Reality
Upstream URL: https://bino3d.org/
Licenses: GPL3
Submitter: jose1711
Maintainer: SunRed
Last Packager: SunRed
Votes: 10
Popularity: 0.000011
First Submitted: 2016-01-01 21:21 (UTC)
Last Updated: 2023-02-18 22:55 (UTC)

Latest Comments

1 2 3 Next › Last »

SunRed commented on 2023-02-21 21:35 (UTC) (edited on 2023-02-21 22:08 (UTC) by SunRed)

@mkellem I can't seem to reproduce this issue as bino and the qvr package build fine in a clean chroot for me. ldd also doesn't list a missing dependency.

After looking into this issue further I see that openvr as well as vrpn and others are optional dependencies for qvr, not necessarily required for bino to work correctly in VR. I will look into adding them as optional dependencies. Your warning might be thrown if you've built qvr with openvr support and removed the openvr package afterwards. This might need additional checks upstream.

mkellem commented on 2023-02-20 16:10 (UTC)

2.1-1 failed to build on my machine. Resolved by installing the openvr package.

/usr/bin/ld: warning: libopenvr_api.so, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/12.2.1/../../../../lib/libqvr.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/12.2.1/../../../../lib/libqvr.so: undefined reference to `VR_GetInitToken'
/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/12.2.1/../../../../lib/libqvr.so: undefined reference to `VR_ShutdownInternal'

SunRed commented on 2022-06-14 22:40 (UTC)

@gruenfron Sorry! I forgot to update the checksum. Should be fixed now. It was a busy day.

I should really setup a pipeline for that on my Gitea.

gruenfron commented on 2022-06-14 20:13 (UTC) (edited on 2022-06-14 20:27 (UTC) by gruenfron)

@patlefort: that makes sense, I am not an autoconf guru - maybe we'll see conversion to cmake in some far future...

@SunRed: no idea whether this is going to happen since I have no overview which distros offer an ffmpeg4.x package

Oh, and it seems that the ffmpeg4.4.patch pkgsum is not updated?

SunRed commented on 2022-06-14 15:12 (UTC)

@patlefort Thanks.

@gruenfron I see you already left a commit in the GitHub mirror of the project. So this will hopefully be upstreamed somehow.

patlefort commented on 2022-06-14 00:45 (UTC)

I suggest changing the patch to:

--- a/configure.ac
+++ b/configure.ac
@@ -143,25 +143,6 @@ if test -z "$PKG_CONFIG"; then
     AC_MSG_WARN([please install pkg-config; Debian package: pkg-config])
 fi

-dnl FFmpeg
-PKG_CHECK_MODULES([libavformat], [libavformat >= 52.110.0 libavcodec libavutil], [HAVE_LIBAVFORMAT=1], [HAVE_LIBAVFORMAT=0])
-if test "$HAVE_LIBAVFORMAT" != "1"; then
-    AC_MSG_WARN([required library libavformat >= 52.110.0 not found:])
-    AC_MSG_WARN([$libavformat_PKG_ERRORS])
-    AC_MSG_WARN([libavformat >= 52.110.0 is provided by libav >= 0.7 or FFmpeg >= 0.7])
-fi
-PKG_CHECK_MODULES([libavdevice], [libavdevice >= 52.5.0], [HAVE_LIBAVDEVICE=1], [HAVE_LIBAVDEVICE=0])
-if test "$HAVE_LIBAVDEVICE" != "1"; then
-    AC_MSG_WARN([required library libavdevice >= 52.5.0 not found:])
-    AC_MSG_WARN([$libavdevice_PKG_ERRORS])
-    AC_MSG_WARN([libavdevice >= 52.5.0 is provided by libav >= 0.7 or FFmpeg >= 0.7])
-fi
-PKG_CHECK_MODULES([libswscale], [libswscale >= 0.14.1 libavutil], [HAVE_LIBSWSCALE=1], [HAVE_LIBSWSCALE=0])
-if test "$HAVE_LIBSWSCALE" != "1"; then
-    AC_MSG_WARN([required library libswscale >= 0.14.1 not found:])
-    AC_MSG_WARN([$libswscale_PKG_ERRORS])
-    AC_MSG_WARN([libswscale >= 0.14.1 is provided by libav >= 0.7 or FFmpeg >= 0.7])
-fi
 AC_CHECK_FUNCS([sysconf])

 dnl libass
@@ -400,11 +381,16 @@ UPDATE_DESKTOP_DATABASE=""
 AC_ARG_VAR([UPDATE_DESKTOP_DATABASE], [update-desktop-database command])
 AC_CHECK_PROGS([UPDATE_DESKTOP_DATABASE], [update-desktop-database])

+dnl ffmpeg4.4 libs
+LIBS="$LIBS /usr/lib/libswscale.so.5"
+LIBS="$LIBS /usr/lib/libavutil.so.56"
+LIBS="$LIBS /usr/lib/libavformat.so.58"
+LIBS="$LIBS /usr/lib/libavdevice.so.58"
+LIBS="$LIBS /usr/lib/libavcodec.so.58"
+CPPFLAGS="$CPPFLAGS -I/usr/include/ffmpeg4.4"
+
 dnl Check if all libraries were found
 if test "$am_cv_func_iconv" != "yes" \
-    -o "$HAVE_LIBAVFORMAT" != "1" \
-    -o "$HAVE_LIBAVDEVICE" != "1" \
-    -o "$HAVE_LIBSWSCALE" != "1" \
     -o "$HAVE_LIBASS" != "1" \
     -o "$HAVE_LIBOPENAL" != "1" \
     -o "$HAVE_LIBQTOPENGL" != "1" \

To make it POSIX compliant, as configure scripts should be. Else it will not work if you use for example dash as your shell. Also, the ffmpeg dependency should be changed to ffmpeg4.4.

SunRed commented on 2022-06-13 22:37 (UTC)

@gruenfron Many thanks for the patch! I added you to the list of contributors.

gruenfron commented on 2022-06-10 17:03 (UTC) (edited on 2022-06-10 17:09 (UTC) by gruenfron)

Doesn't compile with ffmpeg 2:5 anymore. Here is my fix that hopefully helps. First step is to change dependency from ffmpeg to ffmpeg4.4 and second step is to patch the configure.ac file to make use of it exclusively.

The modification for PKGBUILD


--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,15 +9,17 @@ pkgdesc='3D video player with multi-display support'
 arch=('x86_64')
 url='https://bino3d.org/'
 license=('GPL3')
-depends=('ffmpeg' 'freealut' 'freeglut' 'glewmx' 'libass' 'qt5-base')
+depends=('ffmpeg4.4' 'freealut' 'freeglut' 'glewmx' 'libass' 'qt5-base')
 optdepends=('lirc: infrared remote control')
-source=(https://bino3d.org/releases/bino-${pkgver}.tar.xz{,.sig})
+source=(https://bino3d.org/releases/bino-${pkgver}.tar.xz{,.sig} ffmpeg4.4.patch)
 sha512sums=('d8cf5be356add4ed3fb36673038b5ffd92d0dc840798cc616fa4b11fec221c7f114347dfc7cdb7a3a24c5599b56301cddc99f84d3862d8e874612960281319cc'
-       'SKIP')
+            'SKIP'
+            '13a6df34566df4141f33e473fb10aa17de844ee18d555c0cbad561b19b9249a1045c791c40479fbe4e6c8dcc217637e91e096d98ffb6463fe6084dd25426a55d')
 validpgpkeys=('2F61B4828BBA779AECB3F32703A2A4AB1E32FD34')

 build() {
        cd "${srcdir}/${pkgname}-${pkgver}"
+    patch -Np1 < ${srcdir}/ffmpeg4.4.patch
        ./configure \
          --prefix=/usr \
          --with-qt-version=5 \

The patch file ffmpeg4.4.patch


--- a/configure.ac
+++ b/configure.ac
@@ -143,25 +143,6 @@ if test -z "$PKG_CONFIG"; then
     AC_MSG_WARN([please install pkg-config; Debian package: pkg-config])
 fi

-dnl FFmpeg
-PKG_CHECK_MODULES([libavformat], [libavformat >= 52.110.0 libavcodec libavutil], [HAVE_LIBAVFORMAT=1], [HAVE_LIBAVFORMAT=0])
-if test "$HAVE_LIBAVFORMAT" != "1"; then
-    AC_MSG_WARN([required library libavformat >= 52.110.0 not found:])
-    AC_MSG_WARN([$libavformat_PKG_ERRORS])
-    AC_MSG_WARN([libavformat >= 52.110.0 is provided by libav >= 0.7 or FFmpeg >= 0.7])
-fi
-PKG_CHECK_MODULES([libavdevice], [libavdevice >= 52.5.0], [HAVE_LIBAVDEVICE=1], [HAVE_LIBAVDEVICE=0])
-if test "$HAVE_LIBAVDEVICE" != "1"; then
-    AC_MSG_WARN([required library libavdevice >= 52.5.0 not found:])
-    AC_MSG_WARN([$libavdevice_PKG_ERRORS])
-    AC_MSG_WARN([libavdevice >= 52.5.0 is provided by libav >= 0.7 or FFmpeg >= 0.7])
-fi
-PKG_CHECK_MODULES([libswscale], [libswscale >= 0.14.1 libavutil], [HAVE_LIBSWSCALE=1], [HAVE_LIBSWSCALE=0])
-if test "$HAVE_LIBSWSCALE" != "1"; then
-    AC_MSG_WARN([required library libswscale >= 0.14.1 not found:])
-    AC_MSG_WARN([$libswscale_PKG_ERRORS])
-    AC_MSG_WARN([libswscale >= 0.14.1 is provided by libav >= 0.7 or FFmpeg >= 0.7])
-fi
 AC_CHECK_FUNCS([sysconf])

 dnl libass
@@ -400,11 +381,16 @@ UPDATE_DESKTOP_DATABASE=""
 AC_ARG_VAR([UPDATE_DESKTOP_DATABASE], [update-desktop-database command])
 AC_CHECK_PROGS([UPDATE_DESKTOP_DATABASE], [update-desktop-database])

+dnl ffmpeg4.4 libs
+LIBS+=" /usr/lib/libswscale.so.5"
+LIBS+=" /usr/lib/libavutil.so.56"
+LIBS+=" /usr/lib/libavformat.so.58"
+LIBS+=" /usr/lib/libavdevice.so.58"
+LIBS+=" /usr/lib/libavcodec.so.58"
+CPPFLAGS+=" -I/usr/include/ffmpeg4.4"
+
 dnl Check if all libraries were found
 if test "$am_cv_func_iconv" != "yes" \
-    -o "$HAVE_LIBAVFORMAT" != "1" \
-    -o "$HAVE_LIBAVDEVICE" != "1" \
-    -o "$HAVE_LIBSWSCALE" != "1" \
     -o "$HAVE_LIBASS" != "1" \
     -o "$HAVE_LIBOPENAL" != "1" \
     -o "$HAVE_LIBQTOPENGL" != "1" \

MarsSeed commented on 2022-05-24 15:46 (UTC)

glewmx dependency orphaned.

SunRed commented on 2021-10-17 08:03 (UTC)

Sorry I neglected this package in the past. I added a patch now using commits from the master branch and also removed the glew envs, finally fixing the compiler errors and making the package work again.

@ViGA-FR You have to import the PGP key first using gpg --recv-keys 03A2A4AB1E32FD34. If you're using an AUR helper it should also ask you to import the key into your keyring.