Package Details: brother-dcp7040 2.0.2-2

Git Clone URL: https://aur.archlinux.org/brother-dcp7040.git (read-only)
Package Base: brother-dcp7040
Description: LPR and CUPS driver for the Brother DCP7040
Upstream URL: http://solutions.brother.com/linux/en_us/
Licenses: custom:brother commercial license
Submitter: FredBezies
Maintainer: FredBezies
Last Packager: FredBezies
Votes: 1
Popularity: 0.017626
First Submitted: 2015-09-22 20:45
Last Updated: 2017-02-01 10:41

Latest Comments

FredBezies commented on 2017-02-06 22:07

@archasaurusrex : you're welcome. Glad it works.

archasaurusrex commented on 2017-02-06 19:32

Just got around to uninstall/reinstall/testing, it works great.

Thanks for the quick response!

FredBezies commented on 2017-02-01 10:41

Applied both modifications in PKGBUILD. Can you tell me it is ok or not?

Thanks!

archasaurusrex commented on 2017-01-31 22:32

I was very happy to see my printer already in the AUR, but it was printing my PDF's too low on the page and cutting the bottoms off. It turned out to be a permissions issue: a low-level config file with the page size was not writable to CUPS, therefore I was effectively unable to change the page size. I fixed it by running:

# echo DCP7040 | sudo tee /usr/share/brother/inf/brPrintList

and then running:

# sudo chown daemon:lp /usr/share/brother/inf/brDCP7040rc

For some reason, /usr/share/brother/cupswrapper/brcupsconfig3, which is called by /usr/lib/cups/filter/brlpdwrapperDCP7040, needs the second change. The first change is also necessary... but I'm not as sure where the issue is coming from.