Package Details: brother-mfc-j4420dw 3.0.1-1

Git Clone URL: https://aur.archlinux.org/brother-mfc-j4420dw.git (read-only)
Package Base: brother-mfc-j4420dw
Description: LPR and CUPS driver for the Brother MFC-J4420DW
Upstream URL: http://solutions.brother.com/linux/en_us/
Licenses: custom:brother commercial license
Submitter: pfrenssen
Maintainer: pfrenssen
Last Packager: pfrenssen
Votes: 1
Popularity: 0.000000
First Submitted: 2016-01-18 21:26
Last Updated: 2018-05-25 09:13

Latest Comments

N00byKing commented on 2018-09-15 18:43

After who knows how long to try and get this Printer to work: Thank you

pfrenssen commented on 2018-05-25 09:15

Thanks theghost! I have included your patch.

theghost commented on 2018-03-02 13:04

Dear maintainer, unfortunately this driver does not work out of the box. With the current release of this driver and CUPS, you still can add a printer, using the driver provided by the package but printing via network (IPP with DNS-SD, AppSocket/HP, etc.) fails. Every printing job is simply ignored. I patched the PKGBUILD to add lib32-glibc as required dependancy to fix this issues. With my patch printing via IPP with DNS-SD, AppSocket/HP and USB worked again. The patch is available at my Github-Repo, I hope you will integrate it in the driver: https://gist.github.com/1heghost/6c7d8c064e4c0398b2dbf20cbe3b537d. Feel free to add feedback I might have done something wrong, as this is my first contribution to Arch.

kuenx commented on 2016-09-13 13:02

I get an error when trying to install this:

error: failed to commit transaction (conflicting files)
brother-mfc-j4420dw: /opt/brother exists in filesystem
Errors occurred, no packages were upgraded.