Package Details: calibre-git 5.34.0.r114.g0cf7af69ac-1

Git Clone URL: https://aur.archlinux.org/calibre-git.git (read-only, click to copy)
Package Base: calibre-git
Description: Ebook management application
Upstream URL: https://calibre-ebook.com/
Licenses: GPL3
Conflicts: calibre, calibre-common, calibre-python3
Provides: calibre
Replaces: calibre-common-git, calibre-python3-git
Submitter: eschwartz
Maintainer: alerque (eschwartz)
Last Packager: alerque
Votes: 17
Popularity: 0.000498
First Submitted: 2015-08-09 15:02 (UTC)
Last Updated: 2022-01-17 20:49 (UTC)

Latest Comments

1 2 3 4 Next › Last »

qubidt commented on 2022-10-26 09:53 (UTC)

@haawda, I was trying to understand why the versioned dependency was causing the build to fail (since this package should provide calibre>=5.15). Removing the version dependency just works around the issue, it doesn't explain why it's an issue in the first place

haawda commented on 2022-07-18 17:22 (UTC)

qubidt, no the git revision is not the culprit. Try to remove the versioned dependency in calibre-plugin-dedrm, i.e. change depends=('calibre>=5.15') to just depends=('calibre'), or add the version number in provides in calibre-git's PKGBUILD. Both should work.

What I want to ask: Is it just me for whom manpage creation fails? A hidden makedependency?

melvyn2 commented on 2022-07-13 21:03 (UTC)

Might be missing pyqt6 makedepends

qubidt commented on 2021-12-17 09:24 (UTC)

aur/calibre-plugin-dedrm fails to build/install because it has depends=('calibre>=5.15'). pacman considers it a missing dependency, even though calibre-git provides calibre and is at version 5.34.0.r5.g1127c285bb-1. It works when modifying the calibre-plugin-dedrm PKGBUILD to not specify a calibre dependency. I'm assuming it's failing because the version number of the package contains the git revision? But I don't see why it should since the first three segments of the version # should satisfy the comparison. Any thoughts?

malcolm commented on 2021-06-05 21:12 (UTC) (edited on 2021-06-05 21:13 (UTC) by malcolm)

The build stops when displaying this

Could not find QtWebEngineProcess

I have all the dependencies of calibre installed, as well as qt5-webengine (5.15.4-3) python-pyqtwebengine (5.15.4-1)

eschwartz commented on 2020-12-07 13:19 (UTC) (edited on 2020-12-07 13:20 (UTC) by eschwartz)

This has been previously requested on the bugtracker for community/calibre too (in that case, the user wanted calibre-server to be split out), and was just as invalid there.

calibre isn't multiple programs in one package. It is one unified codebase with a number of entry points into it. Qt5-base is used essentially everywhere. The conversion pipeline directly relies on a headless plugin with mandatory x11 client libraries, even though ebook-convert doesn't run in a GUI, but doesn't require a running xorg server. etc.

Inporting any part of the codebase will inevitably result in most or all of the dependencies being used, simply because a lot of functionality you might not think is related, nevertheless is.

lenormf commented on 2020-12-07 07:55 (UTC)

Any way you could please split this package into separate ones, to allow installing Xorg-less utilities like calibredb on a server without pulling X11 dependencies?

eschwartz commented on 2019-11-22 06:34 (UTC)

I've pushed an update I've been experimenting with -- calibre-python3-git and calibre-git now depend on a "common" package, and you can install one or both as you wish. I'd still advise having the calibre2 version around, though...

eschwartz commented on 2019-11-15 02:24 (UTC)

Yeah, let me go rebuild my custom repo for python3.8 right now.