Package Details: carla-git 1:2.3.0.RC2.r0.g2294a5c86-1

Git Clone URL: https://aur.archlinux.org/carla-git.git (read-only, click to copy)
Package Base: carla-git
Description: Audio Plugin Host
Upstream URL: http://kxstudio.sf.net/carla
Keywords: daw host plugin vst2 vst3
Licenses: GPL2+
Conflicts: carla
Provides: carla
Submitter: cocreature
Maintainer: SpotlightKid (Joermungand)
Last Packager: SpotlightKid
Votes: 23
Popularity: 0.26
First Submitted: 2013-10-11 12:29
Last Updated: 2021-03-17 22:08

Required by (12)

Sources (1)

Pinned Comments

SpotlightKid commented on 2021-03-17 22:10

Heads up, everybody! I've switched this package back from building the "develop" branch to the "main" branch again, since the "develop" branch is now gone. If you re-use your package build directories, you might have to delete the old "carla" repo directory and you also may need to delete the "src" directory before re-building.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

muncrief commented on 2019-07-12 19:12

@SpotlightKid: I did a completely clean build by changing to a working directory and executing "yay -G carla-git" to create a clean build directory.

I then ran makepkg and got the patch failure so I looked at the patch and the CarlaBridgeToolkitQt.cpp file and saw the reason the patch failed was because the CarlaBridgeToolkitQt.cpp was different than what the patch expected, and that's why it failed.

But like I said I'm not familiar with Carla, and only install it because I like to have a full KXStudio package. However the PKGBUILD does look like it's using the develop branch, and I didn't change anything in it other than removing the patch.

SpotlightKid commented on 2019-07-12 18:41

@muncrief: Are you sure you are looking at 'develop' branch? Have you removed your 'src' directory before rebuilding?

The patch only fixes compilation for Qt >= 5.13. Not all Arch variants have upgraded Qt yet, e.g. Manjaro is still on 5.12.x.

muncrief commented on 2019-07-12 18:14

I tried building this today and the patch failed so it wouldn't build. Upon further inspection I discovered the source/bridges-ui/CarlaBridgeToolkitQt.cpp file has substantially changed and it looks like the patch may now be obsolete.

So I removed the patch from the PKGBUILD and carla compiled and installed. And when I run it the window appears and looks correct.

However I don't actually use Carla and have no way of testing its actual functionality, so hopefully a user will be able to verify if removing the patch is okay.

dvzrv commented on 2019-07-10 08:22

@SpotlightKid: No, the patch is relevant for qt5 >= 5.13 (only actually). The qt4 bits stay in place, but for qt5 it's relevant as some parts of the code otherwise get namespaced and lead to compiler errors.

SpotlightKid commented on 2019-07-09 10:54

@Teteros: Isn't this patch only relevant, if you compile with Qt4 support at all? This PKGBUILD recently turned off Qt4 support by passing HAVE_QT4=false to make.

Teteros commented on 2019-07-06 03:08

Fails to build currently on gcc9 and Qt >= 5.13

https://github.com/falkTX/Carla/issues/894

Patch from PR #895 fixes compile:

fix_qt5.13_moc.patch

diff --git a/source/bridges-ui/CarlaBridgeToolkitQt.cpp b/source/bridges-ui/CarlaBridgeToolkitQt.cpp
index 81478fd3..0fbae9cf 100644
--- a/source/bridges-ui/CarlaBridgeToolkitQt.cpp
+++ b/source/bridges-ui/CarlaBridgeToolkitQt.cpp
@@ -263,9 +263,7 @@ private:
 # pragma GCC diagnostic ignored "-Wzero-as-null-pointer-constant"
 #endif

-#if (QT_VERSION >= QT_VERSION_CHECK(5, 0, 0))
-# include "CarlaBridgeToolkitQt5.moc"
-#else
+#if (QT_VERSION < QT_VERSION_CHECK(5, 0, 0))
 # include "CarlaBridgeToolkitQt4.moc"
 #endif

@@ -286,6 +284,21 @@ CARLA_BRIDGE_UI_END_NAMESPACE

 // -------------------------------------------------------------------------

+#if defined(__GNUC__) && (__GNUC__ > 4 || (__GNUC__ == 4 && __GNUC_MINOR__ >= 6))
+# pragma GCC diagnostic push
+# pragma GCC diagnostic ignored "-Wzero-as-null-pointer-constant"
+#endif
+
+#if (QT_VERSION >= QT_VERSION_CHECK(5, 0, 0))
+# include "CarlaBridgeToolkitQt5.moc"
+#endif
+
+#if defined(__GNUC__) && (__GNUC__ > 4 || (__GNUC__ == 4 && __GNUC_MINOR__ >= 6))
+# pragma GCC diagnostic pop
+#endif
+
+// -------------------------------------------------------------------------
+
 #if defined(__GNUC__) && (__GNUC__ > 4 || (__GNUC__ == 4 && __GNUC_MINOR__ >= 6))
 # pragma GCC diagnostic push
 # pragma GCC diagnostic ignored "-Wmissing-declarations"

You can apply in the PKGBUILD as usual:

source=("$pkgname"::"git://github.com/falkTX/Carla.git" "fix_qt5.13_moc.patch")
md5sums=('SKIP' 'SKIP')

prepare() {
  cd "$srcdir/$pkgname"
  patch -p1 < "$srcdir/fix_qt5.13_moc.patch"
}

SpotlightKid commented on 2019-06-29 16:47

@milk: I just pushed a new version, which drops support for Qt4 completely. If you want to use LV2 plugins with a Qt4 GUI with Carla, you have to edit the PKGBUILD file and remove the HAVE_QT=false lines (and install the qt4 AUR package of course) and rebuild.

SpotlightKid commented on 2019-06-24 09:49

@milk: I didn't realize, 'qt4' is in the AUR now (on Manjaro, it seems, it is still in the 'community' repos). Alas, to build the LV2 bridge for LV2 plugins using Qt4, you still need Qt4 at compile time. But at least on my system there seem to be no LV2 plugins actually linked against Qt4.

Here's the command I'm using to check:

find /usr/lib/lv2/ -name "*.so" | while read so; do ldd "$so" | grep -H 'QtCore\.so\.4' ; done

Let me think about this for a day or two...

milk commented on 2019-06-23 16:28

Can qt4 be removed from makedepends as it is in optdepends? Qt4 takes two hours to build on my system and I want shot of it.

SpotlightKid commented on 2019-05-02 17:01

'qt5' is indirectly required by 'python-pyqt5', which is in the 'depends' list. All 'depends' packages are automatically make dependencies as well. 'qt4' is only in 'makedepends' and in 'optdepends', because it is only required for plugins using Qt4 and building the Carla plugin bridge for those. Carla itself only uses Qt5 nowadays, I think.