Package Details: conan 1.52.0-1

Git Clone URL: https://aur.archlinux.org/conan.git (read-only, click to copy)
Package Base: conan
Description: A distributed, open source, C/C++ package manager.
Upstream URL: https://conan.io
Licenses: MIT
Submitter: suridaj
Maintainer: suridaj
Last Packager: suridaj
Votes: 61
Popularity: 0.29
First Submitted: 2016-08-21 01:35 (UTC)
Last Updated: 2022-09-07 19:07 (UTC)

Latest Comments

1 2 3 4 5 6 .. 10 Next › Last »

suridaj commented on 2022-07-23 09:16 (UTC)

python-pyjwt has been updated. Conan 1.50 can be installed now.

suridaj commented on 2022-07-08 21:35 (UTC)

Conan 1.50.0 depends on python-pyjwt>=2.4.0.

Current version of python-pyjwt is 2.2.0.

Until python-pyjwt is updated, we cannot safely upgrade Conan to 1.50.0 and above.

suridaj commented on 2022-04-27 13:51 (UTC)

@FabioLolix: thank you for the suggestion, from now on the source file is renamed as $pkgname-$pkgver.

FabioLolix commented on 2022-04-24 12:17 (UTC)

You're welcome to rename the source as $pkgname-$pkgver

raeste commented on 2022-01-05 05:01 (UTC)

Thanks for the hint with the python version in .local and /usr. I removed the packages from the .local folder and after that the installation was successfull =)

carlosal1015 commented on 2022-01-04 17:03 (UTC) (edited on 2022-01-04 17:04 (UTC) by carlosal1015)

I do not have any error

==> Finished making: conan 1.44.0-1 (Tue 04 Jan 2022 12:01:45 PM -05)

Please could you please upload the logs.

Usually, mixing python versions ~/.local/lib/python3.10 with /usr/lib/python3.10 could generate errors.

raeste commented on 2022-01-04 16:41 (UTC) (edited on 2022-01-04 16:54 (UTC) by raeste)

I tried to build the current version of conan but i got an error:

File "/home/kev/.local/lib/python3.10/site-packages/setuptools/command/build_py.py", line 127, in build_package_data srcfile in self.distribution.convert_2to3_doctests): AttributeError: 'Distribution' object has no attribute 'convert_2to3_doctests'

suridaj commented on 2021-12-02 11:26 (UTC) (edited on 2021-12-02 12:07 (UTC) by suridaj)

@silverhikari, generally, X-git packages should specify which version of X they provide, see https://wiki.archlinux.org/title/PKGBUILD#provides

In this particular case, conan depends on python-fasteners>=0.14.1. python-fasteners-git does not declare which version of python-fasteners it provides, so pacman cannot guarantee python-fasteners-git can stand in for python-fasteners>=0.14.1.

You can work around your issue in one of the following ways:

  • edit python-fasteners-git's PKGBUILD and specify the provided version of python-fasteners, eg. provides=('python-fasteners=0.16.1')

or

  • edit conan's PKGBUILD and remove the required version of python-fasteners so that its depends line is just 'python-fasteners' without any version.

silverhikari commented on 2021-12-02 09:00 (UTC) (edited on 2021-12-02 09:01 (UTC) by silverhikari)

when trying to install conan i get a package conflict that tries to install python-fasteners though the reason i am running python-fasteners-git for a package that requires it. i do not know why this is happening as the pkgbuild seems to allow for both?

suridaj commented on 2021-08-10 23:02 (UTC)

@bazza: Which command exactly are you running? The quoted command runs for me on a clean, up-to-date system.