Package Details: conan 1.0.4-1

Git Clone URL: https://aur.archlinux.org/conan.git (read-only)
Package Base: conan
Description: A distributed, open source, C/C++ package manager.
Upstream URL: https://conan.io
Licenses: MIT
Submitter: suridaj
Maintainer: suridaj
Last Packager: suridaj
Votes: 25
Popularity: 3.015448
First Submitted: 2016-08-21 01:35
Last Updated: 2018-01-30 20:51

Latest Comments

suridaj commented on 2018-01-24 12:21

Since Conan 1.0.0 I have removed the upper version requirement on dependencies, let's see how that goes for a bit.

We are less strict now so there should be fewer conflicts during upgrades. Still, please keep an eye out for any possible bugs when updating the dependencies!

virtualdxs commented on 2018-01-24 06:38

Please do remove this upper limit.

greyltc commented on 2017-12-25 09:30

Yeah, I vote in favor of removing all the upper version limits for the deps.

suridaj commented on 2017-12-24 12:21

Great that it worked and I am sorry you had to work around this issue.

Again, I would like to hear from the users: would you prefer me to relax requirements on specific versions of conan's dependencies? This would make upgrades smoother but sometimes bugs could seep in when underlying libs break compatibility.

bowhuntr commented on 2017-12-24 12:14

Yes, that worked. Thanks.

suridaj commented on 2017-12-24 12:10

I understand python-pylint and conan cannot be upgraded. Please try removing conan, updating packages from the official repos, then installing conan again.

bowhuntr commented on 2017-12-24 11:40

Something has to change because neither conan nor python-pylint can be updated.

suridaj commented on 2017-12-24 09:29

I try to follow closely the requirements listed by the upstream. On the one hand, it is very rare that updating a dependency breaks Conan functionality - I test this quite often and submit patches to Conan so that Arch's fresh packages are accomodated. On the other hand, there are cases where serious bugs do occur and dependency versions really need to be constrained (such as the pylint 1.7.x + astroid 1.6 breaking bug https://github.com/conan-io/conan/issues/2164 )

That said, I am open for suggestions. Would Conan users be willing to suffer possible occasional bugs and breakage if I remove the high-version limit on dependencies?

greyltc commented on 2017-12-23 23:54

conan: installing python-pylint (1.8.1-1) breaks dependency 'python-pylint<=1.8.0'

Does this package really need all the very specific dependency version requirements it has? Maybe most of them could be removed?

suridaj commented on 2017-12-22 16:30

Conan 0.30.3 is out, however it does not work with python-astroid 1.6.0. Here is the bug: https://github.com/conan-io/conan/issues/2164

Until this issue is resolved, I am uncomfortable with pushing Conan 0.30.3 as it would conflict with python-astroid>=1.6.0 from mainline Arch.

All comments