Package Details: conky-lua-nv 1.17.0-3

Git Clone URL: (read-only, click to copy)
Package Base: conky-lua-nv
Description: An advanced system monitor for X based on torsmo with lua and nvidia enabled
Upstream URL:
Licenses: GPL, BSD
Conflicts: conky
Provides: conky, conky-lua
Replaces: conky, torsmo
Submitter: Andrwe
Maintainer: Foucault
Last Packager: Foucault
Votes: 128
Popularity: 0.24
First Submitted: 2010-04-12 04:55 (UTC)
Last Updated: 2023-02-01 00:30 (UTC)

Dependencies (31)

Required by (10)

Sources (1)

Latest Comments

1 2 3 4 5 6 .. 11 Next › Last »

sylphio commented on 2023-01-31 21:42 (UTC)

@Syphist @MichaelARCH The new checksum is eaa4aefd1caff4f87d2d7689a4e217a9ad895433 but don't take my word for it.

MichaelARCH commented on 2023-01-31 16:23 (UTC) (edited on 2023-01-31 16:24 (UTC) by MichaelARCH)

Just got this

Erstelle conky-lua-nv...
==> Erstelle Paket: conky-lua-nv 1.17.0-2 (Di 31 Jan 2023 17:19:08 CET)
==> Prüfe Laufzeit-Abhängigkeiten...
==> Prüfe Buildtime-Abhängigkeiten...
==> Empfange Quellen...
  -> v1.17.0.tar.gz gefunden
==> Überprüfe source Dateien mit sha1sums...
  v1.17.0.tar.gz ... FAILED
==> ERROR: One or more Files did not pass the validity test!

Syphist commented on 2023-01-31 00:48 (UTC) (edited on 2023-01-31 00:56 (UTC) by Syphist)


It appears that the SHA-1 has in the PKGBUILD is wrong.

When trying to build this package I get the following output from paru:

==> Making package: conky-lua-nv 1.17.0-1 (Mon 30 Jan 2023 06:34:48 PM CST) ==> Retrieving sources... -> Found v1.17.0.tar.gz ==> Validating source files with sha1sums... v1.17.0.tar.gz ... FAILED ==> ERROR: One or more files did not pass the validity check! error: failed to download sources for 'conky-lua-nv-1.17.0-1': error: packages failed to build: conky-lua-nv-1.17.0-1

agorg_louk commented on 2022-12-13 18:44 (UTC)

Please .vim file installation, currently you are creating a nested folder, leading into: Cannot source a directory: "/usr/share/vim/vimfiles/ftdetect/conkyrc.vim" in neovim. Patch:

diff --git a/PKGBUILD b/PKGBUILD
index f27502f..04b42ad 100644
@@ -74,8 +74,8 @@ package() {
   cd ${srcdir}/${_pkgname}-${pkgver}
   make -C build DESTDIR=${pkgdir} install
   install -D -m644 COPYING -t ${pkgdir}/usr/share/licenses/${pkgname}
-  install -D -m644 build/extras/vim/syntax/conkyrc.vim -t "${pkgdir}"/usr/share/vim/vimfiles/syntax/conkyrc.vim
-  install -D -m644 extras/vim/ftdetect/conkyrc.vim -t "${pkgdir}"/usr/share/vim/vimfiles/ftdetect/conkyrc.vim
+  install -D -m644 build/extras/vim/syntax/conkyrc.vim -t "${pkgdir}"/usr/share/vim/vimfiles/syntax/
+  install -D -m644 extras/vim/ftdetect/conkyrc.vim -t "${pkgdir}"/usr/share/vim/vimfiles/ftdetect/

 # vim:ts=2:et:sw=2

Foucault commented on 2022-08-06 17:23 (UTC) (edited on 2022-08-06 17:27 (UTC) by Foucault)

When the package was originally created [community] conky had been being built with neither lua nor nvidia. It still doesn't include cairo or rsvg support, so if you want these these two you get two additional AUR packages (with and without nvidia support).

yochananmarqos commented on 2022-08-06 17:15 (UTC)

The Arch community package has NVIDIA=ON. What's the point in having both conky-lua-nv and conky-lua packages?

grimvik90 commented on 2022-07-02 22:04 (UTC)

hola gente paso por aca para ver si hay alguna otra solucion para resolver el siquiente error, he intentado con las soluciones que aca mensionan pero eso no ha servido para mi

[ 93%] Building CXX object tests/CMakeFiles/test-conky.dir/ In file included from /usr/include/signal.h:328, from /home/victorn/Downloads/conky-lua-nv/src/conky-1.12.2/tests/catch2/catch.hpp:5730, from /home/victorn/Downloads/conky-lua-nv/src/conky-1.12.2/tests/ /home/victorn/Downloads/conky-lua-nv/src/conky-1.12.2/tests/catch2/catch.hpp:8351:14: error: call to non-‘constexpr’ function ‘long int sysconf(int)’ 8351 | 32768 >= MINSIGSTKSZ ? 32768 : MINSIGSTKSZ; | ^~~~~~~~~~~ In file included from /usr/include/bits/sigstksz.h:24: /usr/include/unistd.h:640:17: note: ‘long int sysconf(int)’ declared here 640 | extern long int sysconf (int __name) __THROW; | ^~~~~~~ /home/victorn/Downloads/conky-lua-nv/src/conky-1.12.2/tests/catch2/catch.hpp:8409:41: error: size of array ‘altStackMem’ is not an integral constant-expression 8409 | char FatalConditionHandler::altStackMem[sigStackSize] = {}; | ^~~~~~~~~~~~ make[2]: [tests/CMakeFiles/test-conky.dir/build.make:76: tests/CMakeFiles/test-conky.dir/] Error 1 make[1]: [CMakeFiles/Makefile2:1253: tests/CMakeFiles/test-conky.dir/all] Error 2 make: *** [Makefile:166: all] Error 2 ==> ERROR: A failure occurred in build(). Aborting...  ╱  ~/Downloads/conky-lua-nv ╱  4m 15s 

RaZorr commented on 2022-03-22 14:22 (UTC) (edited on 2022-03-22 14:22 (UTC) by RaZorr)

Yes, upstream also produces this issue. There is already an open issue at conky repo

Another thread that may be relevant:

Foucault commented on 2022-03-22 11:49 (UTC)

I am trying to follow the repo PKGBUILD as close as possible to minimise any differences between this and the official package. And for regular releases MAINTAINER_MODE should actually be ON. This is most likely a bug in upstream conky that will resolve itself at some later release. If upstream git does not exhibit the issue then maybe we can produce a patch to fix that.

RaZorr commented on 2022-03-22 11:45 (UTC) (edited on 2022-03-22 11:45 (UTC) by RaZorr)

@Foucault Any reason why MAINTAINER_MODE=off is not the default option for the PKGBUILD ?