Package Details: coolkey 1.1.0_36-2

Git Clone URL: https://aur.archlinux.org/coolkey.git (read-only, click to copy)
Package Base: coolkey
Description: Provides PKCS11 module support for smart-card readers, now with 144k smartcard/CAC support and downstream Fedora patches.
Upstream URL: http://directory.fedora.redhat.com/wiki/CoolKey
Licenses: GPL
Submitter: arch-nemesis
Maintainer: n17ikh
Last Packager: n17ikh
Votes: 16
Popularity: 0.000057
First Submitted: 2009-06-19 15:05
Last Updated: 2019-10-24 22:50

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

arch-nemesis commented on 2011-08-14 05:57

@theflyingfool
Thanks for the heads up. It was failing the MD5 hash. The version number is the same on the fedora download site, but the MD5 had changed. The package is now updated and should compile fine now.

theflyingfool commented on 2011-08-14 03:10

Fails to build

==> Continue building coolkey ? [Y/n]
==> ---------------------------------
==>
==> Building and installing package
==> Making package: coolkey 1.1.0_19-3 (Sun Aug 14 12:07:21 KST 2011)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
-> Found coolkey-1.1.0-19.fc15.src.rpm
==> ERROR: Integrity checks are missing.
==> ERROR: Makepkg was unable to build coolkey.

n17ikh commented on 2011-03-01 20:04

Whoops, wrong URL in my PKGBUILD. the correct URL is in buckethead's comment below.

n17ikh commented on 2011-03-01 19:56

It builds just fine for me from the following PKGBUILD:
http://aur.pastebin.com/3mg9yARd

I suspect the fedora-compiled binary won't work well on a non-red-hat-based system for a number of reasons.

arch-nemesis commented on 2011-02-23 19:18

It installs okay now, but I can't get firefox to load it... I'll have do do a bit of research on the fedora page.

arch-nemesis commented on 2011-02-23 19:15

I couldn't get the source to compile, so I changed to binary sources. Should still work with both 32 and 64 bit architectures, although I don't have a 32 bit machine to test it on.

arch-nemesis commented on 2011-02-23 17:36

Thanks buckethead. Updating the PKGBUILD now.

arch-nemesis commented on 2011-02-23 17:32

Thanks again n17ikh.
I updated the PKGBUILD, and cited your name.

Anonymous comment on 2011-02-14 02:58

Source should be http://download.fedora.redhat.com/pub/fedora/linux/development/rawhide/source/SRPMS/coolkey-1.1.0-19.fc15.src.rpm

arch-nemesis commented on 2010-09-19 06:32

Great work, n17ikh.
your PKGBUILD works perfectly and I updated the package from it.

I also want to add, that DOD smartcard users may want to switch to cackey instead of coolkey. coolkey DOES still work for DOD cards (I'm using mine right now), but cackey is newer and is specifically implimented for DOD common access cards. Currently, you will need a working CAC card in order to download the cackey software, so you will need to either use another computer to get it or use coolkey first and then switch to cackey.