Package Details: coursera-dl-git 0.11.5.r11.g10ba6b8-1

Git Clone URL: (read-only, click to copy)
Package Base: coursera-dl-git
Description: Script for downloading videos and naming them
Upstream URL:
Licenses: LGPL3
Conflicts: coursera-dl
Provides: coursera-dl
Submitter: ilpianista
Maintainer: hexchain
Last Packager: hexchain
Votes: 32
Popularity: 0.000000
First Submitted: 2012-09-10 15:59 (UTC)
Last Updated: 2021-10-04 12:51 (UTC)

Latest Comments

1 2 3 4 Next › Last »

hexchain commented on 2021-10-04 12:52 (UTC)

@leuko: fixed, thanks!

leuko commented on 2021-10-04 07:31 (UTC)

Note that current version has problems with a deprecated method of HTMLParser. There is already a PR which is still waiting. To apply it in PKGBUILD change prepare() as follows:

prepare() {
  export LC_CTYPE="en_US.UTF-8"
  cd "$srcdir/$_gitname"
  wget -O htmlparser.patch ''
  git apply htmlparser.patch

nanners commented on 2017-06-15 09:48 (UTC)

Unlisted dependency: configargparse pip install configargparse and running coursera-dl should then show the help rather than python error.

hexchain commented on 2016-03-31 13:23 (UTC)

@zsrkmyn: fixed, thanks!

zsrkmyn commented on 2016-03-31 12:31 (UTC)

==> Starting package()... Traceback (most recent call last): File "./", line 60, in <module> 'Generate README.rst from via pandoc!\n\nExample: ' File "./", line 50, in read_file lines = File "/usr/lib/python3.5/encodings/", line 26, in decode return codecs.ascii_decode(input, self.errors)[0] UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 19273: ordinal not in range(128) Solution: add ``` prepare() { export LC_CTYPE=en_US.UTF-8 } ``` to PKGBUILD.

hexchain commented on 2016-02-21 08:17 (UTC)

I've included html5lib in dependencies and updated PKGBUILD. Coursera-dl itself requires html5lib>=1.0b2 in its requirements.txt but currently I have not encountered any problems with the one in community. So I'm overwritting the launcher script generated by setuptools with the one provided by author. Also there's a coursera-dl package (without -git), which is considered more stable.

anatolik commented on 2015-07-04 22:20 (UTC)

python-html5lib seems hard dependency now: Traceback (most recent call last): File "/usr/bin/coursera-dl", line 6, in <module> coursera_dl.main() File "/usr/lib/python3.4/site-packages/coursera/", line 1022, in main result = download_class(args, class_name) File "/usr/lib/python3.4/site-packages/coursera/", line 919, in download_class args.intact_fnames, subtitle_language) File "/usr/lib/python3.4/site-packages/coursera/", line 255, in parse_syllabus soup = BeautifulSoup(page) File "/usr/lib/python3.4/site-packages/coursera/", line 63, in <lambda> BeautifulSoup = lambda page: BeautifulSoup_(page, 'html5lib') File "/usr/lib/python3.4/site-packages/bs4/", line 152, in __init__ % ",".join(features)) bs4.FeatureNotFound: Couldn't find a tree builder with the features you requested: html5lib. Do you need to install a parser library?

tklee commented on 2014-07-12 03:52 (UTC)

I'm sorry I made a mistake of falgging it out-of-date. The PKGBUILD is still valid and up-to-date. Could you remove the wrong flag?

hexchain commented on 2014-03-30 09:30 (UTC)

Updated for Python 3.4

dummyano commented on 2014-03-30 02:51 (UTC)

Please update path for python 3.4. Thanks for mantaining this!