Package Details: crowdsec 1.4.5-1

Git Clone URL: https://aur.archlinux.org/crowdsec.git (read-only, click to copy)
Package Base: crowdsec
Description: The open-source and collaborative IPS
Upstream URL: https://crowdsec.net
Licenses: MIT
Provides: crowdsec
Submitter: solveit
Maintainer: solveit
Last Packager: solveit
Votes: 11
Popularity: 1.34
First Submitted: 2021-12-01 20:49 (UTC)
Last Updated: 2023-01-26 17:03 (UTC)

Latest Comments

1 2 Next › Last »

solveit commented on 2022-03-14 16:16 (UTC) (edited on 2022-03-14 21:02 (UTC) by solveit)

Edit 2: After emailing with crowdsec, I have an acceptable solution to the build_tag. I will implement it in the next PKGBUILD.

Edit 1: I didn't notice this, but your version shows up as 1.3.0. The latest revision is 1.3.2. While the build_tag still shows up as blank, it is not asking me to update when accessing app.crowdsec.net

I will have to reach out to crowdsec as I don't know what they're looking to see. The issue is that when you download the source from github, it is not seen as a repository. This is why I have to manually adjust the BUILD_VERSION in the PKGBUILD file.

The Makefile defines the missing BUILD_TAG using git rev-parse HEAD. This is then used in the pkg/cwversion/version.go file with the Show function. This defines the version for cscli as BUILD_VERSION-BUILD_TAG.

They also have a "static" release that might be a better option.

Byter commented on 2022-03-14 13:59 (UTC) (edited on 2022-03-14 14:00 (UTC) by Byter)

While adding new scenarios I noticed that cscli version still returns v1.3.0-.

Is there something I need to clear or is this actually a crowdsec bug this time? I tried to reinstall with a fresh build.

This also prevents me from installing scenarios that require the newest version, and it displays "1.3.0" in the Crowdsec Console, nagging me to update :D

Byter commented on 2022-03-10 16:41 (UTC)

Thanks! I'll update straight away :D

solveit commented on 2022-03-09 15:58 (UTC)

I think I figured it out now. My error was in the sed command used to adjust the BUILD_VERSION in the Makefile. For some reason, the original one suggested by @stephen304 no longer worked and my adjustments add an additional ' into the version.

I performed a clean install and it properly installed whereas it did not with the -1 revision.

solveit commented on 2022-03-09 15:19 (UTC)

@Byter - I have been out on business travel that last couple of days and haven't had an opportunity to address it yet. I'll see if I can get to it tonight.

Byter commented on 2022-03-08 18:49 (UTC)

I originally reported the bug here but was told this is a problem with the AUR package: https://github.com/crowdsecurity/crowdsec/issues/1324

It seems the version being used has a character in it that makes connection to the CAPI impossible. Could this have anything to do with the sed'd package version?

solveit commented on 2022-01-26 20:10 (UTC)

I've updated the package and removed the firewalls as a requirement. I also made a few adjustments to the post_upgrade command in order to better handle the upgrade versus binupgrade commands from crowdsec.

solveit commented on 2022-01-17 15:34 (UTC)

Good point. I will make the adjustments to the packages during the next release. I would recommend looking at crowdsec's page to make sure firewalld is supported. I presume it would work with ipset, but it's not listed as a supported solution.

Madic commented on 2022-01-15 12:26 (UTC)

Are ipset and iptables really dependencies from crowdsec and not from cs-firewall-bouncer? Could they also be optional dependencies for cs-firewall-bouncer? Because I would use the firewall-bouncer with firewalld

solveit commented on 2022-01-12 15:29 (UTC)

Thanks Stephen304. That's cleaner than having to resort to patching Makefile directly.

I was able to update from 1.2.2 -> 1.2.3 in an upgrade, so hopefully the upgrade process should be sorted out now.