Package Details: cryptomator 1.4.7-1

Git Clone URL: (read-only)
Package Base: cryptomator
Description: Multiplatform transparent client-side encryption of your files in the cloud.
Upstream URL:
Licenses: GPL3
Submitter: Foxboron
Maintainer: Foxboron (overheadhunter, tobihagemann)
Last Packager: overheadhunter
Votes: 41
Popularity: 1.272738
First Submitted: 2016-04-03 17:36
Last Updated: 2019-04-12 12:26

Latest Comments

1 2 3 4 Next › Last »

mirolPirol commented on 2019-03-04 14:16

Cryptomator wird dringend gebraucht! Wann kommt v 1.5 für Linux? Cryptomator is very highly needed - when will v 1.5 be available

tobihagemann commented on 2019-01-20 09:32

For anyone stumbling upon this comment: I unflagged the "out-of-date" status because 1.4.2 is a Windows-only hotfix. Currently, 1.4.1 is the most recent version for Linux.

ivand commented on 2018-09-25 16:56

Hey, could you fix the cryptomator startup script (/usr/bin/cryptomator) to use the same java version as is set in path?

Until 1.4 is out, it doesn't work if your default java on the system is higher than java-8

To fix this, replace the following lines:

export PATH="/usr/lib/jvm/java-8-openjdk/jre/bin/:$PATH"
exec /usr/bin/java \


export PATH="/usr/lib/jvm/java-8-openjdk/jre/bin/:$PATH"
exec /usr/lib/jvm/java-8-openjdk/jre/bin/java \

or better


export PATH="$javapath:$PATH"
exec $javapath/java \

binaryanomaly commented on 2018-09-03 15:42

According to the discussions in the openjfx bug the missing gtk2 dependency should be added to the cryptomator package. (Since openjfx itself does not need to be dependent on gtk2 to function).

binaryanomaly commented on 2018-09-02 08:49

Thanks fawn. I opened a bug over here so java-openjfx maintainers can check if there's something wrong. The Wiki page mentions the dependency but I don't see it when I do "pacman -Qii java-openjfx".

fawn commented on 2018-09-02 08:18

To: binaryanomaly. You're right. According this thread GTK 2.18 or greater is required to run JavaFX. Java-openjfx package should have gtk2 as dependency.

binaryanomaly commented on 2018-09-01 21:04

Hmm, "sudo pacman -S gtk2" fixed it. Am I wrong to suspect that this might be a missing dependency?

fawn commented on 2018-09-01 20:08

This error is java-openjfx related. Check if You have multiple versions of JDK/JRE installed.

binaryanomaly commented on 2018-09-01 15:32

@fawn: Thanks for your feedback.

I did indeed initially choose by mistake openjdk10. Then removed cryptomator with "pacman -Rcsn cryptomator", deleted the cloned dir, cloned again and re-installed it with "makepkg -si" but still have the same error.

Any ideas how this could be fixed? Re-installing the whole system from scratch would be a lot of effort.

fawn commented on 2018-09-01 15:14

To: binaryanomaly

For me, it's working with openjdk8 not with openjdk10.