Package Details: dupeguru 4.3.1-1

Git Clone URL: https://aur.archlinux.org/dupeguru.git (read-only, click to copy)
Package Base: dupeguru
Description: Find duplicate files with various contents, using perceptual diff for pictures
Upstream URL: https://dupeguru.voltaicideas.net/
Licenses: GPL3
Conflicts: dupeguru-git, dupeguru-me, dupeguru-pe, dupeguru-se
Provides: dupeguru
Submitter: dangoldbj
Maintainer: fuan_k
Last Packager: fuan_k
Votes: 89
Popularity: 0.86
First Submitted: 2016-10-25 11:55 (UTC)
Last Updated: 2022-07-09 10:15 (UTC)

Pinned Comments

itsnotme commented on 2019-07-21 13:08 (UTC)

If anyone is wondering why the source has changed, Dupeguru's website says the maintainer has changed. And so the link https://www.hardcoded.net/dupeguru/ leads us to https://dupeguru.voltaicideas.net/ which in turn has a link to https://github.com/arsenetar/dupeguru/ which is the GitHub repo the sources are downloaded from. So the source change is legitimate.

Latest Comments

1 2 3 4 5 6 .. 12 Next › Last »

harmtemolder commented on 2022-11-28 11:56 (UTC)

When trying to start dupeguru 4.3.1-1 I get:

ModuleNotFoundError: No module named 'core.pe._block'

Creating these links fixed this for now (python --version returns Python 3.10.1):

sudo ln /usr/share/dupeguru/core/pe/_cache.cpython-39-x86_64-linux-gnu.so /usr/share/dupeguru/core/pe/_cache.cpython-310-x86_64-linux-gnu.so
sudo ln /usr/share/dupeguru/core/pe/_block.cpython-39-x86_64-linux-gnu.so /usr/share/dupeguru/core/pe/_block.cpython-310-x86_64-linux-gnu.so
sudo ln /usr/share/dupeguru/qt/pe/_block_qt.cpython-39-x86_64-linux-gnu.so /usr/share/dupeguru/qt/pe/_block_qt.cpython-310-x86_64-linux-gnu.so

This seems to happen every once in a while, e.g.: https://github.com/arsenetar/dupeguru/issues/519

Is this something we could fix once and for all? Or is it up to the developer to do so?

auris commented on 2022-06-05 12:07 (UTC)

@bartoszer: The python-polib package is not available in the official repositories. You must install it from the AUR before installing dupeguru. The other missing dependencies are then automatically installed by pacman.

bartoszer commented on 2022-05-28 13:08 (UTC)

makepkg -si

error: target not found: python-polib
==> ERROR: 'pacman' failed to install missing dependencies.
==> Missing dependencies:
  -> python-polib
  -> python-semantic-version
  -> python-xxhash
  -> python-mutagen
  -> python-send2trash

Seems that some deps are no longer available?

fuan_k commented on 2021-12-20 23:30 (UTC)

@bonob thanks, for some reason I did not notice it when I searched for it.

bonob commented on 2021-12-20 07:04 (UTC)

You noted in the last update that python-send2trash is not in the AUR anymore. It is in community though, if that's relevant?

Rus commented on 2021-12-19 23:54 (UTC) (edited on 2021-12-19 23:55 (UTC) by Rus)

It worked after the PKGBUILD update, thanks

fuan_k commented on 2021-12-19 23:49 (UTC)

@Rus: I would need more information, but I suspect you might have an outdated python-polib installed on your system. Pushed a possible workaround, let me know if it still fails.

Another possible solution in that case would be to change python -m venv env --system-site-packages to just python -m venv env to avoid using packages already installed system-wide.

Rus commented on 2021-12-19 17:29 (UTC) (edited on 2021-12-19 17:30 (UTC) by Rus)

WARNING: Location 'deps' is ignored: it is either a non-existing path or lacks a specific scheme.
ERROR: Could not find a version that satisfies the requirement polib>=1.0.4 (from versions: none)
ERROR: No matching distribution found for polib>=1.0.4

fuan_k commented on 2021-02-01 01:33 (UTC) (edited on 2021-03-23 23:00 (UTC) by fuan_k)

@JohnRobson can you please be more specific? It builds fine in a clean chroot, I don't see what you are missing. python-polib package just got updated, maybe you need to update it.

JohnRobson commented on 2021-01-31 20:13 (UTC)

python-polib version 1.1.0-3, please, fix the "requirements.txt"