Package Details: eidklient 3.0.0-1

Git Clone URL: https://aur.archlinux.org/eidklient.git (read-only)
Package Base: eidklient
Description: Slovak eID Client
Upstream URL: https://www.slovensko.sk/
Keywords: eac_mw_klient
Licenses: custom
Submitter: piecka
Maintainer: piecka
Last Packager: piecka
Votes: 4
Popularity: 0.201705
First Submitted: 2017-07-07 20:33
Last Updated: 2018-11-21 23:26

Pinned Comments

piecka commented on 2018-11-21 23:30

LD_PRELOAD is set in the desktop entry for the application to work correctly.

If you want to run the application in a terminal, use this command: LD_PRELOAD=/usr/lib/libcurl-openssl-1.0.so EAC_MW_klient

Latest Comments

piecka commented on 2018-11-21 23:30

LD_PRELOAD is set in the desktop entry for the application to work correctly.

If you want to run the application in a terminal, use this command: LD_PRELOAD=/usr/lib/libcurl-openssl-1.0.so EAC_MW_klient

piecka commented on 2018-11-21 23:28

I've updated the PKGBUILD to reflect the new version 3.0.0.

8472 commented on 2018-11-21 18:14

It seems, that AUR's "libcurl-openssl-1.0" package installation is indeed inevitable dependency, currently.

I've updated the Arch's wiki with what I hope could be considered a working installation guide, for both, eidklient v3 and the disig-web-signer.

@helourx: Check the wiki for howto resolve the dependencies. However, I cannot test this online functionality myself, so I'll keep that to others.

@all: Feel free to update the wiki on any discrepancies you'll discover.

helourx commented on 2018-11-20 17:03

Install the openssl-1.0, libcurl-compat, and libcurl-openssl-1.0, then run the eIDklient with: LD_PRELOAD=/usr/lib/libcurl-openssl-1.0.so EAC_MW_klient. Tested on Manjaro 18.0. BTW: I have problem with the disig websigner apps instalation and running because of dependency on the gdebi and libgl1-mesa-glx. Has anyone tried to run it without problems?

piecka commented on 2018-11-17 21:14

I ackonwledge the application doesn't work at the moment.

Unfortunately, there's no easy fix. The application requires OpenSSL 1.0. However it also requires QT4. QT4 in Arch is linked against a newer OpenSSL (1.1). To my understanding, this causes a clash.

As this package is only a repack of a binary application, I have no way to fix the linking problem/incompatibility with OpenSSL 1.1.

I have discussed the problem with the vendor. However, to no avail. Arch Linux is unsupported by the vendor. I'll try this in a new Ubuntu 18.10 which also uses OpenSSL 1.1. However, it seems in Ubuntu QT4 is not linked against libssl at compile time. Ubuntu is officially supported by vendor.

D.Launcher application is distributed as an installer by the vendor. The installer is supposed to be run as a regular user and installed to the user's home directory. It's possible to make it into a package, but I think it wouldn't very practical.

martin022 commented on 2018-10-22 21:05

update please, it is not working for now. also can you make packages for web signer?

8472 commented on 2018-08-27 05:23

@piecka: no need to rename the package. You never know when the vendor will change it again to whatever else. At least it is clear what is it under it's present name.

piecka commented on 2018-08-26 22:07

PKGBUILD updated for the new version of upstream app.

The source Debian package has been renamed to eac_mw_klient, as 8472 noted. I'm leaving the name of Arch package unchanged for now, but I'll consider creating a new package with a corresponding name in future.

8472 commented on 2018-08-21 20:13

@Maintainer:

I've updated the wiki at https://wiki.archlinux.org/index.php/Slovak_eID_card_reader_(Slovensk%C3%BD) There are several changes at point 4, 5, 6, 8 + the program name in "Prvé spustenie" changed, also the path in "Povolenie automatického spúšťania eID klienta" has changed.. The vendor has changed completely the naming from "eidklient" to "eac_mw_klient" at mostly all places, so beware of that. Feel free to annotate any issues I might've missed.

martin022 commented on 2018-08-21 18:12

please update, there is v2 out and the old packages which are downloading are not working since it's out.