Package Details: electrum-git 4.5.5.r114.gef536493e-1

Git Clone URL: https://aur.archlinux.org/electrum-git.git (read-only, click to copy)
Package Base: electrum-git
Description: Lightweight Bitcoin wallet
Upstream URL: https://github.com/spesmilo/electrum
Keywords: bitbox bitcoin coldcard cryptocurrency keepkey ledger trezor wallet
Licenses: MIT
Conflicts: electrum
Provides: electrum
Submitter: oneeyed
Maintainer: pizzaman
Last Packager: pizzaman
Votes: 38
Popularity: 0.004358
First Submitted: 2012-08-15 12:32 (UTC)
Last Updated: 2024-05-30 04:05 (UTC)

Latest Comments

1 2 3 4 Next › Last »

Necromortis commented on 2024-06-08 18:17 (UTC) (edited on 2024-06-08 18:19 (UTC) by Necromortis)

Try connect trezor, but receive error:

 trezor: (error getting device infos)
    Library version for 'trezor' is incompatible.
    Installed: 0.13.8, Needed: 0.13.0 <= x < 0.14
    Make sure you install it with python3

tuxxx commented on 2024-04-15 12:32 (UTC)

With the upcoming change in electrums jade library (https://github.com/spesmilo/electrum/pull/9007) the needed python version will change from python-cbor to python-cbor2

pizzaman commented on 2022-06-21 09:53 (UTC)

@nulldev Thanks. Fixed.

nulldev commented on 2022-06-21 01:52 (UTC)

This package fails to package() because upstream has converted their README.rst -> README.md

pizzaman commented on 2022-06-02 03:14 (UTC) (edited on 2022-06-02 03:15 (UTC) by pizzaman)

@ordtrogen As per https://wiki.archlinux.org/title/Arch_User_Repository#Build_the_package

In reference to the flag for `makepkg`:

"-s/--syncdeps automatically resolves and installs any dependencies with pacman before building. If the package depends on other AUR packages, you will need to manually install them first."

So yes you need to install the other AUR dependencies manually. Or you can use an aur helper https://wiki.archlinux.org/title/AUR_helpers , I like trizen https://aur.archlinux.org/packages/trizen

ordtrogen commented on 2022-06-02 02:38 (UTC)

When I do "makepkg -si", I get a bunch of errors related to missing dependencies (below is the output in my native Swedish) Basically "saknade beroenden" is "missing dependencies"

I'm used to the process automatically installing what's required. In this case, do I have to install these depencies manually?

==> Installerar saknade beroenden... FEL: Kunde inte hitta målet python-aiorpcx-git>=0.22 FEL: Kunde inte hitta målet python-aiorpcx-git<0.23 ==> FEL: 'pacman' misslyckades att installera saknade beroenden ==> Saknade beroenden: -> python-qdarkstyle -> python-aiorpcx-git>=0.22 -> python-aiorpcx-git<0.23 -> python-cryptography ==> Kontrollerar byggberoenden... ==> FEL: Kan inte lösa alla beroenden.

pizzaman commented on 2021-05-19 02:05 (UTC) (edited on 2021-06-05 12:16 (UTC) by pizzaman)

@Bfg Opened an issue upstream. https://github.com/spesmilo/electrum/issues/7307

Update: This was fixed upstream.

bfg commented on 2021-05-17 17:13 (UTC)

Cannot compile. It ends with testutils error (test ip address)


______________________________________________ TestUtil.test_is_ip_address _______________________________________________

self = <electrum.tests.test_util.TestUtil testMethod=test_is_ip_address>

    def test_is_ip_address(self):
        self.assertTrue(is_ip_address("127.0.0.1"))
>       self.assertTrue(is_ip_address("127.000.000.1"))
E       AssertionError: False is not true

electrum/tests/test_util.py:234: AssertionError

toby44 commented on 2019-06-05 05:39 (UTC)

@pizzaman , thanks did have to force remove the old aiorpcx but worked after that :-)

pizzaman commented on 2019-06-05 02:56 (UTC)

@toby44 New version of python-aiorpcx was released but community repo hasn't upgraded yet, fixed by changing dependency to new python-aiorpcx-git

if you run into any trouble delete manually old python-aiorpcx

sudo pacman -Rdd python-aiorpcx