Package Details: emacs-pretest 28.0-0.923

Git Clone URL: https://aur.archlinux.org/emacs-pretest.git (read-only, click to copy)
Package Base: emacs-pretest
Description: The extensible, customizable, self-documenting real-time display editor -- pretest version. -- Retagged because msnspk is an idiot.
Upstream URL: http://www.gnu.org/software/emacs/emacs.html
Licenses: GPL3
Conflicts: emacs
Provides: emacs
Submitter: Schnouki
Maintainer: toropisco
Last Packager: toropisco
Votes: 7
Popularity: 0.000000
First Submitted: 2011-11-17 16:48 (UTC)
Last Updated: 2022-06-03 21:59 (UTC)

Required by (424)

Sources (2)

Latest Comments

msnspk commented on 2022-04-06 16:59 (UTC)

Elementary school actually, I just turned six.

Anyways, I'm not sure what "advice" you're trying to give me between the insults, but I sincerely hope, if for nothing more than your own health, that one day you learn to not be so bothered by "frivolous bug reports". There's no way this much pent-up anger can be healthy. Have a good day

toropisco commented on 2022-04-06 16:47 (UTC)

msnspk. No you didn't hit a nerve, just arose my utter contempt. I am taking the opportunity to give you a piece of advice that will allow you live beyond your teens and perhaps have a decent adult life. You have reminded me why I don't teach undergraduates anymore. Or are you a middle-schooler?

msnspk commented on 2022-04-06 16:28 (UTC) (edited on 2022-04-06 16:28 (UTC) by msnspk)

I mentioned in my message that I was not sure whether you normally updated to stable or not, and that I would unflag if you said you didn't (and I have)

In hindsight I should have more thoroughly checked the update log first, but apparently I hit a nerve lmao

toropisco commented on 2022-04-06 16:12 (UTC)

msnpk you really are an idiot. Have you not noticed that I AM the person who has maintained this package for the last 6 years?

And how come you do not understand the concept of PRETEST? Please do not bother maintainers with frivolous bug reports.

msnspk commented on 2022-04-06 16:07 (UTC) (edited on 2022-04-06 16:07 (UTC) by msnspk)

"IDOT" reporting for duty I guess?

toropisco commented on 2022-04-06 12:20 (UTC)

msnspk, are you an IDOT? A pretest package is not a release package. Get a brain transplant!

mattsawyer77 commented on 2018-05-15 17:06 (UTC)

This was working until a recent upgrade, now I get

emacs: error while loading shared libraries: libMagickWand-6.Q16HDRI.so.5: cannot open shared object file: No such file or directory

I do have imagemagick installed.

toropisco commented on 2017-10-12 22:38 (UTC)

Version 26.0.90 is broken under arch, so no update yet.

j3thr0 commented on 2016-10-27 16:09 (UTC)

To solve the unknow public key error just do: -> % gpg --recv-keys 233587A47C207910

oniram commented on 2016-09-14 13:56 (UTC)

@vorbote Thanks. I really don't know anything about PGP key signing.

toropisco commented on 2016-09-14 13:52 (UTC)

@oniram No. Not an error. You need to import the key to the personal gnupg public keyring of the user under which you run makepkg by hand. It doesn't happen by magic. If you don't want PGP signature verification, run makepkg with the "--skippgpcheck" option.

oniram commented on 2016-09-14 13:42 (UTC)

I'm seeing this weird error: emacs-25.1-rc2.tar.xz ... FAILED (unknown public key 233587A47C207910) That unknown key is just the last digits of the key given in the PKGBUILD.

toropisco commented on 2016-09-01 17:37 (UTC)

OK, should be fixed now. I promise to start using my reading glasses. Phew!

toropisco commented on 2016-09-01 17:24 (UTC)

Argh! I botched the fix. I'll work on that ASAP.

lizzie commented on 2016-08-31 18:50 (UTC)

Thanks for fixing that, but now the pkgrel is 0.2.1, which doesn't seem to be allowed: "==> ERROR: pkgrel must be a decimal, not 0.2.1.".

lizzie commented on 2016-08-30 18:55 (UTC)

The author has misspelled 'validpgpkeys' as 'validpgkkeys'. This causes the error that jeffles mentioned.

toropisco commented on 2016-04-04 22:32 (UTC) (edited on 2016-04-04 22:33 (UTC) by toropisco)

jeffles, the key is perfectly valid. You should use hkp://keys.gnupg.net as it is more trustworthy and complete. Keyservers do not work as you think. Once a key is published it cannot be removed, only revoked by uploading a revocation certificate created by the owner of such key (or whoever stole his revocation certificate...). Else, where is the web of trust left?

jeffles commented on 2016-04-04 22:05 (UTC)

This fails for me. It says: the public key 28D3BED851FDF3AB57FEF93C233587A47C207910 is not trusted. I think it has been revoked: $ gpg --search-keys 28D3BED851FDF3AB57FEF93C233587A47C207910 gpg: searching for "28D3BED851FDF3AB57FEF93C233587A47C207910" from hkps server hkps.pool.sks-keyservers.net gpg: key "28D3BED851FDF3AB57FEF93C233587A47C207910" not found on keyserver

jschwab commented on 2016-03-02 18:57 (UTC)

The next pretest (25.0.92) is now available. https://lists.gnu.org/archive/html/emacs-devel/2016-03/msg00024.html

toropisco commented on 2016-02-14 15:42 (UTC)

Me again. The second pretest version is out. --------- snews://news.eternal-september.org:563/mailman.4592.1455396584.843.info-gnu-emacs@gnu.org ______ Hi! The second pretest for what will be the 25.1 release of Emacs (the extensible text editor) is available at ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-25.0.91.tar.xz You can get the PGP signature at ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-25.0.91.tar.xz.sig Please give it as much testing as you can. As always, if you encounter problems building or using Emacs, send a report to bug-gnu-emacs@gnu.org with full details (if possible, use M-x report-emacs-bug). Thanks for helping to test Emacs. Nico

toropisco commented on 2016-02-14 14:34 (UTC)

Hi Schnouki, I flagged this package some days ago, as the first prestest for 25.1 is already out. Let me know if you want me to lend you a hand with this. Cheers.

Schnouki commented on 2014-06-27 09:05 (UTC)

@Javafant another solution is to add "--without-giflib" to the "./configure" line in this PKGBUILD. But anyway, the latest version (24.3.92) builds just fine against giflib 5.1.0 :)

cocreature commented on 2014-06-17 19:28 (UTC)

Build seems to be broken with giflib 5.1.0. Downgrading giflib works

Schnouki commented on 2012-02-28 13:28 (UTC)

Updated, thanks!

commented on 2012-02-28 12:40 (UTC)

New version available: http://permalink.gmane.org/gmane.emacs.devel/148805