Package Details: epson-inkjet-printer-escpr 1.7.10-1

Git Clone URL: https://aur.archlinux.org/epson-inkjet-printer-escpr.git (read-only, click to copy)
Package Base: epson-inkjet-printer-escpr
Description: Epson Inkjet Printer Driver (ESC/P-R) for Linux
Upstream URL: http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
Licenses: GPL2
Submitter: FFY00
Maintainer: nicolas-bs (hcartiaux)
Last Packager: hcartiaux
Votes: 41
Popularity: 1.50
First Submitted: 2019-04-26 09:00
Last Updated: 2021-05-05 09:56

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

mokkurkalve commented on 2019-04-27 14:55

Adding autoreconf -vfi before ./configure was all it took to build ok here.

Abrasion commented on 2019-04-27 13:12

autoreconf -vfi gave me an error about configure.ac configure.in required

i'd try again and now that work fine ... why ? no clue

Chazza commented on 2019-04-27 12:57

@Abrasion, there's no need to call aclocal separately if you are calling autoreconf. autoreconf calls all the autotools (including aclocal) in the correct order. Just a single call of autoreconf -vfi before calling ./configure will suffice.

As for the checksums, if you install pacman-contrib, you can just run updpkgsums and that will auto-update all the checksums in the PKGBUILD, without needing to insert them manually.

Abrasion commented on 2019-04-27 12:35

@gun26 anytime

gun26 commented on 2019-04-27 12:28

@Chazza thanks, I uninstalled my F-ed up versions of automake. @Abrasion, thanks, I incorporated your changes in the PKGBUILD and it builds and installs fine here. For anyone not willing to edit the PKGBUILD themselves per Abrasion's instructions, I put my own modified PKGBUILD with just his changes up on Pastebin here: https://pastebin.com/z2z1tZPV

Abrasion commented on 2019-04-27 04:00

Add line : autoreconf --install Before : ./configure \

Add line : aclocal Before : make (the one with no arg)

Change : e278cf3db482aed862c2343a2ee5147fa0e53b14d80b9fdf6907e35eae0235a440b2dfe480cbae28dc4e00c0e7cf119e6b870480a69759a6df4e0c676aec5229

For : ff4f736ec884c4d2354a83c89ee535732cb414ef0c6443bdc8ec869f889f486b242d76e143ad59d61b182231697dfe3bdf68122cb8aae873a9776ce109a07dab

that should workd fine

simona commented on 2019-04-27 00:43

==> Validazione di source file con sha512sums... epson-inkjet-printer-escpr-1.6.40-1lsb3.2.tar.gz ... Verificato bug_x86_64.patch ... NON RIUSCITO ==> ERRORE: Uno o più file non hanno superato il controllo di validità! Error downloading sources: epson-inkjet-printer-escpr

Chazza commented on 2019-04-26 16:11

@gnu26 No need to install any different version of automake. It's just the project's autotools config files are out of date. In the PKGBUILD add the following line:

autoreconf -vfi

before the configure line and it will build just fine. I'm surprised that isn't in the PKGBUILD...

gun26 commented on 2019-04-26 15:57

Won't build here. Even with Abrasion's substituted sha256sum (thanks btw!) it then looks for automake-1.14. There is an orphaned automake-1.14 in AUR which will build and install but this package then looks for automake-1.15 which is NOT available in AUR, and my attempts to BS one out of the automake 1.14 package did build and install, but didn't get much further in building this package.

hcartiaux commented on 2019-04-26 13:10

Not in community anymore ?

Btw, there's a checksum error:

==> Validating source files with sha512sums... epson-inkjet-printer-escpr-1.6.40-1lsb3.2.tar.gz ... Passed bug_x86_64.patch ... FAILED ==> ERROR: One or more files did not pass the validity check!