Package Details: flexget-git 2.13.3.r13070.9b8b02092-1

Git Clone URL: (read-only)
Package Base: flexget-git
Description: Automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more.
Upstream URL:
Licenses: MIT
Conflicts: flexget
Provides: flexget
Submitter: cgirard
Maintainer: cgirard
Last Packager: cgirard
Votes: 3
Popularity: 0.077792
First Submitted: 2015-08-10 10:05
Last Updated: 2018-04-17 15:06

Latest Comments

brando56894 commented on 2018-05-19 15:25

Please update this and remove the explicit version requirements, there is no reason for it. Instead, please use the respective python2 packages if you need it, I had to remove them all from mine to get it to build correctly.

cgirard commented on 2017-12-22 16:01

@zevdg they all are available on the AUR or the Arch Linux Archive.

zevdg commented on 2017-12-20 23:33

Install fails with:

error: target not found: python-cherrypy<12
error: target not found: python-rebulk=0.8.2
error: target not found: python-rpyc=3.3.0
error: target not found: python-guessit<=2.0.4

cgirard commented on 2017-12-11 16:45

I have switched the package to Python3. You may get some errors at first restart with restoring some jobs by apscheduler but it seems to works fine afterward.

If you prefer using python2 version, use previous PKGBUILD from git history, I am not interested in maintaining both.

IamCarbonMan commented on 2017-03-29 15:21

Install fails with:

error: target not found: python2-flask-restplus=0.8.6
error: target not found: python2-guessit<=2.0.4

cgirard commented on 2017-03-21 20:24

Sorry forgot to commit. Fixed.

ooxxcc commented on 2017-03-21 02:33

flexget updated to 2.10.*

# Make sure the perms allow reading by all
chmod ugo+r ${pkgdir}/usr/lib/python2.7/site-packages/FlexGet-2.9.*.dev0-py2.7.egg-info/*

will fail

cgirard commented on 2016-10-14 13:52

Switched from npm to yarn. It is way faster to build!

cgirard commented on 2016-09-06 11:05

If the npm command hangs, downgrade nodejs to 6.4.0. (see )

cgirard commented on 2015-11-16 09:12

No this are missing deps from python2-pyscss. I have already asked the maintainer to update its PKGBUILD.

For python2-beautifulsoup4, as far as I can tell 4.4.1 is not inferior to 4.4. So this is expected.

shelbydz commented on 2015-11-14 23:08

Just installed this package. It seems the latest version from git also needs

also, i couldn't get it to run with latest python2-beautifulsoup4 from the repo (4.4.1 i think). I had to downgrade that package.

kazuo commented on 2015-09-11 18:06

beautifulsoup 4.4 support:

flexget-git works for me (TM) with beautifulsoup 4.4.0 (you need to remove the check for <4.4).

cgirard commented on 2015-09-11 16:11

Yes, I know. And?

ccoffey commented on 2015-09-11 15:14 is now at 4.4.0-1.

awh commented on 2015-08-20 14:43

Seems I had previously installed flexget with pip. Removing all pip packages and reinstalling the python2-* packages seems to have fixed up the deps.

cgirard commented on 2015-08-20 08:50

You have outdated packages installed or have managed to broke package dependencies:
- python2-apscheduler is a dependency of flexget-git
- python2-six is a dependency of python2-apscheduler
- python2-six is currently at version 1.9.0 in [community]

awh commented on 2015-08-19 18:02

getting the following upon service start:
pkg_resources.DistributionNotFound: The 'six>=1.4.0' distribution was not found and is required by apscheduler

cgirard commented on 2015-08-12 14:19

I switched to python2-dateutil as 2.4 is not blacklisted by flexget and seems to work.

kevku commented on 2015-08-12 14:02

python2-dateutil1 is missing from AUR