Package Details: flexget 2.2.20-1

Git Clone URL: (read-only)
Package Base: flexget
Description: Automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more.
Upstream URL:
Licenses: MIT
Submitter: jonkristian
Maintainer: sleduc
Last Packager: sleduc
Votes: 65
Popularity: 0.553218
First Submitted: 2009-09-11 19:38
Last Updated: 2016-08-16 07:49

Latest Comments

redbaron commented on 2016-08-18 06:34

Hello, reinstalled flexget from zero (deleted all dependencies and orphaned python packages), python2-guessit asked for python2-dateutil<2.5.2 which is not available in repository so I installed 2.5.1 from archive and then flexget fully installed.
Bu when running "flexget check" it gives error:

pkg_resources.DistributionNotFound: The 'guessit<=2.0.4' distribution was not found and is required by FlexGet

but in dependencies from PKGBUILD python2-guessit>=2.0.3 (python2-guessit-git) is required.

jevv commented on 2016-08-16 07:57

BTW, guppy (opt. dep.) no longer compiles, on python3:

Perhaps a patch can be useful, :-) See, it was reported on 2012-01, updated on 2014-05, and since then the bug hadn't been attended. Therefore a patch would be great... Meanwhile I'd guess it can be removed from the opt. deps. if using python3...

Tha of course if in the mood to migrate to python3, :-)

sleduc commented on 2016-08-16 07:52

Thanks for the comments.
For now I just updated it to the latest version still using python2, I will look into the migration to python3 and the creation of all dependency packages.

jevv commented on 2016-08-16 06:21

Just in case, a brief of what I did to upgrade to 2.2.20 and at the same time migrate to python3 (none of the new pkgs are in AUR):

flexget -> 2.2.20
-> CHANGE to python3
-> REMOVE all #AUR# on deps
-> REMOVE "prepare"
-> NEW DEPENDENCY python-pathlib
-> MOVED from OPT to DEP (really opt?)
python-transmissionrpc python-rarfile
sha256sums 42b49386fd5f0bb60e1e920d2a5eb5651c9ef0d0df12f464fe2d3a3d64dcef87
python-apscheduler -> 3.2.0
sha256sums 5baa1195ba711868fae257612cf80372ff1124014ca896884bf132f75636f638
python-flask-restful -> REMOVE python2
python-rpyc -> REMOVE python2
python-flask-compress -> new python3
python-flask-cors -> new python3
python-flask-restplus086 -> new python3
python-flask-restplus -> new python3 (required 086, only for completeness)
python-rednose -> new python3 (prior deps on this)
python-termstyle -> new python3 (prior deps on this)
python-safe -> new python3
python-pynzb -> new python3
python-pytvmaze -> new python3
python-pathlib -> new python3

jevv commented on 2016-08-16 03:15

2.2.20 out, on

kevku commented on 2016-06-20 10:50

requiers guessit<=2.0.4

adam900710 commented on 2016-04-29 01:55

Thanks, I asked in upstream IRC, and decided to use virtualenv + pip do install it for a given user.

sleduc commented on 2016-04-28 17:54

Unfortunately I do not think this is possible.
In fact I guess it would require some modification of the code of Flexget to be more "modular".
But I fear we can't do much on the "packaging" side since flexget will not even start if one dependency is missing.
Maybe you could ask this question "upstream" (in

adam900710 commented on 2016-04-28 02:50

Any idea to stripe off the so many python dependency?

Or is there any option to disable features which I won't need?

Personally speaking, I just need flexget to filter torrents and download to given dir.
Nothing more, the dependency makes me quite scared though.

sleduc commented on 2016-03-18 19:54

Thanks, I updated the dependency (and the package version), it should all work correctly now.

All comments