Package Details: flexget 2.10.48-1

Git Clone URL: https://aur.archlinux.org/flexget.git (read-only)
Package Base: flexget
Description: Automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more.
Upstream URL: http://flexget.com/
Licenses: MIT
Submitter: jonkristian
Maintainer: sleduc
Last Packager: sleduc
Votes: 66
Popularity: 0.857720
First Submitted: 2009-09-11 19:38
Last Updated: 2017-05-21 09:34

Latest Comments

jarondl commented on 2017-08-14 13:00

This has nothing to do with this package. You are using some AUR manager that auto-installs dependencies, and you had a problem with python-tzlocal. Even this problem is probably transient, because I had no problem running:

git clone https://aur.archlinux.org/python-tzlocal.git

fucksociety commented on 2017-08-13 17:31

Building python-tzlocal...
Cloning into 'python-tzlocal'...
fatal: unable to access 'https://aur.archlinux.org/python-tzlocal.git/': The requested URL returned error: 502

sleduc commented on 2017-05-21 09:39

I updated the package to 2.10.48 and applied your fix for the dependency on guessit.
It seems to work, hoping that using this version of guessit will not create too many bugs... but I guess it will still be better than not being able to install it at all :)

jevv commented on 2017-05-15 01:40

Also, if porting to python (python3), then the patch for requirements.txt should be modified to remove dep on pahtlib:

https://github.com/Flexget/Flexget/issues/1822

Like:

% cat requirements.patch
diff -Naur Flexget-2.10.14-old/requirements.txt Flexget-2.10.14/requirements.txt
--- Flexget-2.10.14-old/requirements.txt 2017-05-14 19:27:31.385094023 -0600
+++ Flexget-2.10.14/requirements.txt 2017-05-14 19:28:29.416874195 -0600
@@ -11,12 +11,10 @@
jinja2
# There is a bug in requests 2.4.0 where it leaks urllib3 exceptions
requests>=2.8.0, <3.0
-#Guessit requires python-dateutil<=2.5.2
python-dateutil>=2.5.3
jsonschema>=2.0
path.py>=8.1.1
-pathlib>=1.0
-guessit<=2.0.4
+guessit>=2.1.2
apscheduler>=3.2.0
terminaltables>=3.1.0
colorclass>=2.2.0

jevv commented on 2017-05-15 00:54

Well, the owner could apply:

https://github.com/Flexget/Flexget/pull/1398/files

The guys from flexget have accepted and rejected it... People from gentoo indicates compiles and works. There's also a indication of 3 tests failing...

I suggest applying the changes so the flexget keeps working on Arch, but also keep track of:

https://github.com/Flexget/Flexget/issues/1804
https://github.com/Flexget/Flexget/pull/1398

I seen no reason either not to move to python, rather than keep using python2...

IamCarbonMan commented on 2017-03-29 15:35

Install fails with:

error: target not found: python2-guessit<=2.0.4

highway commented on 2016-09-01 02:28

@redbaron i just re-read the comment, maybe you can report that to them on their site? open a new issue and report that.

highway commented on 2016-09-01 02:24

@redbaron there is an issue open with guessit in their github. you can comment to show support/urgency if you like. the issue is with dateutil functionality breaking guessit tests that might get removed.

https://github.com/guessit-io/guessit/issues/329

redbaron commented on 2016-08-18 06:34

Hello, reinstalled flexget from zero (deleted all dependencies and orphaned python packages), python2-guessit asked for python2-dateutil<2.5.2 which is not available in repository so I installed 2.5.1 from archive and then flexget fully installed.
Bu when running "flexget check" it gives error:

pkg_resources.DistributionNotFound: The 'guessit<=2.0.4' distribution was not found and is required by FlexGet

but in dependencies from PKGBUILD python2-guessit>=2.0.3 (python2-guessit-git) is required.

jevv commented on 2016-08-16 07:57

BTW, guppy (opt. dep.) no longer compiles, on python3:

https://sourceforge.net/p/guppy-pe/bugs/17

Perhaps a patch can be useful, :-) See, it was reported on 2012-01, updated on 2014-05, and since then the bug hadn't been attended. Therefore a patch would be great... Meanwhile I'd guess it can be removed from the opt. deps. if using python3...

Tha of course if in the mood to migrate to python3, :-)

All comments