Package Details: flexget 2.20.27-1

Git Clone URL: https://aur.archlinux.org/flexget.git (read-only)
Package Base: flexget
Description: Automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more.
Upstream URL: http://flexget.com/
Licenses: MIT
Submitter: jonkristian
Maintainer: sleduc (redfish)
Last Packager: redfish
Votes: 69
Popularity: 0.042925
First Submitted: 2009-09-11 19:38
Last Updated: 2019-05-13 01:58

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

mkaito commented on 2016-03-17 17:04

Both of those commands returned an error for me, which was odd. I tried reinstalliing restplus, and now it seems the version is too new for flexget:

pkg_resources.DistributionNotFound: The 'flask-restplus==0.8.6' distribution was not found and is required by FlexGet

❯ pacman -Q python2-flask-restplus
python2-flask-restplus 0.9.0-1

sleduc commented on 2016-03-17 16:57

It is strange that you have this traceback if you have the files...
Can you try the import manually :
python2 -c "from flask_restplus import Api as RestPlusAPI"

And maybe to check the package of the files :
pacman -Qo /usr/lib/python2.7/site-packages/flask_restplus/__init__.pyc

mkaito commented on 2016-03-17 09:57

That was a typo on my part. python2-flask-restplus is correctly installed, and files exist under /usr/lib/python2.7/site-packages/flask_restplus.

sleduc commented on 2016-03-16 18:33

Indeed, the error on your pastebin seems to indicate an error on flask_restplus, not on flask_restful.

The package python2-flask-restplus is a dependency of flexget, and should provide the python package flask_restplus.
Do you have this package installed ?
Do you see files in /usr/lib/python2.7/site-packages/flask_restplus/ ?

mkaito commented on 2016-03-16 17:25

There seems to be an issue with flask-restful: http://paste.ubuntu.com/15402921/

sleduc commented on 2016-01-27 12:05

python2-pathlib is a missing dependency of python2-pyscss, so it should be added there (a comment has already been posted on this package but it has not yet been updated).

I am not really sure about guessit : since the dependency states "python2-guessit>=2.0rc5" which is provided by python2-guessit-rc it should work, but maybe I am missing something...
I will have to try to do more tests to see what is going on.

bkuri commented on 2016-01-27 05:41

I think `python2-pathlib` should be added to the list of dependencies. Also `python2-guessit-rc` wasn't found at setup runtime for some reason, so I had to install it manually before retrying.

cgirard commented on 2015-11-04 08:53

See my comment there, the PKGBUILD misses deps indeed.

rvasilev commented on 2015-11-04 08:30

After 1.2.378-1 update I'm getting
'
The 'pathlib' distribution was not found and is required by pyScss.
'

After installing python2-pathlib everything is fine.

May be strange, but pathlib is not listed as dependancy for python2-pyscss 1.3.4-2 (https://aur.archlinux.org/packages/python2-pyscss/)

sleduc commented on 2015-09-16 11:14

I updated flexget to the latest version and added a small patch to bypass the "beautifulsoup4 < 4.4" dependency since it is still present upstream.
It seems to work fine on my side, let me know if you see a problem with this new version.