Package Details: fpm 1.11.0-1

Git Clone URL: https://aur.archlinux.org/fpm.git (read-only)
Package Base: fpm
Description: Effing package management! Build packages for multiple platforms (deb, rpm, etc) with great ease and sanity.
Upstream URL: https://github.com/jordansissel/fpm
Keywords: deb packaging rpm ruby
Licenses: MIT
Submitter: markzz
Maintainer: RX14
Last Packager: RX14
Votes: 5
Popularity: 0.133854
First Submitted: 2015-12-06 19:48
Last Updated: 2019-02-18 01:16

Latest Comments

1 2 Next › Last »

markzz commented on 2018-07-04 05:30

rpi2: "arch=(any)"

Yes, it supports armv7 as long as you have all the dependencies installed.

As for your other problem, check the architectures of the package and the operating system. They must match letter by letter.

rpi2 commented on 2018-07-04 02:00

covert deb to pacman success, pacman -U got this error: error: failed to prepare transaction (package architecture is not valid)

does fpm support armv7 architecture? btw, convert on Alarm.

RX14 commented on 2018-04-12 13:02

@Twiki it offers you all the benefits of using the pacman package manager to manage your gems, instead of having to use gem itself. The benefit is that fpm is installed system-wide without having to run gem as root, which I strongly dislike doing.

Twiki commented on 2018-04-11 14:37

What does this offer beyond installing with "gem install --no-ri --no-rdoc fpm" ?

RX14 commented on 2018-01-31 22:43

@pd5rm this seems like a bug in the ruby-archive-tar-minitar package, please report this bug to the correct package!

pd5rm commented on 2018-01-31 22:33

Sorry for comment spam, dealing with MD comment formatting issues. ;-)

1) Seems to requires 'ruby-rdoc' to be installed for the ruby-archive-tar-minitar package to build.

@RX14 Thanks I'll report to that package.

2) ruby-insist (a package dep) appears to be packaged incorrectly. Follow the workaround provided by user Salamandar on that package.

Traceback (most recent call last): 12: from /usr/bin/fpm:23:in <main>' 11: from /usr/lib/ruby/2.5.0/rubygems.rb:309:inactivate_bin_path' 10: from /usr/lib/ruby/2.5.0/rubygems.rb:309:in synchronize' 9: from /usr/lib/ruby/2.5.0/rubygems.rb:310:inblock in activate_bin_path' 8: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1439:in activate' 7: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1457:inactivate_dependencies' 6: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1457:in each' 5: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1471:inblock in activate_dependencies' 4: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1439:in activate' 3: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1457:inactivate_dependencies' 2: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1457:in each' 1: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1468:inblock in activate_dependencies' /usr/lib/ruby/2.5.0/rubygems/dependency.rb:310:in to_specs': Could not find 'insist' (>= 0) among 48 total gem(s) (Gem::MissingSpecError) Checked in 'GEM_PATH=/home/pedrum/.gem/ruby/2.5.0:/usr/lib/ruby/gems/2.5.0', executegem env` for more information

3) Package seems to run, but getting warnings (not a ruby expert so not sure if important).

/usr/lib/ruby/gems/2.5.0/gems/backports-3.6.7/lib/backports/1.8.7/fixnum/div.rb:1: warning: constant ::Fixnum is >deprecated /usr/lib/ruby/gems/2.5.0/gems/backports-3.6.7/lib/backports/1.8.7/fixnum/fdiv.rb:1: warning: constant ::Fixnum is deprecated /usr/lib/ruby/gems/2.5.0/gems/backports-3.6.7/lib/backports/2.1.0/bignum/bit_length.rb:1: warning: constant ::Bignum is deprecated /usr/lib/ruby/gems/2.5.0/gems/backports-3.6.7/lib/backports/2.1.0/fixnum/bit_length.rb:1: warning: constant ::Fixnum is deprecated

RX14 commented on 2017-11-11 15:01

I've updated the package to 1.9.3 and fixed the clamp dependency.

gnufred commented on 2017-07-05 17:15

fpm --version
/usr/lib/ruby/2.4.0/rubygems/dependency.rb:310:in `to_specs': Could not find 'clamp' (~> 1.0.0) - did find: [clamp-1.1.2] (Gem::MissingSpecVersionError)
Checked in 'GEM_PATH=/home/fred/.gem/ruby/2.4.0:/usr/lib/ruby/gems/2.4.0', execute `gem env` for more information
from /usr/lib/ruby/2.4.0/rubygems/specification.rb:1442:in `block in activate_dependencies'
from /usr/lib/ruby/2.4.0/rubygems/specification.rb:1431:in `each'
from /usr/lib/ruby/2.4.0/rubygems/specification.rb:1431:in `activate_dependencies'
from /usr/lib/ruby/2.4.0/rubygems/specification.rb:1413:in `activate'
from /usr/lib/ruby/2.4.0/rubygems.rb:299:in `block in activate_bin_path'
from /usr/lib/ruby/2.4.0/rubygems.rb:299:in `synchronize'
from /usr/lib/ruby/2.4.0/rubygems.rb:299:in `activate_bin_path'
from /usr/bin/fpm:22:in `<main>'

simonsd commented on 2017-02-27 15:06

Still missing ruby-archive-tar-minitar dependency

markzz commented on 2016-12-14 15:24

Yes, I know about the missing ruby dependencies, I just keep forgetting to get them fixed. I will work on it this weekend.