Package Details: git-annex-remote-rclone 0.4-4

Git Clone URL: https://aur.archlinux.org/git-annex-remote-rclone.git (read-only)
Package Base: git-annex-remote-rclone
Description: A git-annex special remote using rclone
Upstream URL: https://github.com/DanielDent/git-annex-remote-rclone
Licenses: GPL3
Submitter: montag451
Maintainer: montag451 (pigmonkey)
Last Packager: pigmonkey
Votes: 2
Popularity: 0.611413
First Submitted: 2016-07-27 16:14
Last Updated: 2017-03-21 03:35

Latest Comments

PythonNut commented on 2017-01-04 17:59

This package is causing a dependency error again now that rclone 1.35 has landed in the repo.

The CI tests for the upstream reported no problems with the new rclone.

montag451 commented on 2016-11-19 23:40

@pigmonkey I added you as a co-maintainer of the package

pigmonkey commented on 2016-11-19 23:04

Thanks for the update.

If you no longer want to maintain this package since you're on Nix, I'd be willing to take over.

montag451 commented on 2016-11-19 17:43

I've updated the package dependencies. I can't test the new version since I'm not using Archlinux anymore (I've switched to NixOS). Let me know if you encounter some problems with the new version. Thanks for your contribution !

pigmonkey commented on 2016-11-17 22:03

This package is causing a dependency error again now that rclone 1.34 has landed in the repo. I'm not sure if there are any compatibility issues we need to worry about this time around.

https://github.com/DanielDent/git-annex-remote-rclone/issues/14

montag451 commented on 2016-08-26 16:34

@pigmonkey I also ran some tests and didn't find any problem so I will update the package. Thank you for your help!

pigmonkey commented on 2016-08-26 15:54

I upgraded rclone to 1.33 to test. My b2, hubic, and google drive special remotes seem to be working fine. I tried adding files to an annex, copying them to the remotes, and fscking from the remotes.

It seems safe to set the upper bound to at least 1.33, if not remove it.

Thanks for packaging this up!

montag451 commented on 2016-08-26 06:02

@pigmonkey I added this constraint on the dependency because the author of git-annex-remote-rclone specify that "git-annex-remote-rclone has been tested with rclone versions 1.29 through 1.32. Because rclone sometimes changes its output, updates to this software may be required for compatibility.". I can remove the upper bound constraint but it may break the package

pigmonkey commented on 2016-08-25 23:19

This package causes a dependency error now that rclone 1.33 has landed in community. Is the <=1.32 dependency actually required for something, or is it just a precaution?