Package Details: gitfs 0.4.5.1-1

Git Clone URL: https://aur.archlinux.org/gitfs.git (read-only)
Package Base: gitfs
Description: Version controlled file system
Upstream URL: http://www.presslabs.com/gitfs/
Licenses: Apache
Submitter: Dragonlord
Maintainer: Dragonlord
Last Packager: Dragonlord
Votes: 7
Popularity: 1.463751
First Submitted: 2014-12-14 15:56
Last Updated: 2016-12-08 17:47

Required by (0)

Sources (1)

Latest Comments

Harvie commented on 2017-10-13 16:16

@nikvdp: Do you have SSH working? Only HTTPS works for me.

nikvdp commented on 2017-10-05 23:43

I've opened a PR upstream here: https://github.com/PressLabs/gitfs/pull/276

In the meantime, for those who just want to install it, this "one-liner" will install it with below patch and python-six fix via yaourt:

cd /tmp && \
yaourt -G gitfs && \
cd gitfs && \
git apply <(curl -L https://gist.githubusercontent.com/nikvdp/6e80c3903cc1470668d0871ebd6bfffd/raw/f790ec4c685bfeddc4af8824623565bb7cd15e14/0001-Hacks-and-Bug-Fixes.patch) && \
yaourt --noconfirm -Pi . && \
rm -rf ./gitfs && \
cd -


combined patch available here: https://gist.githubusercontent.com/nikvdp/6e80c3903cc1470668d0871ebd6bfffd/raw/f790ec4c685bfeddc4af8824623565bb7cd15e14/0001-Hacks-and-Bug-Fixes.patch

khampf commented on 2017-09-22 19:16

Also the version check of the python-six dependency needs to be altered from == to >= version

ahrs commented on 2017-05-08 06:58

Here's a patch that fixes things:

https://gist.github.com/anonymous/5cb46d5f4fbf3e226c5a23c0b3282ab1

This adds python-raven to the dependencies and makes python-setuptools a dependency as opposed to a makedependency since this is a runtime dependency for some weird reason with gitfs complaining about `ModuleNotFoundError: No module named 'pkg_resources'`. I also patched the requirements.txt file making fusepy,pygit2 and raven use newer packages (>= instead of ==). It's unclear if gitfs needs specific versions of these modules for some reason. In my testing I can mount git repos no problem whatsoever but there may be some weird edge cases. It's probably worth asking upstream if gitfs requires specific versions of the aforementioned modules and if so, why.

psamim commented on 2017-02-03 18:39

I got the error:

pkg_resources.DistributionNotFound: The 'raven==5.27.0' distribution was not found and is required by gitfs

Thanks

themba commented on 2016-04-22 08:29

0.4.1-1 is the first ever aur release of gitfs that I was able to get working! Great work. I still had some issues so I created a wiki page here with some tips and tricks for the problems I encountered: https://wiki.archlinux.org/index.php/Gitfs
Maybe it will help someone in the future.

Dragonlord commented on 2016-01-27 18:37

I'd suggest to open an upstream bug and for the time being downgrade the python2-pygit2 package, in case it does not interfere with anything else. I won't be able to provide a patch for this error myself, sorry.

rlp10 commented on 2016-01-27 10:39

Installation succeeds, but then I can't run it. I think it is because the dependency python2-pygit2 has updated to version 0.23.0, whereas gitfs requires the earlier 0.22.0.

Can this be fixed please? Happy to provide any help or information you may need.

Traceback (most recent call last):
File "/usr/bin/gitfs", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3130, in <module>
@_call_aside
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3116, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3143, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 644, in _build_master
return cls._build_from_requirements(__requires__)
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 657, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 830, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'pygit2==0.22.0' distribution was not found and is required by gitfs

Dragonlord commented on 2015-09-03 20:00

Dependencies should be sorted and went back to python2 for this package. I did not really test the functionality, so would be great to have some feedback if this really works now.

rumpelsepp commented on 2015-02-19 17:01

Also it seems to break on python3. :)
Sorry for posting three comments instead of one...

All comments