Package Details: gnome-shell-extension-maximus-two-git 5-3

Git Clone URL: https://aur.archlinux.org/gnome-shell-extension-maximus-two-git.git (read-only, click to copy)
Package Base: gnome-shell-extension-maximus-two-git
Description: Removes the title bar on maximised windows
Upstream URL: https://github.com/danielkza/GnomeExtensionMaximusTwo
Licenses: GPLv3
Conflicts: gnome-shell-extension-maximus-two
Provides: gnome-shell-extension-maximus-two
Submitter: XZS
Maintainer: XZS
Last Packager: XZS
Votes: 20
Popularity: 0.000000
First Submitted: 2015-04-16 12:46 (UTC)
Last Updated: 2016-11-03 13:52 (UTC)

Latest Comments

kaptoxic commented on 2018-05-30 22:43 (UTC)

Is it possible to update this package (not sure if there is an upstream version that works with the newest version of Gnome)?

XZS commented on 2017-09-28 16:47 (UTC)

Now that we have Gnome shell 3.26, upstream finally declared it compatible with 3.24.

kaptoxic commented on 2017-05-01 02:01 (UTC)

Does not work with Gnome shell 3.24; not sure if the upstream has a compatible implementation.

XZS commented on 2016-06-13 15:28 (UTC)

As of now, it should finally work with gnome-shell 3.20.

hpstg commented on 2016-06-02 21:57 (UTC)

Even when the repo is updated, it won't work with gnome 3.20.

Asher256 commented on 2016-05-07 02:57 (UTC)

The PKGBUILD doesn't work anymore. You need to update the Github repository to: https://github.com/wilfm/GnomeExtensionMaximusTwo

XZS commented on 2016-04-18 23:39 (UTC)

I deleted my outdated fork on purpose and requested merge of an update. As soon as upstream processes this, the package will reflect a gnome-shell 3.20 compatible version.

commented on 2016-04-18 23:16 (UTC)

@XZS The upstream GitHub URL seems to be dead. This results in git asking for a username/password when installing/updating.

commented on 2016-04-15 01:44 (UTC)

@XZS and anyone else looking to make it compatible with GNOME 3.20: I added the following lines to package_02_install(): sed -i.bak "s/3.18/3.18\",\n \"3.20/g" "$pkgdir/usr/share/gnome-shell/extensions/$extname/metadata.json" sed -i.bak "s/3.18/3.18\",\n \"3.20/g" $(find -path ./pkg -type d -prune -o -name metadata.json)

commented on 2016-03-23 21:10 (UTC)

Works wonderfully, along with the rest of your PKG files. Thanks a ton!

XZS commented on 2016-03-23 20:19 (UTC)

Yes, the grep script parses the JSON for compatible gnome-shell verions numbers to set up the depends array correctly. Surprisingly, also traditional tools like grep are regularly updated still today, find exactly the weird unintended behaviour I rely upon to do so and forbid it. The issue affected all my gnome-shell-extension-* packages and is fixed now. More details can be found in the respective commit to the package collection <https://github.com/dffischer/gnome-shell-extensions/commit/785f0a35c7760de237ddfe2e53c959132be200d1>.

XZS commented on 2016-03-19 22:52 (UTC)

Thanks for pointing out the change in metadata.json. It is indeed most probably the culprit. I will fix this in the next few days.

Asher256 commented on 2016-03-19 16:49 (UTC)

Hi, There is a bug in the PKGBUILD: gnome-shell-extension-maximus-two-git/PKGBUILD: line 52: compatibles: bad array subscript It is probably because the metadata.json is written differently. In the last Github master version: "shell-version": [ "3.16", "3.18" ], The bug is caused by this: local compatibles=($(\ find -path ./pkg -type d -prune -o \ -name metadata.json -exec grep -Pzo '(?s)(?<="shell-version": \[)[^\[\]]*(?=\])' '{}' \; | \ tr '\n," ' '\n' | sed 's/3\.//g;/^$/d' | sort -n -t. -k 1,1)) cat metadata.json depends+=("gnome-shell>=3.${compatibles[0]}") local max="${compatibles[-1]}" # <---- It stops here with the error below

commented on 2016-03-18 20:55 (UTC)

When trying to install, I get the following error: grep: unescaped ^ or $ not supported with -Pz /tmp/pacaurtmp-user/gnome-shell-extension-maximus-two-git/PKGBUILD: line 51: compatibles: bad array subscript

chrbayer commented on 2016-01-10 13:05 (UTC)

I get the following error, if I try to install the extension: Error: Schema org.gnome.shell.extensions.maximus could not be found for extension maximus@luis.pabon.auronconsulting.co.uk. Please check your installation. Stack trace: getSettings@/home/chrbayer/.local/share/gnome-shell/extensions/maximus@luis.pabon.auronconsulting.co.uk/convenience.js:66 MaximusPrefsWidget<._init@/home/chrbayer/.local/share/gnome-shell/extensions/maximus@luis.pabon.auronconsulting.co.uk/prefs.js:188 wrapper@resource:///org/gnome/gjs/modules/lang.js:178 buildPrefsWidget@/home/chrbayer/.local/share/gnome-shell/extensions/maximus@luis.pabon.auronconsulting.co.uk/prefs.js:326 Application<._selectExtension@resource:///org/gnome/shell/extensionPrefs/main.js:95 wrapper@resource:///org/gnome/gjs/modules/lang.js:178 Application<._onCommandLine@resource:///org/gnome/shell/extensionPrefs/main.js:259 wrapper@resource:///org/gnome/gjs/modules/lang.js:178 main@resource:///org/gnome/shell/extensionPrefs/main.js:397 @<main>:1

mayamcdougall commented on 2015-05-15 13:58 (UTC)

You should add 'wmctrl' as a dependency. Without it, the extension will generate a long list of error notifications that read "Execution of 'wmctrl' failed: Command not found" (as well as, obviously, not working).

XZS commented on 2015-04-16 12:58 (UTC)

This extension is not developed any further long since and does not work with Gnome Shell 3.16 and up. Users are advised to switch to gnome-shell-extension-maximus-two-git.

XZS commented on 2014-02-16 22:35 (UTC)

Added xorg-xprop as a dependency, fixed url.

defendor commented on 2014-02-16 20:11 (UTC)

Please add xorg-xprop as dependency. Fails without it.