Package Details: gns3-server 2.1.21-2

Git Clone URL: https://aur.archlinux.org/gns3-server.git (read-only)
Package Base: gns3-server
Description: GNS3 network simulator, Server package
Upstream URL: https://github.com/GNS3/gns3-server
Licenses: GPL3
Groups: gns3
Submitter: korjjj
Maintainer: buzo
Last Packager: buzo
Votes: 57
Popularity: 0.580017
First Submitted: 2014-05-13 17:40
Last Updated: 2019-06-16 19:19

Dependencies (18)

Required by (1)

Sources (2)

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 Next › Last »

buhaha commented on 2016-07-05 15:15

1.5.0
http://pastebin.com/G9VKhu8k

xrayfur commented on 2016-07-03 15:32

1.5.0 has a new dependency: python-zipstream

buhaha commented on 2016-06-24 23:47

1.5.0rc2
http://pastebin.com/HkJqC3bV

cioby23 commented on 2016-01-29 15:02

Please add ubridge as dependency. https://github.com/GNS3/ubridge
It's needed for Vmware support inside GNS3.

ledbrv commented on 2015-04-09 13:33

@korjjj I just updated gns3-server to version 1.3.0-2. It worked. Thanks.

korjjj commented on 2015-04-09 11:15

@max-k by mistake

max-k commented on 2015-04-09 09:42

Hi korjjj,

Why did you remove dynamips as an optional dependency ?

korjjj commented on 2015-04-09 05:31

@ledbrv yeah, upstream keeps forgetting that dependencies can sometimes be upgraded too.
Posted an issue at github and added a small patch for the package.

ledbrv commented on 2015-04-08 18:55

Hi,

Today, after some packages updates, gns3 failed to start with the error:

pkg_resources.DistributionNotFound: The 'aiohttp==0.14.4' distribution was not found and is required by gns3-server

My current python-aiohttp package is version 0.15.1-1 (after the update).

I found the requires.txt file on /usr/lib/python3.4/site-packages/gns3_server-1.3.0-py3.4.egg-info an changed aiohttp from version 0.14.4 to version 0.15.1.
I don`t know yet if something is broken, but at least gns3 starts without erros..

diff --git a/requires.txt b/requires.txt
index f699d5e..1a4c59f 100644
--- a/requires.txt
+++ b/requires.txt
@@ -1,4 +1,4 @@
-aiohttp==0.14.4
+aiohttp==0.15.1
jsonschema==2.4.0
Jinja2==2.7.3
raven==5.2.0

korjjj commented on 2015-04-01 16:20

@TomFyuri had no problem with qemu in 1.3.0.
Didn't check with 1.2.x, though.