Package Details: go-for-it 1.6-1

Git Clone URL: https://aur.archlinux.org/go-for-it.git (read-only)
Package Base: go-for-it
Description: A stylish to-do list with built-in productivity timer.
Upstream URL: https://github.com/mank319/Go-For-It
Licenses: GPL3
Conflicts: go-for-it-bzr, go-for-it-git
Submitter: Case_Of
Maintainer: Case_Of (JMoerman)
Last Packager: Case_Of
Votes: 4
Popularity: 0.036483
First Submitted: 2015-12-17 00:33
Last Updated: 2017-10-20 01:41

Latest Comments

JMoerman commented on 2017-10-06 20:06

One more thing: the following line in the PKGBUILD:

install -Dm644 "${srcdir}/data/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"

should not be necessary anymore, as of https://github.com/mank319/Go-For-It/commit/588e669c6db6e4b4f675e6e70d95062e91d49769 (included in release_v1.4.7).

JMoerman commented on 2017-10-06 19:49

@Case_Of Version 1.6 is out, which also builds with val versions > 0.34, so you can remove the dependency on valac version 0.26. Should you run into any issues, please report them here: https://github.com/mank319/Go-For-It/issues. (I don't use Arch so you may experience different issues, or experience issues sooner.)
I hope to have the time and energy to fix issues like this sooner in the future. (and also that Vala vapi files are not changed in an backwards incompatible way for some time.)
- Jonathan (Maintainer of Go For It!)

Case_Of commented on 2017-05-07 10:49

It can't build with vala in extra.

dare023 commented on 2017-05-07 10:46

Package asks for vala 0.26, while in [extra] we have vala 0.36.
Can you remove dependency to use package from extra? or it must use vala 0.26?

Case_Of commented on 2017-05-05 22:18

@MarcusE1W:
Are you using makepkg or another thing?
What is the result with makepkg?
Your paste is incomplete. I updated the makedeps. Retry to build.

@btd1337: # pacman -S --needed base-devel

MarcusE1W commented on 2017-05-05 14:40

I get this error message:
cmake is now an orphan package
:: vala is now an orphan package
:: failed to build go-for-it package(s)

btd1337 commented on 2017-05-01 16:08

Error in install


==> Iniciando build()...
-- The C compiler identification is GNU 6.3.1
-- The CXX compiler identification is GNU 6.3.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE)
CMake Error at /usr/share/cmake-3.7/Modules/FindPkgConfig.cmake:470 (message):
pkg-config tool not found
Call Stack (most recent call first):
/usr/share/cmake-3.7/Modules/FindPkgConfig.cmake:588 (_pkg_check_modules_internal)
CMakeLists.txt:28 (pkg_check_modules)


-- Found Vala: /usr/bin/valac
-- checking for a minimum Vala version of 0.16
-- found Vala, version 0.34.6
CMake Error at src/CMakeLists.txt:6 (if):
if given arguments:

"VERSION_GREATER" "3.9"

Unknown arguments specified


-- Configuring incomplete, errors occurred!

Case_Of commented on 2016-08-22 23:02

@Jhackler: Fixed. Thanks for the feedback.

Jhackler commented on 2016-08-22 20:44

this last update removed the go for it launcher from applications