Package Details: google-drive-ocamlfuse 0.6.7-1

Git Clone URL: https://aur.archlinux.org/google-drive-ocamlfuse.git (read-only)
Package Base: google-drive-ocamlfuse
Description: FUSE filesystem backed by Google Drive, written in OCaml.
Upstream URL: http://gdfuse.forge.ocamlcore.org/
Keywords: drive fuse google ocaml
Licenses: MIT
Submitter: mlq
Maintainer: pricechrispy
Last Packager: pricechrispy
Votes: 31
Popularity: 1.235402
First Submitted: 2013-10-14 21:44
Last Updated: 2017-01-12 20:16

Dependencies (5)

Required by (1)

  • bups (requires google-drive-ocamlfuse) (optional)

Sources (1)

Latest Comments

kynikos commented on 2017-02-10 10:54

I've tried again today and it builds now without those symlinks. However at the first attempt I got:

Cannot find external tool 'ocamlbuild'

I think "makedepends=('ocamlbuild')" should be added to this PKGBUILD.

wilmerhenao commented on 2017-02-02 17:41

Same problem as kynikos

kynikos commented on 2017-01-31 16:43

Is it only me who still requires 'com.cmxa' and 'com.a' under /usr/lib/ocaml/camlidl/ instead of just /usr/lib/ocaml/ to build this package?
They're from the camlidl package, I'm adding the following to the package() function in its PKGBUILD (ugly workaround, I know):

ln -s /usr/lib/ocaml/com.a ${pkgdir}/usr/lib/ocaml/camlidl/
ln -s /usr/lib/ocaml/com.cmxa ${pkgdir}/usr/lib/ocaml/camlidl/

If it's still a common problem, perhaps it should be fixed in camlidl's PKGBUILD?

pricechrispy commented on 2017-01-26 08:46

@antouank A new maintainer has adopted and updated the gapi-ocaml package, so you should no longer have to change the PKGBUILD manually.

antouank commented on 2017-01-13 13:31

I get a "error: target not found: gapi-ocaml>=0.2.14" message when I try to update google-drive-ocamlfuse.

How can I get gapi-ocaml 0.2.14? It's still on 0.2.10

pricechrispy commented on 2017-01-12 20:23

Upgraded to latest release package.

This requires an updated gapi-ocaml package, minimum v0.2.14, for which you can manually change the PKGBUILD of that package until the maintainer updates it.

@noogar You seem to have file permission errors while building the zarith package, try and fix those.

tmily00 commented on 2016-12-19 15:26

upgrade to last Upstream version please

noogar commented on 2016-12-12 02:05


same error with zariath in ocaml and opam..


#=== ERROR while installing zarith.1.4.1 ======================================#
# opam-version 1.2.2
# os linux
# command make
# path /home/remote/.opam/system/build/zarith.1.4.1
# compiler system (4.04.0)
# exit-code 2
# env-file /home/remote/.opam/system/build/zarith.1.4.1/zarith-23855-6cc03f.env
# stdout-file /home/remote/.opam/system/build/zarith.1.4.1/zarith-23855-6cc03f.out
# stderr-file /home/remote/.opam/system/build/zarith.1.4.1/zarith-23855-6cc03f.err
### stdout ###
# ./z_pp.pl x86_64
### stderr ###
# [...]
# perl: warning: Please check that your locale settings:
# LANGUAGE = (unset),
# LC_ALL = (unset),
# LANG = "en_US.UTF-8"
# are supported and installed on your system.
# perl: warning: Falling back to the standard locale ("C").
# Can't locate warnings.pm: /root/.opam/system/lib/perl5/warnings.pm: Permission denied at ./z_pp.pl line 3.
# BEGIN failed--compilation aborted at ./z_pp.pl line 3.
# project.mak:137: depend: No such file or directory
# make: *** [project.mak:110: z.ml] Error 13



=-=- Error report -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
The following actions were aborted
∗ install cryptokit 1.11
∗ install gapi-ocaml 0.3.1
∗ install google-drive-ocamlfuse 0.6.4
The following actions failed
∗ install zarith 1.4.1
The following changes have been performed
∗ install ocamlnet 4.1.2

pricechrispy commented on 2016-11-17 10:46

While upgrading to the newer build, the same build error persists as reported in the comments.

When doing a fresh build, I manually created symlinks as root so that the build process finds them, as similarly suggested in the comments.

# ln -s /usr/lib/ocaml/com.cmxa /usr/lib/ocaml/camlidl/
# ln -s /usr/lib/ocaml/com.a /usr/lib/ocaml/camlidl/

After doing this, the directory '/usr/lib/ocaml/camlidl/' should have the following structure in a fresh environment:

$ ls -l /usr/lib/ocaml/camlidl/
total 4
lrwxrwxrwx 1 root root 20 Nov 17 02:23 com.a -> /usr/lib/ocaml/com.a
lrwxrwxrwx 1 root root 23 Nov 17 02:23 com.cmxa -> /usr/lib/ocaml/com.cmxa
-rw-r--r-- 1 root root 102 Nov 17 01:11 META

This should allow the package to build for now, until an automated PKGBUILD solution is found.

shillshocked commented on 2016-11-07 04:55

That doesn't change anything for me. Still get same error.

All comments