Package Details: gapi-ocaml 0.3.19-2

Git Clone URL: https://aur.archlinux.org/gapi-ocaml.git (read-only, click to copy)
Package Base: gapi-ocaml
Description: A simple OCaml client for Google Services.
Upstream URL: https://astrada.github.io/gapi-ocaml/
Keywords: api gapi google ocaml
Licenses: MIT
Submitter: whynothugo
Maintainer: pricechrispy
Last Packager: pricechrispy
Votes: 46
Popularity: 0.000114
First Submitted: 2013-07-08 03:56 (UTC)
Last Updated: 2021-06-24 06:07 (UTC)

Pinned Comments

nerflad commented on 2019-09-10 10:13 (UTC)

@caseyjp1 It's not a problem with the build. Read the error message. You have updated ocaml since the last time you compiled this package so you need to recompile all the dependencies. Use "pacman -Qo [.cmi filename]" to find which packages to rebuild. Or if you're brave, pacman -Rsc gapi-ocaml && pacman -Sc and start from scratch.

Latest Comments

1 2 3 4 5 6 .. 9 Next › Last »

musiclover commented on 2022-09-27 15:44 (UTC)

Working PKGBUILD:

pkgname=gapi-ocaml
pkgver=0.4.2
pkgrel=2
pkgdesc="A simple OCaml client for Google Services."
arch=("x86_64" "i686" "armv7h")
url="https://astrada.github.io/gapi-ocaml/"
license=('MIT')
makedepends=('dune' 'ocaml-ounit>=1.1.0')
depends=(
'ocaml>=4.02.3'
'ocaml-findlib>=1.2.7'
'ocamlnet>=4.1.4'
'ocaml-curl>=0.5.3'
'ocaml-cryptokit>=1.3.14'
'ocaml-yojson>=1.6.0'
'ocaml-xmlm>=1.0.2'
)
source=("$pkgname-$pkgver.tar.gz::https://github.com/astrada/$pkgname/archive/v$pkgver.tar.gz")
options=('!strip' 'staticlibs')
sha256sums=('9c4c6dfa43443675d2ac0a14ec6ff5a105e274dc8bb4cdef657fb5f6e0af5b2a')

build() {
  cd $pkgname-$pkgver
  dune build @install
  sed -i '/doc:\s\[/,$d' _build/default/gapi-ocaml.install
}

package() {
  cd $pkgname-$pkgver
  DESTDIR="${pkgdir}" dune install --prefix "/usr"
  install -dm755 "${pkgdir}/usr/share/"
}

hectorconte commented on 2022-07-23 18:37 (UTC) (edited on 2022-07-23 18:38 (UTC) by hectorconte)

@Glitchyme I changed the ocaml lib ownership but I also had to modify the PKGBUILD package() cause 'dune' kept asking for dir definitions, so I changed it from this:


package() {
  cd ${srcdir}/${pkgname}-${pkgver}
  export OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)"
  install -dm755 "$OCAMLFIND_DESTDIR"

  dune install 
}
To this:


package() {
  cd ${srcdir}/${pkgname}-${pkgver}
  export OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)"
  install -dm755 "$OCAMLFIND_DESTDIR"

  dune install --mandir /usr/share/man --docdir=/usr/share/doc --etcdir=/etc --datadir=/usr/data --sbindir=/usr/sbin --bindir=/usr/bin
}

Since I use 'yay' to manage aur packages, it was tricky to modify the PKGBUILD (if anyone knows how I would be grateful), but after all, that worked.

Glitchyme commented on 2022-05-21 21:27 (UTC) (edited on 2022-05-21 21:31 (UTC) by Glitchyme)

@webdawg does installing through opam work in the meantime? opam install gapi-ocaml

If not you can get around it the same way I did (though probably not recommended):

sudo chown -R user:user /usr/lib/ocaml # temporarily own for your user
yay -S gapi-ocaml
sudo chown -R root:root /usr/lib/ocaml # set back to root

webdawg commented on 2022-05-13 14:44 (UTC)

fails to create directories

webdawg commented on 2022-05-13 14:42 (UTC)

Installing /usr/lib/ocaml/gapi-ocaml/META Error: /usr/lib/ocaml/gapi-ocaml/META: Is a directory

Wodger commented on 2021-07-05 23:44 (UTC)

@Galacta_dm Nice one mate - It's been giving me a bit of a headache (and fiddling around updating other packages using AURutils manually as -u would stop on these packages). For anyone using aurutils, while following the instructions outlined by Galacta_dm, ensure you -Syyy and then reinstall the modified cryptokit package via pacman BEFORE trying to install gapi-ocaml etc, else it will present you with "cryptokit library not found" if you try gapi-ocaml install. After this, Aur sync -u worked like a charm for gapi-ocaml. Thanks again Galacta_dm

galacta_dm commented on 2021-07-05 13:01 (UTC) (edited on 2021-07-05 13:05 (UTC) by galacta_dm)

@Wodger

I think this is a solution

First, delete /usr/lib/ocaml/cryptokit

Then I edited package() part of PKGBUILD as in https://aur.archlinux.org/packages/ocaml-cryptokit/

package() {
    cd cryptokit-release1161
    DESTDIR="$pkgdir" dune install --prefix "/usr" --libdir "lib/ocaml" -p cryptokit
    install -dm755 "${pkgdir}/usr/share"
    mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share"
}

then I reinstalled ocaml-cryptokit.

After these changes, installation of gapi-ocaml has been done without any errors.

galacta_dm commented on 2021-06-28 06:59 (UTC)

I have the same error

Wodger commented on 2021-06-27 00:35 (UTC)

Fails to build for me:

File "src/gapi/gapiJwtServiceAccount.mli", line 26, characters 34-51: 26 | val parse_private_key : string -> Cryptokit.RSA.key ^^^^^^^^^^^^^^^^^ Error: Unbound module Cryptokit File "src/gapi/gapiOAuth1.ml", line 2, characters 8-35: 2 | lazy (Cryptokit.Random.pseudo_rng ^^^^^^^^^^^^^^^^^^^^^^^^^^^ Error: Unbound module Cryptokit ==> ERROR: A failure occurred in build(). Aborting...