Package Details: guake-git 3.4.0.48.g7c91cfe-1

Git Clone URL: https://aur.archlinux.org/guake-git.git (read-only)
Package Base: guake-git
Description: Top-down terminal for Gnome using gtk3 and vte3
Upstream URL: https://github.com/Guake/guake
Licenses: GPL
Conflicts: guake, guake-gtk2-git
Provides: guake
Submitter: Skatox
Maintainer: Skatox
Last Packager: Skatox
Votes: 48
Popularity: 0.045251
First Submitted: 2008-03-07 02:12
Last Updated: 2019-03-12 04:31

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

bwrsandman commented on 2014-02-11 16:27

http://guake.org/ points to https://github.com/Guake/guake now.

Your source points to a gitorious page which hasn't had any activity in 9 months.
How about updating the PKGBUILD to use
source=('git://github.com/Guake/guake.git' ...

A cool trick to avoid "$pkgname"::'git:// is to use cd ${pkgname%-git} in pkgver(), prepare(), build() and package(). ;)

Skatox commented on 2013-10-31 19:12

@salantrax Added.
@bwrsandman Thanks! Your PKGBUILD helped me to update it.

salantrax commented on 2013-10-29 12:38

Builds and runs flawlessly on armv7h; request to add 'armv7h' to arch=().

bwrsandman commented on 2013-10-24 01:32

Here's a PKGBUILD which conforms to the VCS and GNOME packaging standards.
https://gist.github.com/bwrsandman/7129822

- Sets the version properly
- Fetches from git using makepkg
- Replaced the patch with sed commands
- Formatting for readability

Skatox commented on 2013-09-28 13:15

Updated, patched source code to use python2, added new dependencies and improvind PKGBUILD according to Arch's standards.

Anonymous comment on 2013-09-22 19:29

Please patch $srcdir/$_gitname-build/src/guake file to use python2 instead of python.
You're currently only patching the guake-prefs file in that same directory, so /usr/bin/guake still needs editing after installation/upgrade as per aricart's 2012-11-23 comment.

Also, patching with sed is somewhat unreliable - you should maybe use diff+patch instead :)

Skatox commented on 2013-03-17 13:39

This PKGBUILD is working, if you can't compile due to automake 1.13 detection, it's not a problem of this package it's a problem with gnome-common, you can check this bug at: https://bugs.archlinux.org/task/33285 and the solution to fix it in here: https://bbs.archlinux.org/viewtopic.php?id=155725

Det commented on 2013-03-17 12:49

Are you alive?

hav3lock commented on 2013-02-14 21:24

add guake to the list of conflicts.

hav3lock commented on 2013-02-14 20:22

this can be built using automake-1.12 (AUR). Just run:

$ packer -S automake-1.12 && packer -S guake-git