Package Details: heroku-cli 7.67.1-1

Git Clone URL: https://aur.archlinux.org/heroku-cli.git (read-only, click to copy)
Package Base: heroku-cli
Description: CLI to manage Heroku apps and services with forced auto-update removed
Upstream URL: https://devcenter.heroku.com/articles/heroku-cli
Licenses: custom, ISC
Conflicts: heroku-cli-bin, heroku-client-standalone, heroku-toolbelt, ruby-heroku
Provides: heroku, heroku-cli
Submitter: Redrield
Maintainer: rnestler
Last Packager: rnestler
Votes: 71
Popularity: 0.158350
First Submitted: 2017-08-15 23:19 (UTC)
Last Updated: 2022-12-10 14:30 (UTC)

Pinned Comments

Latest Comments

1 2 3 4 5 6 7 Next › Last »

rnestler commented on 2022-12-10 14:32 (UTC)

I took over maintenance of the package and pushed an update to 7.76.1. Let me know if you have any issues.

Also let me know if you want to help maintaining the package, then I can add you as a co-maintainer.

rnestler commented on 2022-10-28 13:55 (UTC)

@sampsoncrowley I'd we willing to help maintain the package. Can you add me as a co-maintainer?

ArchRob commented on 2022-06-13 19:03 (UTC)

Since this has been flagged as out-of-date for a while, I've been patching the PKGBUILD file manually and running makepkg -si whenever the new updates are released. Here's the patch for 7.60.2:

--- PKGBUILD.old    2022-06-13 13:56:19.830499649 -0500
+++ PKGBUILD    2022-06-13 13:47:11.109997946 -0500
@@ -5,9 +5,9 @@
 # Github Contributor: Joey Dumont <https://github.com/joeydumont>

 pkgname=heroku-cli
-pkgver=7.60.1
+pkgver=7.60.2
 pkgrel=1
-_commit_id="4e998800e9bde9b30d97e465f1e2c066c5734ff5"
+_commit_id="b8292f347101f13c2bb833b1dcf088886c8aa984"
 pkgdesc="CLI to manage Heroku apps and services with forced auto-update removed"
 arch=('any')
 url="https://devcenter.heroku.com/articles/heroku-cli"
  1. Pull down the repo: `git clone https://aur.archlinux.org/heroku-cli.git
  2. Enter the repo dir: cd heroku-cli
  3. Save the patch above to a file called PKGBUILD.patch
  4. Apply the patch with patch -u -b PKGBUILD -i PKGBUILD.patch
  5. Run makepkg -si

That should be all you need to install the latest 7.60.2.

qark commented on 2022-04-02 22:06 (UTC)

PKGBUILD uses npx tool, should have npm as make dependency.

sampsoncrowley commented on 2022-04-02 16:46 (UTC)

Hi guys, sorry again that it's been a while since there's been a new release. I moved houses, and only just now got my arch box out unpacked. I've been only using my work laptop until recently. will get a release out today

bobpaul commented on 2022-01-07 18:45 (UTC) (edited on 2022-01-07 19:42 (UTC) by bobpaul)

Edit Nevermind. I think this is my issue to sort out. I built the package on another machine and was able to install and run that here.

I'm getting this. I tried switching from nodejs to nodejs-lts-gallium same issue.

$ heroku
/usr/lib/heroku/node_modules/@oclif/command/node_modules/semver/semver.js:1

SyntaxError: Invalid or unexpected token
    at Object.compileFunction (node:vm:352:18)
    at wrapSafe (node:internal/modules/cjs/loader:1031:15)
    at Module._compile (node:internal/modules/cjs/loader:1065:27)
    at Object.Module._extensions..js (node:internal/modules/cjs/loader:1153:10)
    at Module.load (node:internal/modules/cjs/loader:981:32)
    at Function.Module._load (node:internal/modules/cjs/loader:822:12)
    at Module.require (node:internal/modules/cjs/loader:1005:19)
    at require (node:internal/modules/cjs/helpers:102:18)
    at Object.<anonymous> (/usr/lib/heroku/node_modules/@oclif/command/lib/index.js:4:16)
    at Module._compile (node:internal/modules/cjs/loader:1101:14)

sampsoncrowley commented on 2021-07-09 22:01 (UTC)

Sorry for the late release of 7.56.0; the fact that it was released got buried in my inbox under a stack of work

valandil commented on 2021-05-03 11:33 (UTC)

Not the maintainer, but I would suggest trying to build in a clean chroot. It builds fine for me that way.

ElderBladeX commented on 2021-05-02 21:43 (UTC) (edited on 2021-05-02 21:45 (UTC) by ElderBladeX)

Still having trouble with installing this package. I have yarn (1.22.10-1) and npm (7.11.2-1) installed on my system, but I get this error:

npm ERR! Invalid Version:
npm ERR! A complete log of this run can be found in:
npm ERR!     /home/<user-name>/.npm/_logs/2021-05-02T21_12_58_012Z-debug.log
==> ERROR: A failure occurred in prepare().
    Aborting...

Looking at the npm log, it just says "Invalid Version:" I searched this error for npm and it seems to be sensitive to the format of the version number in the json package. From what I can tell, 7.53.0 is valid and is listed as such in the PKGBUILD. Yarn is also listed as a make dependency in this version so I'm at a loss as to what is causing the error.

I opted to install heroku-cli-bin instead, which installs just fine, but wanted to know what I'm missing here.