Package Details: heroku-cli 8.11.1-1

Git Clone URL: (read-only, click to copy)
Package Base: heroku-cli
Description: CLI to manage Heroku apps and services with forced auto-update removed
Upstream URL:
Licenses: custom, ISC
Conflicts: heroku-cli-bin, heroku-client-standalone, heroku-toolbelt, ruby-heroku
Provides: heroku, heroku-cli
Submitter: Redrield
Maintainer: rnestler (ChloeColman)
Last Packager: rnestler
Votes: 74
Popularity: 0.63
First Submitted: 2017-08-15 23:19 (UTC)
Last Updated: 2024-04-02 12:19 (UTC)

Dependencies (5)

Required by (0)

Sources (1)

Pinned Comments

Latest Comments

1 2 3 4 5 6 7 Next › Last »

rnestler commented on 2023-09-28 17:56 (UTC)

I've adopted the Heroku-cli-bin package, I'd be happy to pitch in here as well if you're looking for someone to (help) maintain!

Sure! I'll add you as a maintainer.

ChloeColman commented on 2023-08-17 17:00 (UTC)

I've adopted the Heroku-cli-bin package, I'd be happy to pitch in here as well if you're looking for someone to (help) maintain!

Lulzagna commented on 2023-07-05 14:17 (UTC)

Cannot build with yarn-berry, which makes sense as all commands in the PKGBUILD assume yarn v1. It looks like Arch treats yarn-berry as being synonymous with yarn, which is not true at all.

If you have trouble building this package, make sure yarn -v returns v1. If it doesn't, uninstall your yarn dependency and install yarn and try again.

rnestler commented on 2022-12-10 14:32 (UTC)

I took over maintenance of the package and pushed an update to 7.76.1. Let me know if you have any issues.

Also let me know if you want to help maintaining the package, then I can add you as a co-maintainer.

rnestler commented on 2022-10-28 13:55 (UTC)

@sampsoncrowley I'd we willing to help maintain the package. Can you add me as a co-maintainer?

ArchRob commented on 2022-06-13 19:03 (UTC)

Since this has been flagged as out-of-date for a while, I've been patching the PKGBUILD file manually and running makepkg -si whenever the new updates are released. Here's the patch for 7.60.2:

--- PKGBUILD.old    2022-06-13 13:56:19.830499649 -0500
+++ PKGBUILD    2022-06-13 13:47:11.109997946 -0500
@@ -5,9 +5,9 @@
 # Github Contributor: Joey Dumont <>

 pkgdesc="CLI to manage Heroku apps and services with forced auto-update removed"
  1. Pull down the repo: `git clone
  2. Enter the repo dir: cd heroku-cli
  3. Save the patch above to a file called PKGBUILD.patch
  4. Apply the patch with patch -u -b PKGBUILD -i PKGBUILD.patch
  5. Run makepkg -si

That should be all you need to install the latest 7.60.2.

qark commented on 2022-04-02 22:06 (UTC)

PKGBUILD uses npx tool, should have npm as make dependency.

sampsoncrowley commented on 2022-04-02 16:46 (UTC)

Hi guys, sorry again that it's been a while since there's been a new release. I moved houses, and only just now got my arch box out unpacked. I've been only using my work laptop until recently. will get a release out today

bobpaul commented on 2022-01-07 18:45 (UTC) (edited on 2022-01-07 19:42 (UTC) by bobpaul)

Edit Nevermind. I think this is my issue to sort out. I built the package on another machine and was able to install and run that here.

I'm getting this. I tried switching from nodejs to nodejs-lts-gallium same issue.

$ heroku

SyntaxError: Invalid or unexpected token
    at Object.compileFunction (node:vm:352:18)
    at wrapSafe (node:internal/modules/cjs/loader:1031:15)
    at Module._compile (node:internal/modules/cjs/loader:1065:27)
    at Object.Module._extensions..js (node:internal/modules/cjs/loader:1153:10)
    at Module.load (node:internal/modules/cjs/loader:981:32)
    at Function.Module._load (node:internal/modules/cjs/loader:822:12)
    at Module.require (node:internal/modules/cjs/loader:1005:19)
    at require (node:internal/modules/cjs/helpers:102:18)
    at Object.<anonymous> (/usr/lib/heroku/node_modules/@oclif/command/lib/index.js:4:16)
    at Module._compile (node:internal/modules/cjs/loader:1101:14)

sampsoncrowley commented on 2021-07-09 22:01 (UTC)

Sorry for the late release of 7.56.0; the fact that it was released got buried in my inbox under a stack of work