Package Details: hugo-git v0.54.0.r1.g5383fe458c0c-2

Git Clone URL: https://aur.archlinux.org/hugo-git.git (read-only, click to copy)
Package Base: hugo-git
Description: Fast and Flexible Static Site Generator in Go
Upstream URL: https://gohugo.io/
Keywords: blog
Licenses: Apache
Conflicts: hugo
Provides: hugo
Submitter: premysl
Maintainer: navigaid
Last Packager: SamWhited
Votes: 6
Popularity: 0.56
First Submitted: 2015-05-14 02:58 (UTC)
Last Updated: 2019-02-01 18:02 (UTC)

Dependencies (4)

Required by (5)

Sources (1)

Latest Comments

1 2 Next › Last »

dr460nf1r3 commented on 2022-04-02 19:40 (UTC)

Directory man/ does not exist, creating... Generating Hugo man pages in man/ ... Done. Error: unknown flag: --type

SamWhited commented on 2019-02-01 18:02 (UTC)

Hi all,

I am now using the stable package in community/hugo, so I likely won't notice breaking changes to this package. Because of this, I am choosing to abandon it so that someone who uses it and will update it regularly can take over maintaining it.

HaoZeke commented on 2018-09-01 10:51 (UTC)

Currently broken:

with sha512sums...
    hugo ... Skipped
==> Cleaning up...
==> Making package: hugo-git v0.44.r3.g2f2bc7ff-1 (Sat 01 Sep 2018 04:13:19 PM IST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating hugo git repo...
Fetching origin
==> Validating source files with sha512sums...
    hugo ... Skipped
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Creating working copy of hugo git repo...
Cloning into 'hugo'...
done.
==> Starting prepare()...
==> Starting pkgver()...
==> Updated version: hugo-git v0.48.r14.gbcbe57c6-1
==> Sources are ready.
==> Making package: hugo-git v0.48.r14.gbcbe57c6-1 (Sat 01 Sep 2018 04:13:23 PM IST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting pkgver()...
==> Starting build()...
/home/haozeke/.cache/yay/hugo-git/PKGBUILD: line 38: cd: /home/haozeke/.go/src/github.com/gohugoio/hugo: No such file or directory
==> ERROR: A failure occurred in build().
    Aborting...
Error making: hugo-git

bclemens commented on 2018-07-14 23:39 (UTC) (edited on 2018-07-14 23:39 (UTC) by bclemens)

Requested package to be orphaned and adopted it. Brought it up to speed with with @jlichtblau's PKGBUILD from the community repo and @StephenBrown's specs.

Cheers

StephenBrown2 commented on 2018-07-06 19:13 (UTC) (edited on 2018-07-06 19:14 (UTC) by StephenBrown2)

Just a heads up, the next release (0.43) due on Monday (2018-07-09) will need HUGO_BUILD_TAGS=extended added to the mage command in build().

I saw an opportunity to update the PKGBUILD to bring it more in line with the community/hugo package, as several things were out of date.

Here's the diff, which works for me:

diff --git c/PKGBUILD w/PKGBUILD
index 33cdbc5..bce11c1 100644
--- c/PKGBUILD
+++ w/PKGBUILD
@@ -3,41 +3,47 @@

pkgname=hugo-git _pkgname=hugo -pkgver=v0.15.r3.g26af48a +pkgver=v0.43.DEV.0EFD3748 pkgrel=1 pkgdesc="Fast and Flexible Static Site Generator in Go" -arch=('x86_64' 'i686' 'arm') -url="http://hugo.spf13.com/" +arch=('x86_64') +url="https://gohugo.io/" conflicts=('hugo') provides=('hugo') options=('!strip') license=('Apache') -makedepends=('go' 'git' 'mercurial') -source=('git+https://github.com/spf13/hugo.git') +depends=('glibc') +makedepends=('go-pie' 'git') +optdepends=('pygmentize: syntax-highlight code snippets') +source=('git+https://github.com/gohugoio/hugo.git') sha512sums=('SKIP')

pkgver() { - cd "$srcdir/$_pkgname" + cd "${srcdir}/${_pkgname}" ( set -o pipefail git describe --long --tags 2>/dev/null | sed 's/([^-]*-g)/r\1/;s/-/./g' || printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" ) }

-build() { - cd "$srcdir/$_pkgname" - - # Force our own git checkout - export GOPATH="$srcdir" - mkdir -p "$GOPATH/src/github.com/spf13" - ln -s pwd "$GOPATH/src/github.com/spf13/hugo" +prepare() { + cd "${srcdir}/${_pkgname}" + export GOPATH="${srcdir}" + export PATH="${PATH}:${srcdir}/bin" + install -d "${GOPATH}/src/github.com/gohugoio" + cp -a "$(pwd)" "${GOPATH}/src/github.com/gohugoio/hugo" +}

  • go get -d -v github.com/spf13/hugo
  • go build +build() {
  • cd "${GOPATH}/src/github.com/gohugoio/hugo"
  • go get -u github.com/golang/dep/cmd/dep
  • dep ensure
  • go get github.com/magefile/mage
  • HUGO_BUILD_TAGS=extended mage hugo }

package() { - cd "$srcdir/$_pkgname" - install -Dm755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname" - install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$_pkgname/LICENSE" + cd "${GOPATH}/src/github.com/gohugoio/hugo" + install -Dm755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}" + install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE" }

strubbl commented on 2018-06-13 13:42 (UTC)

can you please fix the license issue @vorot93 ?

strubbl commented on 2018-04-23 08:42 (UTC) (edited on 2018-04-23 08:44 (UTC) by strubbl)

yes, LICENSE.md has been removed: https://github.com/gohugoio/hugo/issues/4623

License can be found in the file LICENSE now: https://github.com/gohugoio/hugo/blob/master/LICENSE

lisu_ml commented on 2018-04-20 20:07 (UTC)

package() fails with:

install: cannot stat 'LICENSE.md': No such file or directory

m4ng0squ4sh commented on 2016-08-29 06:56 (UTC)

Please add the pygmentize package as optional dependency.