Package Details: hybrid-encoder 20220320-1

Git Clone URL: https://aur.archlinux.org/hybrid-encoder.git (read-only, click to copy)
Package Base: hybrid-encoder
Description: A very complete gui for video encoding
Upstream URL: http://www.selur.de/
Licenses: custom
Submitter: whynothugo
Maintainer: JohnyRi
Last Packager: JohnyRi
Votes: 44
Popularity: 0.26
First Submitted: 2011-06-17 05:56 (UTC)
Last Updated: 2022-03-30 15:41 (UTC)

Dependencies (29)

Required by (0)

Sources (4)

Latest Comments

FabioLolix commented on 2022-04-16 20:27 (UTC)

telxcc-git no longer exist

damian101 commented on 2021-09-21 21:08 (UTC)

@JohnyRi Without mplayer installed, it crashes as soon as I open a video or audio file, which makes the program unusable.

geekborg commented on 2021-09-20 11:03 (UTC)

@JohnyRi : OK you're right. My Mediainfo (CLI version) was not installed. I installed it, now it works. I think next time it should be automatically installed as a dependency.

JohnyRi commented on 2021-09-20 10:44 (UTC)

damian101: I left almost everything as optional as not all features are always required. When exactly does it crash? geekborg: Sorry I cannot test it with DVD right now, but just a quick check: do you have mediainfo installed? Did you try to replace the ./mediainfo with /usr/bin/mediainfo in Config>Tools? I cannot alter the program configuration.

geekborg commented on 2021-09-20 07:11 (UTC)

Error when loading a DVD disc : Couldn't find an absolute path for Mediainfo Mediainfo DelayGrabber created an empty call!

damian101 commented on 2021-08-28 17:05 (UTC) (edited on 2021-09-20 13:50 (UTC) by damian101)

Hybrid crashes for me when mplayer is not installed, error message Path to mpv is empty!, MPV support seems to be buggy.

Maybe it should not be an optional dependency

Win8Error commented on 2020-11-10 01:27 (UTC)

And how i can enable Vapoursynth Support?

In the filtering Tab just stands "Support: no XSynth" ...

JohnyRi commented on 2020-08-08 09:31 (UTC)

The author dropped the upx compression of the package, which resolved the SEGFAULT issue on ArchLinux. The package was updated.

bitspyer commented on 2020-07-31 17:18 (UTC)

If you decompress the latest Hybrid Binary with upx (upx -d Hybrid), it works. It seems that there are some Problems with upx compressor under Ubuntu 18.04 LTS

JohnyRi commented on 2020-05-06 14:22 (UTC)

According to the information provided by Selur in this post, the file, currently available for download is probably static binary build for the Ubuntu package.

If you need to have the latest version, please download the zip, from this post. I will upload the new version when it's available.

As for vapoursynth the repository, mentioned by the author is intended for ubuntu. I have no idea if it can be enabled in the different distro. Arch users should have the last version of vapoursynth installed already.

JohnyRi commented on 2020-05-03 10:49 (UTC)

Sorry, I am currently not able to compile the new version without a segmentation fault right after startup.

I will try to get more info and come with a working update.

kayaksan commented on 2020-05-02 21:27 (UTC)

How to enable VapourSynth with this package?

tempomolto commented on 2020-02-18 07:58 (UTC)

The new md5 is '1cee0d5981827f1750b20b33dd1ebb47' for Hybrid_20200217_64bit_binary_qt551.zip

bitspyer commented on 2019-11-20 15:02 (UTC)

The Error { FilteringModel get->found no field videoHandling } was a missing dependancy for vapoursynth (Selur, developer of Hybrid, told me).

Try to install it and check again, if the error is gone.

eliminater74 commented on 2019-11-14 13:26 (UTC) (edited on 2019-11-14 14:09 (UTC) by eliminater74)

Same Error: { FilteringModel get->found no field videoHandling } In your ver:190930: at least for me.. even tried to uninstall and reinstall same thing....... going to try even older version and see if that fixes it..

Edit: Only one I was able to get fully working without that above Error was this one: https://www.videohelp.com/download/Hybrid_190827_64bit_binary_qt551.zip and all under it... but anything above that caused that above error....

JohnyRi commented on 2019-11-13 16:29 (UTC) (edited on 2019-11-13 16:30 (UTC) by JohnyRi)

Sorry, but I am currently not able to fix that. The newest version 191103 seems to have some kind of problem. After upgrading and attempting to run Hybrid I am getting the following error no matter if the vapoursynth package is installed or not:

FilteringModel get->found no field videoHandling

zsh: segmentation fault (core dumped) Hybrid

I posted this error to Selur here: https://forum.selur.net/Thread-FilteringModel-get-found-no-field-videoHandling The developer looked into it and the bug is fixed in the development version. I'll update this package when the next major version is released.

Meanwhile either download the previous version manually (https://www.videohelp.com/software?d=Hybrid_190930_64bit_binary_qt551.zip) or wait until a new version is released.

bitspyer commented on 2019-11-13 07:43 (UTC) (edited on 2019-11-13 07:45 (UTC) by bitspyer)

The Downloadlink from PKGBUILD doesnt work. The File was too small (aprox 100kb) And also on Videohelp, as well on the Developer Site, there is a new Version.

And maybe it would help to put aur/vapoursynth as required dependancy

bitspyer commented on 2019-11-11 10:13 (UTC) (edited on 2019-11-11 10:16 (UTC) by bitspyer)

Current Zip (190827_64bit_binary_qt551.zip) isn't available. There is a new version available : 191103_64bit_binary_qt551.zip

Marked Package as out-of-date

JohnyRi commented on 2018-06-07 01:58 (UTC)

Fixed. Next time, please flag the package as out-of-date.

Thank you

ggrub commented on 2018-06-06 20:00 (UTC) (edited on 2018-06-06 20:01 (UTC) by ggrub)

curl: (22) The requested URL returned error: 404 Not Found http://www.selur.de/sites/default/files/hybrid_downloads/Hybrid_180525_64bit_binary_qt521.zip

mozo commented on 2018-05-26 12:23 (UTC) (edited on 2018-05-26 15:25 (UTC) by mozo)

It doesn't start for me:

https://pastebin.com/fUkbmDNt

It stucks on "updating tool versions,..." forever.

What am I missing?

Edit: It actually start but is hidden. I understand it when I want to turn off the PC and the system asked me if I want to exit Hybrid. Than it show itself...

JohnyRi commented on 2018-02-10 09:20 (UTC)

Hi, I am sorry for the delay. My account was deleted from authors forum so I didn't receive a notification about a new version.

quijoT commented on 2018-02-06 20:10 (UTC)

Hey! package is not working. pkgver must be 180203 and md5sum must be 0c6059ba86a3e2b88f68865caa6e57ac... Thanks!

JohnyRi commented on 2017-12-27 04:22 (UTC)

Thank you, the package was updated according to your suggestions.

FabioLolix commented on 2017-12-27 00:14 (UTC)

This package is missing the license, you can copy from http://www.selur.de/licence and put it in a text file and install it in ${pkgdir}/usr/share/licenses/${pkgname}

The 'if then' for selecting source=() is not compliant and not needed since this package support only x86_64, for multiple architetures use source_x86_64=() source_i686=() and so on

and please delete the multiple md5sums=()

dark-saber commented on 2016-12-28 14:56 (UTC)

Hi, could you please change the dependency from delaycut-git to delaycut, because I've renamed that package recently.

kfgz commented on 2015-05-06 11:56 (UTC)

I'm disownig this package. Feel free to adpot.

kfgz commented on 2015-02-09 17:38 (UTC)

Fixed. Thx.

francoismelchior commented on 2015-02-09 14:46 (UTC)

Hi I would like to say you that the license is not correct: it is a closed source freeware. In http://forum.doom9.org/showthread.php?t=153035 we can read: "there's no specific plan when and if I release the source code. (If/When I stop developing Hybrid I will probably release the code under lgpl.)". License is here: http://www.selur.de/licence

djcj commented on 2015-01-23 10:41 (UTC)

You can add flac to the optional list. Hybrid supports flaccl and regular flac.

kfgz commented on 2014-11-13 07:35 (UTC)

Sort of fixed ;)

FiyreWyrkz commented on 2014-11-13 06:04 (UTC)

Seem to have issues with the source. Have tried a few times haven't looked into pkgbuild to check the link myself. ==> Retrieving sources... -> Downloading Hybrid_141109_2_64bit_binary_qt521.zip... % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0curl: (22) The requested URL returned error: 404 Not Found ==> ERROR: Failure while downloading Hybrid_141109_2_64bit_binary_qt521.zip Aborting... ==> ERROR: Makepkg was unable to build hybrid-encoder.

kfgz commented on 2014-11-11 10:00 (UTC)

Divx265 package created. Have fun!

djcj commented on 2014-11-11 02:14 (UTC)

Hybrid now supports DivX265 which has recently been ported to Linux: http://labs.divx.com/divx265 So maybe someone wants to make a package?

commented on 2014-11-03 20:38 (UTC)

Is required and FLVExtractCL from https://github.com/sherpya/FLVExtractCL and avs2yuv from https://github.com/XhmikosR/avs2yuv

commented on 2014-11-03 20:22 (UTC)

Is required and FLVExtractCL from https://github.com/sherpya/FLVExtractCL

djcj commented on 2014-07-28 02:33 (UTC)

I made a package for Ubuntu which is basically just a script that automatically checks for the latest version and downloads and saves it into the home folder. The tools can be installed all at once through a meta-package, if someone likes that. Qt4.8, 4.6 and 5.x versions can be installed simultaneously. Maybe this would be useful for the AUR. To get the source, just follow the Ubuntu repository download link on Selur's homepage.

DaveCode commented on 2014-06-21 08:08 (UTC)

Now that's service...thank you.

kfgz commented on 2014-06-18 13:26 (UTC)

You are right. It's a -bin package and some dependencies should be optional. I'll modify this package very soon.

DaveCode commented on 2014-06-18 00:16 (UTC)

I wonder whether a sort of -bin or optdepends variation on this tool would be at all possible. I am too scared to install it. It has so many AUR deps! I thought I kept pretty complete multimedia libs, but look at all the stuff this tool asks to install! AUR Packages (12): aur/libqxt aur/aften aur/neroaacenc aur/tsmuxer aur/mp4fpsmod aur/dcaenc aur/delaycut-git aur/telxcc-git aur/bdsup2subpp-git aur/framecounter aur/kvazaar-git aur/hybrid-encoder Repo Packages (6): community/fdkaac community/libfdk-aac extra/qt5-declarative extra/qt5-multimedia extra/qt5-xmlpatterns extra/yasm

kfgz commented on 2014-06-15 14:29 (UTC)

Fixed.

kfgz commented on 2014-06-14 20:21 (UTC)

Yes it's an upstream bug. I'm working on it with the author (Selur). I hope it will be fixed soon.

PelPix commented on 2014-06-13 21:46 (UTC)

The new version fails to find mediainfo. There seems to be no reason why. Mediainfo is installed and the previous version works fine. Upstream bug?

kfgz commented on 2014-05-20 06:40 (UTC)

Fixed.

z1lt0id commented on 2014-05-20 01:56 (UTC)

404 not found. Hybrid_140428_binary_qt521.zip does not exist.

Bastiencade commented on 2014-04-04 20:14 (UTC)

Works great on Manjaro linux (Arch based)! Thanks!

kfgz commented on 2014-02-16 11:50 (UTC)

https://wiki.archlinux.org/index.php/Yaourt

luluhiyee commented on 2014-02-16 03:56 (UTC)

can you tell me how?

kfgz commented on 2014-02-15 10:34 (UTC)

Now you can ;)

luluhiyee commented on 2014-02-15 03:27 (UTC)

Hi! How can I install this package? Thanks

kfgz commented on 2013-10-18 17:37 (UTC)

Fixed. Thanks.

sl1pkn07 commented on 2013-10-18 17:31 (UTC)

kbuildsycoca4(30905) KConfigGroup::readXdgListEntry: List entry Categories in "/usr/share/applications/hybrid.desktop" is not compliant with XDG standard (missing trailing semicolon). greetings

PelPix commented on 2013-10-14 00:28 (UTC)

Also: https://aur.archlinux.org/packages/fdkaac/

PelPix commented on 2013-10-11 23:29 (UTC)

I've created an x264-10bit package that tracks to the main x264 package in extra and has the right naming scheme for Hybrid. If you want, you could add it as an opt dependency for seamless integration. https://aur.archlinux.org/packages/x264-10bit/

z1lt0id commented on 2013-09-17 01:47 (UTC)

130916 is now available.

theflyingfool commented on 2013-06-10 16:41 (UTC)

changing the pkgver to 130608 will allow sources to be downloaded as of june 10th

commented on 2013-04-19 08:39 (UTC)

The requested page "/sites/default/files/hybrid_downloads/Hybrid_130401_binary.zip" could not be found. I can't get the souces, either through yaourt or manually

blackhole commented on 2013-02-20 23:37 (UTC)

I had to install telxcc manually. Now is fine.

kfgz commented on 2013-02-20 17:25 (UTC)

It's probably some yaourt bug.

kfgz commented on 2013-02-20 17:22 (UTC)

No. It's not :P https://aur.archlinux.org/packages/telxcc-git/

blackhole commented on 2013-02-20 16:04 (UTC)

telxcc missing on aur.

kfgz commented on 2013-02-03 13:40 (UTC)

Delaycut is in AUR https://aur.archlinux.org/packages/delaycut-git/

DarioP commented on 2013-02-03 12:00 (UTC)

I have a problem with delaycut. It seems it does not exists anymore :|

kfgz commented on 2013-01-09 14:47 (UTC)

Updated & fixed.

sl1pkn07 commented on 2013-01-09 00:37 (UTC)

Hybrid not need lib32 anymore (64bit version) http://paste.ubuntu.com/1511420

commented on 2012-07-01 19:21 (UTC)

new version 2012.06.28 is available

kfgz commented on 2012-04-18 15:02 (UTC)

Fixed.

commented on 2012-04-17 21:55 (UTC)

hybrid-encoder E: Dependency lib32-qt detected and not included (libraries ['usr/lib32/libQtCore.so.4'] needed in files ['usr/bin/FrameCounter'])

cioby23 commented on 2012-03-23 08:16 (UTC)

There is a new version hybrid-encoder-120319. Please update it. The current PKGBUILD needs to be updated because it fails to build properly. I had to edit the pkgver and md5 checksum manually to get it work.

kfgz commented on 2012-02-26 21:55 (UTC)

Please read this http://forum.selur.de/post1061.html#p1061 https://bugs.archlinux.org/task/28668

blackhole commented on 2012-02-26 17:43 (UTC)

Log Messages Missing avsInfo got ignored,.. (only needed for avisynth input) ->removing neroAAcEnc support,.. ->removing qaac support,.. ->removing x264 support,.. Removing x264 support?

commented on 2012-02-26 02:47 (UTC)

new version: 120221 47945889c3d912b8f078a0648c7466a6 Hybrid_120221_64bit_binary.zip d64f5008b9e6181d606238fb13da2158 Hybrid_120221_binary.zip

whynothugo commented on 2012-01-24 20:03 (UTC)

I'll no longer be updating hybrid, since I don't use it. I'm sure someone else is bound to pick it up. :)

artemklevtsov commented on 2011-12-28 16:14 (UTC)

Now Hybdrid reqiure a 2 new depends: dcaenc (exist in the AUR) and delaycut (named delaycut-git in the AUR). Also you should add 'mencoder' in depends array.

commented on 2011-10-10 13:06 (UTC)

You may add ''mencoder'' to the dependencies as if you have mplayer2 (which provides ''mplayer'') you won't have installed ''mencoder'' but it's required to use Hybrid with XviD streams. And about ''avsInfo'', I want recall there were some Linux build somewhere (I guess they were only x86)

whynothugo commented on 2011-08-23 17:39 (UTC)

Sorry about this, forgot to re-build the package after I made that last change to the PKGBUILD.

artemklevtsov commented on 2011-08-21 03:45 (UTC)

You should fix desktop file name in the PKGBUILD: install -D -m644 hybrid.desktop "${pkgdir}/usr/share/applications/hybrid.desktop"

whynothugo commented on 2011-07-23 18:10 (UTC)

What issue are you having with mkvextract? It works fine for me (I use it to extract subs).

artemklevtsov commented on 2011-07-23 04:27 (UTC)

You should add mplayer2 to the conflicts array. With it mkvextract work not correctly.

commented on 2011-06-26 17:37 (UTC)

Version dated 23 June is running well. I'm using x86_64, if this is important.

commented on 2011-06-26 17:22 (UTC)

I have the following occurs: >> $ Hybrid >> Hybrid: error while loading shared libraries: libQtDBus.so.4: cannot open shared object file: No such file or directory >> $ ll /usr/lib/libQtDBus.so.4 >> lrwxrwxrwx 1 root root 18 Jun 9 10:17 /usr/lib/libQtDBus.so.4 -> libQtDBus.so.4.7.3* >> $ LD_PRELOAD="/usr/lib/libQtDBus.so.4" Hybrid >> ERROR: ld.so: object '/usr/lib/libQtDBus.so.4' from LD_PRELOAD cannot be preloaded: ignored. >> Hybrid: error while loading shared libraries: libQtDBus.so.4: cannot open shared object file: No such file or directory >> $ pacman -Qi qt >> Name : qt >> Version : 4.7.3-3 >> Build Date : Thu Jun 9 10:17:59 2011 >> Install Date : Sun Jun 12 19:13:29 2011 What's wrong?

whynothugo commented on 2011-06-23 16:24 (UTC)

This is becoming a bit TOO frequent. :P Hitting the "Flag out of date" button is enough for me to get an e-mail, no need to comment as well :)

artemklevtsov commented on 2011-06-23 14:56 (UTC)

New version is out. Again.

blackhole commented on 2011-06-22 21:44 (UTC)

Last x264 is now fine with Hybrid-encorder. No need for x264-git.

whynothugo commented on 2011-06-21 20:09 (UTC)

Updated version, Added the icon, Update license (acording to website, source will be release as LGPL when done) Thanks to unikum for almost everything :)

artemklevtsov commented on 2011-06-21 19:55 (UTC)

Updated PKGBUILD: http://archlinux.pastebin.fr/11726 hybryd-desktop: http://archlinux.pastebin.fr/11724

artemklevtsov commented on 2011-06-21 10:58 (UTC)

Yes, it's typo: hybrid.png

commented on 2011-06-21 10:03 (UTC)

Attention, it is Hybrid and not Hybryd (icon name)

artemklevtsov commented on 2011-06-21 09:28 (UTC)

rev 2011.06.20.1 is out. Fix license please: freeware or custom (not GPL). I extract icon from win32 installer: http://ompldr.org/vOTVzbA You may put it to the package archive. Сhange image resolution if necessary. Also add following raw in the desktop file: Icon=/usr/share/pixmaps/hybryd.png

artemklevtsov commented on 2011-06-18 23:04 (UTC)

Thanks. In this version added new dependency - mp4fpsmod. It is not in AUR.

whynothugo commented on 2011-06-18 22:33 (UTC)

Updated to latest version, added desktop entry, but icon is missing (the application doesn't have one).

artemklevtsov commented on 2011-06-18 21:14 (UTC)

rev 2011.06.18.1 is out.

artemklevtsov commented on 2011-06-18 07:09 (UTC)

[Desktop Entry] Name=Hybrid Comment=Gui for Video Encoding Exec=Hybrid Icon=??? Terminal=false Type=Application Categories=Application;AudioVideo

artemklevtsov commented on 2011-06-18 06:15 (UTC)

You should add desktop file (that it appears in apps menu) for launch this program.