Package Details: insync 1.5.7-3

Git Clone URL: https://aur.archlinux.org/insync.git (read-only)
Package Base: insync
Description: An unofficial Google Drive client that runs on Linux, with support for various desktops
Upstream URL: https://www.insynchq.com/downloads
Licenses: custom:insync
Submitter: xzy3186
Maintainer: thenaterhood
Last Packager: thenaterhood
Votes: 250
Popularity: 5.223181
First Submitted: 2012-09-07 17:45
Last Updated: 2019-08-01 03:17

xzy3186 commented on 2012-09-17 07:01

@frat
Ok, maybe I can try to install this app under pure xfce environment at some time to see the error for myself. But as a first
guess, I am afraid you are running the app with some dependencies missing. Can you try to install libappindicator3 from AUR
before running the app again?

frat commented on 2012-09-17 06:56

replace with zip in rpm-package cannot work out too.

frat commented on 2012-09-17 06:39

$ insync
OK: gdata imported
importing client...
loading client...
importing core1...
Traceback (most recent call last):
File "<string>", line 6, in <module>
File "__main__.py", line 128, in <module>
File "__main__insync__.py", line 25, in <module>
File "isyncd/client.py", line 4, in <module>
File "isyncd/requester.py", line 2, in <module>
File "isyncd/clienthttp.py", line 8, in <module>
File "gevent/socket.py", line 784, in <module>
IOError: zipimport: can not open file /usr/lib/insync/library.zip

i use xfce

xzy3186 commented on 2012-09-17 05:52

@frat

Another question is: from which command you get the IOError message?

xzy3186 commented on 2012-09-17 05:47

@frat

So you have tried to replace local library.zip with the file from amd64.deb directly, right? Hm, I can not reproduce
your error quickly as there is no x86_64 archlinux around me at present. I have one suggestion: instead of getting
library.zip from amd64.deb, could you have a try with rpm from following
gnome:
http://s.insynchq.com/builds/insync-beta-gnome-cinnamon-common-0.9.21-1.x86_64.rpm
or KDE:
http://s.insynchq.com/builds/insync-beta-kde-0.9.21-1.x86_64.rpm

By the way, which DE are you using?

frat commented on 2012-09-17 05:21

really weird. i replaced the library.zip with original file in the amd64.deb packgae,error stay the same.

frat commented on 2012-09-17 05:11

i checked /usr/lib/insync permission and ownership ,all files are set to root permission and ownership,and the library.zip size is 5.3m.

xzy3186 commented on 2012-09-17 04:25

@frat
It sounds very weird. But fortunately, 5.4m means the zip file itself is not corrupted.
Then could you check permission and ownership of all the files under /usr/lib/insync?

frat commented on 2012-09-17 03:16

ls: cannot access /usr/lib/insync/library.zip,: No such file or directory

but when i use ls /usr/lib/insync,output show :
bz2.so gevent.core.so libsqlite3.so.0
_codecs_cn.so greenlet.so libssl.so.1.0.0
_codecs_hk.so _heapq.so libtinfo.so.5
_codecs_iso2022.so insync libz.so.1
_codecs_jp.so _io.so _multibytecodec.so
_codecs_kr.so _json.so OpenSSL.crypto.so
_codecs_tw.so libbz2.so.1.0 OpenSSL.rand.so
Crypto.Cipher.AES.so libcrypto.so.1.0.0 OpenSSL.SSL.so
Crypto.Hash.SHA256.so libevent-2.0.so.5 py
Crypto.PublicKey._fastmath.so libexpat.so.1 pyexpat.so
Crypto.Util._counter.so libgcc_s.so.1 readline.so
_ctypes.so libgmp.so.10 simplejson._speedups.so
datetime.so library.zip _sqlite3.so
_elementtree.so libreadline.so.6 termios.so

library.zip exits.And i can see the file in the file manager too,size of the library.zip is 5.4m

xzy3186 commented on 2012-09-17 02:57

@frat
Could you paste your output of: ls -lh /usr/lib/insync/library.zip, please?