Package Details: ipe 7.2.7-2

Git Clone URL: https://aur.archlinux.org/ipe.git (read-only)
Package Base: ipe
Description: The extensible drawing editor
Upstream URL: http://tclab.kaist.ac.kr/ipe/
Licenses: GPL
Conflicts: ipe
Submitter: foxcub
Maintainer: foxcub
Last Packager: foxcub
Votes: 73
Popularity: 0.000352
First Submitted: 2007-01-02 01:58
Last Updated: 2017-10-11 16:20

Latest Comments

1 2 3 4 5 6 ... Next › Last »

hexchain commented on 2018-10-06 13:06

The upstream URL should be http://ipe.otfried.org/ ?

foxcub commented on 2017-10-11 16:20

Thanks for the fix, and thanks for reporting it upstream. I've pushed a new version of the package.

Michitux commented on 2017-10-11 14:48

Since glibc >= 2.26 does not include xlocale.h anymore, ipe does not compile anymore. Adding

sed -i '/#include <xlocale.h>/d' ipelib/ipeplatform.cpp

directly before the first make invocation in the PKGBUILD fixes the problem for me. I have also reported this upstream: https://github.com/otfried/ipe-issues/issues/165

foxcub commented on 2016-09-22 18:28

Try now. The source must have changed. I've updated the md5sum.

muellner commented on 2016-09-22 07:13

I get the following error:

==> Validating source files with md5sums...
ipe-7.2.6-src.tar.gz ... FAILED
b714decd7d5b.tar.gz ... Passed
ipe.bash-completion ... Passed
config.patch ... Passed
==> ERROR: One or more files did not pass the validity check!

angelo commented on 2016-01-11 19:12

I've been otherwise occupied for a while.
Version 7.2.1 compiles and installs with no issue, even without adding -fPIC.

eolianoe - thanks for the instructions, which may be useful if this comes up again (the issue seems to affect several packages).

zhtlancer commented on 2016-01-05 21:30

@lianxiangru I met this problem before too. You can try add "export QT_SELECT=5" in build() section of PKGBUILD and see if it's fixed.

foxcub commented on 2016-01-05 06:49

I've updated the PKGBUILD to Ipe 7.2.1 and pushed some changes to IpePresenter. Let me know if it works now.

eolianoe commented on 2016-01-03 17:01

@angelo: Add -fPIC to CPPFLAGS before building IpePresenter

angelo commented on 2016-01-02 02:25

I'm having trouble compiling this with makepkg:

It seems that a -fPIC flag is required for compatibility with Qt. I'm not sure where/how to add the flag, or if a different approach is better to remove the need for this flag.

[code]
g++ mainwindow.cpp -c -D_FORTIFY_SOURCE=2 -I ../ipe-7.1.9/src/include -I ../ipe-7.1.9/src/ipecanvas -I/usr/include/qt/QtGui -I/usr/include/qt/QtWidgets -I/usr/include/qt/QtCore -I/usr/include/qt
In file included from /usr/include/c++/5.3.0/x86_64-unknown-linux-gnu/bits/os_defines.h:39:0,
from /usr/include/c++/5.3.0/x86_64-unknown-linux-gnu/bits/c++config.h:482,
from /usr/include/c++/5.3.0/cstdio:41,
from ../ipe-7.1.9/src/include/ipebase.h:35,
from ../ipe-7.1.9/src/include/ipelib.h:37,
from ../ipe-7.1.9/src/ipecanvas/ipecanvas.h:35,
from ../ipe-7.1.9/src/ipecanvas/ipecanvas_qt.h:35,
from mainwindow.h:36,
from mainwindow.cpp:32:
/usr/include/features.h:328:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
# warning _FORTIFY_SOURCE requires compiling with optimization (-O)
^
In file included from /usr/include/qt/QtGui/qwindowdefs.h:37:0,
from /usr/include/qt/QtWidgets/qwidget.h:37,
from /usr/include/qt/QtWidgets/QWidget:1,
from ../ipe-7.1.9/src/ipecanvas/ipecanvas_qt.h:37,
from mainwindow.h:36,
from mainwindow.cpp:32:
/usr/include/qt/QtCore/qglobal.h:1067:4: error: #error "You must build your code with position independent code if Qt was built with -reduce-relocations. " "Compile your code with -fPIC (-fPIE is not enough)."
# error "You must build your code with position independent code if Qt was bui
^
Makefile:36: recipe for target 'mainwindow.o' failed
make: *** [mainwindow.o] Error 1
==> ERROR: A failure occurred in build().
Aborting...
[/code]