Package Details: ipe 7.2.24-1

Git Clone URL: https://aur.archlinux.org/ipe.git (read-only, click to copy)
Package Base: ipe
Description: The extensible drawing editor
Upstream URL: http://ipe.otfried.org/
Licenses: GPL
Conflicts: ipe
Submitter: foxcub
Maintainer: foxcub
Last Packager: foxcub
Votes: 76
Popularity: 0.000667
First Submitted: 2007-01-02 01:58
Last Updated: 2021-04-07 14:31

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 10 11 12 ... Next › Last »

vesath commented on 2014-12-28 16:45

The md5sum of http://downloads.sourceforge.net/project/ipe7/ipe/7.1/ipe-7.1.6-src.tar.gz is da0a5f075ede86c529dd4d9d8c5d57ca; could you fix the PKGBUILD accordingly?

runical commented on 2014-12-02 15:06

@foxcub: That would be very much appreciated. Thank you very much in advance.

foxcub commented on 2014-12-02 14:46

It seems the tools have migrated to GitHub [1]. I'll update the PKGBUILD later this week.

[1] https://github.com/otfried/ipe-tools

runical commented on 2014-12-02 14:42

Hello hello, I'm getting a download error for figtoipe-20091205.tar.gz. After inspection, it seems that the tools folder is no longer a part of the online repository and thus these files are no longer available. What are these files for?

foxcub commented on 2014-04-27 18:41

Strange. Everything builds fine here. I'll wait until someone can confirm your report, or you have some more details on how to reproduce it before I investigate further.

Netsu commented on 2014-04-27 16:59

../../build/obj/ipescript/ipescript.o: In function `traceback':
/tmp/yaourt-tmp-netsu/aur-ipe/src/ipe-7.1.4/src/ipescript/ipescript.cpp:61: undefined reference to `lua_callk'
../../build/obj/ipescript/ipescript.o: In function `main':
/tmp/yaourt-tmp-netsu/aur-ipe/src/ipe-7.1.4/src/ipescript/ipescript.cpp:182: undefined reference to `lua_setglobal'
../../build/obj/ipescript/ipescript.o: In function `setup_globals':
/tmp/yaourt-tmp-netsu/aur-ipe/src/ipe-7.1.4/src/ipescript/ipescript.cpp:88: undefined reference to `lua_getglobal'
/tmp/yaourt-tmp-netsu/aur-ipe/src/ipe-7.1.4/src/ipescript/ipescript.cpp:148: undefined reference to `lua_setglobal'
../../build/obj/ipescript/ipescript.o: In function `main':
/tmp/yaourt-tmp-netsu/aur-ipe/src/ipe-7.1.4/src/ipescript/ipescript.cpp:190: undefined reference to `lua_pcallk'
../../build/obj/ipescript/lfs.o: In function `luaopen_lfs(lua_State*)':
/tmp/yaourt-tmp-netsu/aur-ipe/src/ipe-7.1.4/src/ipescript/lfs.cpp:715: undefined reference to `luaL_setfuncs'
/tmp/yaourt-tmp-netsu/aur-ipe/src/ipe-7.1.4/src/ipescript/lfs.cpp:716: undefined reference to `lua_setglobal'
../../build/lib/libipelua.so: undefined reference to `lua_tonumberx'
../../build/lib/libipelua.so: undefined reference to `lua_rawlen'


I tried forcing it use lua51 and lua52 but in both cases it fails with undefined references. Anything I could do?

holos commented on 2013-06-04 02:01

here is an updated PKGBUILD http://ix.io/5XZ

holos commented on 2013-06-04 01:39

on top of that, patching should be done in prepare()

TrialnError commented on 2013-04-26 17:09

PKGBuilds without a package() function are deprecated.
Also it's not adviced to reference $pkgdir in build()

So, the make install and install stuff should be in the package() function

https://wiki.archlinux.org/index.php/Creating_Packages#The_package.28.29_function

foxcub commented on 2013-03-07 21:42

erikw, why do you keep flagging this out-of-date?